summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-15 15:35:20 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-15 16:41:21 +0200
commit55c8acb08e1fee4813fe6901ad9477b7bb95d7ea (patch)
tree5c498826644e25a0a73f408447b642891a1a8f26
parentdev-python/pbr: Backwards transfer KEYWORDS (diff)
downloadgentoo-55c8acb08e1fee4813fe6901ad9477b7bb95d7ea.tar.gz
gentoo-55c8acb08e1fee4813fe6901ad9477b7bb95d7ea.tar.bz2
gentoo-55c8acb08e1fee4813fe6901ad9477b7bb95d7ea.zip
dev-python/pbr: Add python3.5
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/pbr/pbr-0.11.0.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/pbr/pbr-0.11.0.ebuild b/dev-python/pbr/pbr-0.11.0.ebuild
index 016e3d61f6c3..5b8cc65177ef 100644
--- a/dev-python/pbr/pbr-0.11.0.ebuild
+++ b/dev-python/pbr/pbr-0.11.0.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
@@ -58,6 +58,8 @@ python_prepare_all() {
python_test() {
# Note; removed tests pass once package is emerged,
# it's the suite's design that breaks form, not the tests' intended purpose
+ einfo "init tests"
testr init || die
+ einfo "Running tests"
testr run || die "Testsuite failed under ${EPYTHON}"
}