summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-15 09:04:37 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-15 10:34:04 +0200
commit5805b6b66c1014de78a261034ec15ce96a127776 (patch)
tree69f7a34dbce46aa8e1a6ec8f155f2e9393639d2d
parentdev-python/dask: Bump to 2021.5.0 (diff)
downloadgentoo-5805b6b66c1014de78a261034ec15ce96a127776.tar.gz
gentoo-5805b6b66c1014de78a261034ec15ce96a127776.tar.bz2
gentoo-5805b6b66c1014de78a261034ec15ce96a127776.zip
dev-python/asyncstdlib: Bump to 3.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/asyncstdlib/Manifest1
-rw-r--r--dev-python/asyncstdlib/asyncstdlib-3.9.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/asyncstdlib/Manifest b/dev-python/asyncstdlib/Manifest
index 9899598eb5fb..33b3fa606274 100644
--- a/dev-python/asyncstdlib/Manifest
+++ b/dev-python/asyncstdlib/Manifest
@@ -1 +1,2 @@
DIST asyncstdlib-3.9.1.gh.tar.gz 40224 BLAKE2B 8d1e564c9f5ac10c7f05dfa3933f695ae458685550fb67401f3bd0d1294ef0b170f5b385cdcf63c0096854538219a0dea77d4d80bd801f1a9b15f5ad3f2c562a SHA512 de7860d84cee7bfdc974a0677cc231323c86238bcb0bfd2f32a62b7356042aad647ee8d627393be35c5a134855d5f76967143ad8347df9d6258f46bc2b43a62a
+DIST asyncstdlib-3.9.2.gh.tar.gz 41963 BLAKE2B da40c23bacc58c1347aca94107e3026829d9b27645eddc47fc46a96cab4be7baa9ed3c31f6f0045b884130d4316394d6a0b6b44818b42b6e6c512c641847d556 SHA512 f5268451325b48b967747b5e1ffe4e773a5aae82c6d481781e6c95f483d972da2b3806c1117067256d22efaba1238787898667a6a50ac4b2512dac4b5343d2a2
diff --git a/dev-python/asyncstdlib/asyncstdlib-3.9.2.ebuild b/dev-python/asyncstdlib/asyncstdlib-3.9.2.ebuild
new file mode 100644
index 000000000000..65cb15dce8e5
--- /dev/null
+++ b/dev-python/asyncstdlib/asyncstdlib-3.9.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1
+
+DESCRIPTION="The missing async toolbox"
+HOMEPAGE="
+ https://github.com/maxfischer2781/asyncstdlib/
+ https://pypi.org/project/asyncstdlib/"
+SRC_URI="
+ https://github.com/maxfischer2781/asyncstdlib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' python3_7)"
+
+distutils_enable_tests pytest