summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-05-06 15:35:01 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-05-06 15:35:01 +0000
commit589e6d13957e724a0e46cd184ef8b93db7d6378b (patch)
tree58c1138fed94dd7a6f5ef6b7c83669f4581e4fc5
parent2020-05-06 14:38:57 UTC (diff)
parentdev-php/pecl-redis: Drop old (diff)
downloadgentoo-589e6d13957e724a0e46cd184ef8b93db7d6378b.tar.gz
gentoo-589e6d13957e724a0e46cd184ef8b93db7d6378b.tar.bz2
gentoo-589e6d13957e724a0e46cd184ef8b93db7d6378b.zip
Merge updates from master
-rw-r--r--app-text/nuspell/Manifest1
-rw-r--r--app-text/nuspell/nuspell-3.1.1.ebuild51
-rw-r--r--dev-php/igbinary/igbinary-3.1.2.ebuild2
-rw-r--r--dev-php/pecl-mailparse/pecl-mailparse-3.0.4.ebuild2
-rw-r--r--dev-php/pecl-redis/Manifest4
-rw-r--r--dev-php/pecl-redis/pecl-redis-3.1.6-r1.ebuild53
-rw-r--r--dev-php/pecl-redis/pecl-redis-4.2.0.ebuild59
-rw-r--r--dev-php/pecl-redis/pecl-redis-4.3.0.ebuild58
-rw-r--r--dev-php/pecl-redis/pecl-redis-5.0.2.ebuild52
-rw-r--r--net-misc/openntpd/openntpd-6.2_p3-r1.ebuild2
10 files changed, 55 insertions, 229 deletions
diff --git a/app-text/nuspell/Manifest b/app-text/nuspell/Manifest
index 44824bfdad3e..f9863ecdbfa6 100644
--- a/app-text/nuspell/Manifest
+++ b/app-text/nuspell/Manifest
@@ -1,2 +1,3 @@
DIST nuspell-3.0.0.tar.gz 403043 BLAKE2B b437012e4fb327f13d9ff0944dadf7e865c670daf153be00dd48e9d2fc01c87d410ebd5aeaa094f6446d3035346738010cdba961cfaada3751bedce264beaa6a SHA512 d9cd7dd276e2bca43dec3abaf11c5206695949b9fda8c9b86f2772cc7e8fa95bf17c685a2ef9ca87fe3c4f0b55f2fcb435bc21c187355f5e3fa35dcafab2c8c2
DIST nuspell-3.1.0.tar.gz 407196 BLAKE2B 688f6f59ba2f7bceaafe9a7cc707c008be93341e855ca60f07d6de67a626539693048af6f5ca40246ccc51e2573b76ba2bd4439aa9c0acb66a212bebd9219617 SHA512 a9bedfd6e2d77fd34d249cf7aa1fcb6bde5bced26f02f8a2dd860416a61488c9b7016a0df6015052fcccb272b342e6205db601107f46efa44c9d78ce261a826c
+DIST nuspell-3.1.1.tar.gz 379636 BLAKE2B 952cbe6f15221c0050f108b9f95718cc1d1ca9a94a7b15e0b6f2a53a92a2c95cf54f317b110bfc4b297943b9128bae8968a735ce68e7c752ff159359f4562f4b SHA512 239855051d9f49ba16913283090c4214a8f6a6cc290d359ab54014ff76fc297c131b67c6748bd1d4cdcec43c00dccc7f0c1bf8b07e06c9c648bff52ff193e096
diff --git a/app-text/nuspell/nuspell-3.1.1.ebuild b/app-text/nuspell/nuspell-3.1.1.ebuild
new file mode 100644
index 000000000000..d5c3f19e7d56
--- /dev/null
+++ b/app-text/nuspell/nuspell-3.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/3" # due to libnuspell.so.3
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-libs/icu"
+DEPEND="${RDEPEND}
+ doc? ( app-text/ronn )
+ test? ( >=dev-cpp/catch-2.3.0:0 )
+ >=dev-libs/boost-1.62[icu]"
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ rm -R external/Catch2/ || die
+ if ! use test ; then
+ rm -R external/hunspell/ || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users .'
+ einfo
+}
diff --git a/dev-php/igbinary/igbinary-3.1.2.ebuild b/dev-php/igbinary/igbinary-3.1.2.ebuild
index 4d37e24a0532..e56a7b7ca346 100644
--- a/dev-php/igbinary/igbinary-3.1.2.ebuild
+++ b/dev-php/igbinary/igbinary-3.1.2.ebuild
@@ -12,7 +12,7 @@ USE_PHP="php7-1 php7-2 php7-3 php7-4"
inherit php-ext-source-r3
-KEYWORDS="amd64 ~arm ~arm64 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 x86"
DESCRIPTION="A fast drop-in replacement for the standard PHP serialize"
HOMEPAGE="https://github.com/igbinary/igbinary"
diff --git a/dev-php/pecl-mailparse/pecl-mailparse-3.0.4.ebuild b/dev-php/pecl-mailparse/pecl-mailparse-3.0.4.ebuild
index 8984b2d35d87..d0c3ba6cd8c5 100644
--- a/dev-php/pecl-mailparse/pecl-mailparse-3.0.4.ebuild
+++ b/dev-php/pecl-mailparse/pecl-mailparse-3.0.4.ebuild
@@ -14,7 +14,7 @@ DOCS=( README.md )
inherit php-ext-pecl-r3
-KEYWORDS="amd64 ppc ppc64 ~x86"
+KEYWORDS="amd64 ppc ppc64 x86"
DESCRIPTION="PHP extension for parsing and working with RFC822 and MIME compliant messages"
LICENSE="PHP-3.01"
diff --git a/dev-php/pecl-redis/Manifest b/dev-php/pecl-redis/Manifest
index f1244d984b9c..6099de3b6998 100644
--- a/dev-php/pecl-redis/Manifest
+++ b/dev-php/pecl-redis/Manifest
@@ -1,6 +1,2 @@
-DIST redis-3.1.6.tgz 199920 BLAKE2B 00aa81cdbedc03b4a672a58be98d8f01d2076038622b9d1e9673c0628c096152f12f9f5ff540af639da73b4458fcb1fce9c1c8b49a95db48970bab07806ac8d0 SHA512 4263d150c93f11dd06587925ad9a3cd8fbba2e4a18b2f23e6adfaeb25d566a1c2d256551a50ae1b9c770fd0f9bc4c92f483c46d60be9d4f5b5ba056231b7d527
-DIST redis-4.2.0.tgz 235569 BLAKE2B 14089171b9654affeb8c2b3861a698a3ba8d6ac235238fed7e6799cf3f2f74b240facb408acbbc987cc2d5383f197564aa81d828bfe84f91fd1bbff8dbdf563c SHA512 b6325e5e1f9209a3431cbc236dab4578f796aa748481f9a3fcda6d297bf544b0f77269bc56c6e9ff32430dbe74bd08f6d22e9b04b0ecfb735aa562f680f56f8b
-DIST redis-4.3.0.tgz 241883 BLAKE2B 3f3ef7f67ba1167cb031e6816ee9f90d24eecc002064720e68a65bf8db16b0f826c90a5f3b7bed771f535aca8cbc9b62654fa2c234a42af8168baf0315a25c17 SHA512 30ce5863540485463704e6f90cff3a8d1f5bda34360c987e848ab290c8240f323b6eb2df1e90cc4c0922b3413652132d937488943f5db4e242c460c592da54ca
-DIST redis-5.0.2.tgz 243270 BLAKE2B 5c01dc23d5c86f407bddd6a54455f37427a5cae3786e393afc34fae23771062cae9cbe1b55a3c0578b5ecc1ada97328f63fe10e8e91af8fcd0f4b275850f0b50 SHA512 ea5601a520a95443abf5b2f17516ffe047ce50df721519a82b68124b9a406d52628697b486e37cd1ea2798a5ddce82549a516835a9d348925adedbdf5ef2d2b0
DIST redis-5.1.1.tgz 245205 BLAKE2B b7177be5282b081562a446b1b37c7b46ba0ef382e55f27989d5586346a10f842d050ee46e881e480ea6b768e1259458df565d02193eda13a95704cd5455c1ca2 SHA512 eb6aa538d2ae4115634fd5841e3ccccf788cad13b99e0485fb2af43def85e93328012e5cef66d1be4bdd494be6f68de329a066e41b710e434f94f3ed3401bfee
DIST redis-5.2.1.tgz 251570 BLAKE2B 297d6130469735a53f6dfb6ffea8c7c813363099eb76f25619f0cbb05cd06f5ecad9c0f30c370e33985523cf26488cf133aa0a48a99075bc6d5796309e3d914d SHA512 de90bf65cce0cb8c5ea28415e4f7bfff23c8bb3dc96ddca3158f94be2e4bd051e13ec3f34429b0e8ceb436096520e3998f544f377d5ef7d4d1df4edba7f66bc2
diff --git a/dev-php/pecl-redis/pecl-redis-3.1.6-r1.ebuild b/dev-php/pecl-redis/pecl-redis-3.1.6-r1.ebuild
deleted file mode 100644
index bbcdfa102de4..000000000000
--- a/dev-php/pecl-redis/pecl-redis-3.1.6-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PHP_EXT_NAME="redis"
-USE_PHP="php5-6 php7-0 php7-1 php7-2"
-DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
-MY_P="${PN/pecl-/}-${PV/_rc/RC}"
-PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
-PHP_EXT_S="${WORKDIR}/${MY_P}"
-
-inherit php-ext-pecl-r3
-
-DESCRIPTION="PHP extension for interfacing with Redis"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="amd64 ~arm"
-IUSE="igbinary +session"
-
-DEPEND="
- php_targets_php5-6? ( dev-lang/php:5.6[session?] igbinary? ( dev-php/igbinary[php_targets_php5-6] ) )
- php_targets_php7-0? ( dev-lang/php:7.0[session?] igbinary? ( dev-php/igbinary[php_targets_php7-0] ) )
- php_targets_php7-1? ( dev-lang/php:7.1[session?] igbinary? ( dev-php/igbinary[php_targets_php7-1] ) )
- php_targets_php7-2? ( dev-lang/php:7.2[session?] igbinary? ( dev-php/igbinary[php_targets_php7-2] ) )
-"
-RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
-
-# The test suite requires network access.
-RESTRICT=test
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-redis
- $(use_enable igbinary redis-igbinary)
- $(use_enable session redis-session)
- )
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- # Run tests for Redis class
- ${PHPCLI} -d extension=modules/redis.so \
- tests/TestRedis.php \
- --class Redis \
- --host ${PECL_REDIS_HOST} || die 'test suite failed'
- done
-}
diff --git a/dev-php/pecl-redis/pecl-redis-4.2.0.ebuild b/dev-php/pecl-redis/pecl-redis-4.2.0.ebuild
deleted file mode 100644
index 8dbca16cb71f..000000000000
--- a/dev-php/pecl-redis/pecl-redis-4.2.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PHP_EXT_NAME="redis"
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
-DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
-MY_P="${PN/pecl-/}-${PV/_rc/RC}"
-PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
-PHP_EXT_S="${WORKDIR}/${MY_P}"
-
-inherit php-ext-pecl-r3
-
-DESCRIPTION="PHP extension for interfacing with Redis"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="amd64 ~arm"
-IUSE="igbinary +session"
-
-DEPEND="
- php_targets_php5-6? ( dev-lang/php:5.6[session?] igbinary? ( dev-php/igbinary[php_targets_php5-6] ) )
- php_targets_php7-0? ( dev-lang/php:7.0[session?] igbinary? ( dev-php/igbinary[php_targets_php7-0] ) )
- php_targets_php7-1? ( dev-lang/php:7.1[session?] igbinary? ( dev-php/igbinary[php_targets_php7-1] ) )
- php_targets_php7-2? ( dev-lang/php:7.2[session?] igbinary? ( dev-php/igbinary[php_targets_php7-2] ) )
- php_targets_php7-3? ( dev-lang/php:7.3[session?] igbinary? ( dev-php/igbinary[php_targets_php7-3] ) )
-"
-RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
-
-# The test suite requires network access.
-RESTRICT=test
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-redis
- $(use_enable igbinary redis-igbinary)
- $(use_enable session redis-session)
- )
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- # Run tests for Redis class
- ${PHPCLI} -d extension=modules/redis.so \
- tests/TestRedis.php \
- --class Redis \
- --host ${PECL_REDIS_HOST} || die 'test suite failed'
- done
-}
-
-pkg_postinst() {
- elog "The 4.0 release comes with breaking API changes."
- elog "Be sure to verify any applications upon upgrading."
-}
diff --git a/dev-php/pecl-redis/pecl-redis-4.3.0.ebuild b/dev-php/pecl-redis/pecl-redis-4.3.0.ebuild
deleted file mode 100644
index 1dfd74d7f0b4..000000000000
--- a/dev-php/pecl-redis/pecl-redis-4.3.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PHP_EXT_NAME="redis"
-USE_PHP="php5-6 php7-1 php7-2 php7-3"
-DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
-MY_P="${PN/pecl-/}-${PV/_rc/RC}"
-PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
-PHP_EXT_S="${WORKDIR}/${MY_P}"
-
-inherit php-ext-pecl-r3
-
-DESCRIPTION="PHP extension for interfacing with Redis"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="~amd64 ~arm"
-IUSE="igbinary +session"
-
-DEPEND="
- php_targets_php5-6? ( dev-lang/php:5.6[session?] igbinary? ( dev-php/igbinary[php_targets_php5-6] ) )
- php_targets_php7-1? ( dev-lang/php:7.1[session?] igbinary? ( dev-php/igbinary[php_targets_php7-1] ) )
- php_targets_php7-2? ( dev-lang/php:7.2[session?] igbinary? ( dev-php/igbinary[php_targets_php7-2] ) )
- php_targets_php7-3? ( dev-lang/php:7.3[session?] igbinary? ( dev-php/igbinary[php_targets_php7-3] ) )
-"
-RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
-
-# The test suite requires network access.
-RESTRICT=test
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-redis
- $(use_enable igbinary redis-igbinary)
- $(use_enable session redis-session)
- )
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- # Run tests for Redis class
- ${PHPCLI} -d extension=modules/redis.so \
- tests/TestRedis.php \
- --class Redis \
- --host ${PECL_REDIS_HOST} || die 'test suite failed'
- done
-}
-
-pkg_postinst() {
- elog "The 4.0 release comes with breaking API changes."
- elog "Be sure to verify any applications upon upgrading."
-}
diff --git a/dev-php/pecl-redis/pecl-redis-5.0.2.ebuild b/dev-php/pecl-redis/pecl-redis-5.0.2.ebuild
deleted file mode 100644
index 55f32f3d4289..000000000000
--- a/dev-php/pecl-redis/pecl-redis-5.0.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PHP_EXT_NAME="redis"
-USE_PHP="php7-1 php7-2 php7-3 php7-4"
-PHP_EXT_NEEDED_USE="json?,session?"
-DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
-MY_P="${PN/pecl-/}-${PV/_rc/RC}"
-PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
-PHP_EXT_S="${WORKDIR}/${MY_P}"
-
-inherit php-ext-pecl-r3
-
-DESCRIPTION="PHP extension for interfacing with Redis"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="~amd64 ~arm"
-IUSE="igbinary +json +session"
-
-DEPEND="
- igbinary? ( >=dev-php/igbinary-3.0.1-r1[php_targets_php7-1?,php_targets_php7-2?,php_targets_php7-3?,php_targets_php7-4?] )
-"
-RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
-
-# The test suite requires network access.
-RESTRICT=test
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-redis
- $(use_enable igbinary redis-igbinary)
- $(use_enable json redis-json)
- $(use_enable session redis-session)
- )
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- # Run tests for Redis class
- ${PHPCLI} -d extension=modules/redis.so \
- tests/TestRedis.php \
- --class Redis \
- --host ${PECL_REDIS_HOST} || die 'test suite failed'
- done
-}
diff --git a/net-misc/openntpd/openntpd-6.2_p3-r1.ebuild b/net-misc/openntpd/openntpd-6.2_p3-r1.ebuild
index cf1493391340..d2cd91376628 100644
--- a/net-misc/openntpd/openntpd-6.2_p3-r1.ebuild
+++ b/net-misc/openntpd/openntpd-6.2_p3-r1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://openbsd/OpenNTPD/${MY_P}.tar.gz"
LICENSE="BSD GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
IUSE="libressl selinux"
DEPEND="