summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-04 10:04:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-04 10:28:51 +0200
commit6b82c86b0510f2651e061924639c4f2920d70958 (patch)
tree61bc0a370eb29dd2f693bf5f41f95cdfb6d6ac55
parentdev-python/repoze-lru: Port to py3.10 (diff)
downloadgentoo-6b82c86b0510f2651e061924639c4f2920d70958.tar.gz
gentoo-6b82c86b0510f2651e061924639c4f2920d70958.tar.bz2
gentoo-6b82c86b0510f2651e061924639c4f2920d70958.zip
dev-python/routes: Port to py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/routes/routes-2.5.1.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/dev-python/routes/routes-2.5.1.ebuild b/dev-python/routes/routes-2.5.1.ebuild
index 98c48ad54fa4..75e5ba7a36a9 100644
--- a/dev-python/routes/routes-2.5.1.ebuild
+++ b/dev-python/routes/routes-2.5.1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
MY_PN="Routes"
@@ -18,7 +17,6 @@ S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~ia64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="doc"
RDEPEND="
>=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]
@@ -40,13 +38,8 @@ distutils_enable_sphinx docs
# for the faulty docbuild converted to sed stmnts
python_prepare_all() {
# The default theme in sphinx switched to classic from shpinx-1.3.1
- if has_version ">=dev-python/sphinx-1.3.1"; then
- sed -e "s:html_theme_options = {:html_theme = 'classic'\n&:" \
- -i docs/conf.py || die
- else
- sed -e "s:html_theme_options = {:html_theme = 'default'\n&:" \
- -i docs/conf.py || die
- fi
+ sed -e "s:html_theme_options = {:html_theme = 'classic'\n&:" \
+ -i docs/conf.py || die
sed -e "s:changes:changes\n todo:" \
-i docs/index.rst || die