summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-30 04:36:56 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-30 04:36:56 +0100
commit6cadefd457027b8d62fff9d85d55feaaa3a190d1 (patch)
tree9f9cd2f22c1fb7a9bf3f8a162640c069c5ea8337
parentdev-python/django-cors-headers: Remove old (diff)
downloadgentoo-6cadefd457027b8d62fff9d85d55feaaa3a190d1.tar.gz
gentoo-6cadefd457027b8d62fff9d85d55feaaa3a190d1.tar.bz2
gentoo-6cadefd457027b8d62fff9d85d55feaaa3a190d1.zip
dev-python/django-cors-headers: Bump to 4.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/django-cors-headers/Manifest1
-rw-r--r--dev-python/django-cors-headers/django-cors-headers-4.6.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/django-cors-headers/Manifest b/dev-python/django-cors-headers/Manifest
index 532ef1001a16..ac4d817b49ab 100644
--- a/dev-python/django-cors-headers/Manifest
+++ b/dev-python/django-cors-headers/Manifest
@@ -1 +1,2 @@
DIST django-cors-headers-4.5.0.gh.tar.gz 31156 BLAKE2B 5f3c16c6524bdb5832579d9313863e8df334cfca4fbb2831c9cd813759e5f6b491c3967117bd04775dc42d01ef290f0fe5c36d708ee13b4c3076d4513988e91d SHA512 084a6809bfb8b15fe23b65c1cca52453c94a7f659174bb06c36dbc6ec925638bc4f8e2303d7b3e6ef1e0953815b5caf642a5ae988f8a65b18b278f28d59cd4d0
+DIST django-cors-headers-4.6.0.gh.tar.gz 29267 BLAKE2B 23bce012b43d191a6e9e2489529d39385946f4eef353e218f770bb72e65e9d89fd37b7a9b4e39fd138222c6e3145c40a7f9825fd2761d1217929cd55db659156 SHA512 c8148af4127dda25cb8a428330672427d8895ed4f51403f557f955da132012ae809f9c60b40825b0cc414fbd487218228e8f0003b5b7dba413145bcc019de67f
diff --git a/dev-python/django-cors-headers/django-cors-headers-4.6.0.ebuild b/dev-python/django-cors-headers/django-cors-headers-4.6.0.ebuild
new file mode 100644
index 000000000000..bd520efe46cc
--- /dev/null
+++ b/dev-python/django-cors-headers/django-cors-headers-4.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django App that adds CORS (Cross-Origin Resource Sharing) headers to responses"
+HOMEPAGE="
+ https://github.com/adamchainz/django-cors-headers/
+ https://pypi.org/project/django-cors-headers/
+"
+SRC_URI="
+ https://github.com/adamchainz/django-cors-headers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/asgiref-3.6[${PYTHON_USEDEP}]
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest