summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-05 20:07:38 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-05 20:07:38 +0100
commit6cf7b0a1ebdcfb40fc47ab1fe1a8bd6b483e388e (patch)
treed86f1c2d1058c486c718841d1956f5bdf0674616
parentdev-python/mkdocs-htmlproofer-plugin: Bump to 1.2.0 (diff)
downloadgentoo-6cf7b0a1ebdcfb40fc47ab1fe1a8bd6b483e388e.tar.gz
gentoo-6cf7b0a1ebdcfb40fc47ab1fe1a8bd6b483e388e.tar.bz2
gentoo-6cf7b0a1ebdcfb40fc47ab1fe1a8bd6b483e388e.zip
dev-python/libarchive-c: Bump to 5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/libarchive-c/Manifest1
-rw-r--r--dev-python/libarchive-c/libarchive-c-5.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/libarchive-c/Manifest b/dev-python/libarchive-c/Manifest
index f7d764a464da..80b123cabd3f 100644
--- a/dev-python/libarchive-c/Manifest
+++ b/dev-python/libarchive-c/Manifest
@@ -1 +1,2 @@
DIST python-libarchive-c-5.0.gh.tar.gz 48751 BLAKE2B 2ab737c7493c202ba9a1ad57e1066aad12ea984bfa0e63115f59491ea14b3bd1d46d2bb20f033bf5bae64a6badf73b641183f63cc79c9f0e6141792a35521dc4 SHA512 df4758f4b7207fe77ae650aa78c302e9e2a0c7ba81fbeae70af8cb37789a056bc420acd73c1d5baec7b0e93a47fd3e5130db8e43c983f4723366f75a58823f75
+DIST python-libarchive-c-5.1.gh.tar.gz 48816 BLAKE2B 5b727c88eca866f69eda701ca8898d4bd3b68adefb8234a501cb280fae2be98f1314bb64ff94bcc5e1c0cae9ffc6866ee70aa4fbc4353eac1f16d59f9a789ebc SHA512 a2026aba3ef325f10e981e15e50de0435d7371642b0e6df8cd5ab64e76186b2a72297b32f429547e091fb799c9d0fa41be5a6824408c08f6c71585d59175d7a0
diff --git a/dev-python/libarchive-c/libarchive-c-5.1.ebuild b/dev-python/libarchive-c/libarchive-c-5.1.ebuild
new file mode 100644
index 000000000000..4a8dcc8fe716
--- /dev/null
+++ b/dev-python/libarchive-c/libarchive-c-5.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-libarchive-c-${PV}
+DESCRIPTION="A Python interface to libarchive"
+HOMEPAGE="
+ https://github.com/Changaco/python-libarchive-c/
+ https://pypi.org/project/libarchive-c/
+"
+SRC_URI="
+ https://github.com/Changaco/python-libarchive-c/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+
+RDEPEND="
+ app-arch/libarchive
+"
+
+distutils_enable_tests pytest