summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2016-09-15 08:03:02 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2016-09-15 08:03:02 +0000
commit6d998950834e451578e8b383be44b37532e99fd4 (patch)
treeb3e5cea1c0bf6c9c4f87575393874695f77a19b1
parent2016-09-15 07:46:40 UTC (diff)
parentdev-python/python-meteor: add python 3.5 to comapt (diff)
downloadgentoo-6d998950834e451578e8b383be44b37532e99fd4.tar.gz
gentoo-6d998950834e451578e8b383be44b37532e99fd4.tar.bz2
gentoo-6d998950834e451578e8b383be44b37532e99fd4.zip
Merge updates from master
-rw-r--r--dev-libs/ucl/ucl-1.03-r1.ebuild5
-rw-r--r--dev-libs/zookeeper-c/Manifest1
-rw-r--r--dev-libs/zookeeper-c/zookeeper-c-3.4.9.ebuild37
-rw-r--r--dev-python/cherrypy/cherrypy-3.8.0.ebuild4
-rw-r--r--dev-python/python-ddp/python-ddp-0.1.5.ebuild4
-rw-r--r--dev-python/python-meteor/python-meteor-0.1.6.ebuild4
-rw-r--r--dev-python/ws4py/ws4py-0.3.4.ebuild4
-rw-r--r--dev-python/ws4py/ws4py-9999.ebuild4
-rw-r--r--x11-misc/pcmanfm/Manifest1
-rw-r--r--x11-misc/pcmanfm/files/pcmanfm-1.2.4-fix-no-common.patch11
-rw-r--r--x11-misc/pcmanfm/pcmanfm-1.2.4.ebuild72
11 files changed, 136 insertions, 11 deletions
diff --git a/dev-libs/ucl/ucl-1.03-r1.ebuild b/dev-libs/ucl/ucl-1.03-r1.ebuild
index 49083baea207..2a7d118b6e8e 100644
--- a/dev-libs/ucl/ucl-1.03-r1.ebuild
+++ b/dev-libs/ucl/ucl-1.03-r1.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=5
-inherit autotools eutils
+inherit autotools eutils flag-o-matic
DESCRIPTION="the UCL Compression Library"
HOMEPAGE="http://www.oberhumer.com/opensource/ucl/"
@@ -32,6 +32,9 @@ src_prepare() {
}
src_configure() {
+ # bug #585632
+ append-cflags -std=c90
+
econf \
--enable-shared \
$(use_enable static-libs static)
diff --git a/dev-libs/zookeeper-c/Manifest b/dev-libs/zookeeper-c/Manifest
index c99900339461..ca5227658cca 100644
--- a/dev-libs/zookeeper-c/Manifest
+++ b/dev-libs/zookeeper-c/Manifest
@@ -1 +1,2 @@
DIST zookeeper-3.4.8.tar.gz 22261552 SHA256 f10a0b51f45c4f64c1fe69ef713abf9eb9571bc7385a82da892e83bb6c965e90 SHA512 a5f0eca3c66655e0116aeddd92af228402d3d68350b30f9400b3638ef09610d903b7c87a2bb49a5594b12a4d082048c259ba3da121c1c6da4752dd5f5812bfec WHIRLPOOL f4e16b4a771f3a5f57f3ab1b0554d4ac811146414c37037115a3a9c6477a43f8c8c8200eff82358164f7a3af449c570d99005516c13cbc9a9d718b649849b82c
+DIST zookeeper-3.4.9.tar.gz 22724574 SHA256 e7f340412a61c7934b5143faef8d13529b29242ebfba2eba48169f4a8392f535 SHA512 4f3e003c6ce5e3338f642f7deaa0fd2cfd1b30591d3ed4fe880492dded6c4bf01d30483e28f3a38b43bb6d2696ff4d819fc9577733224cec07e236437e88a657 WHIRLPOOL 9e879b335156adf5fcb46e1ddb5e76a061338862cdd14b4cd85dffac4a3343ff21d84ac24b31b232b52426d756bc17734448591cbd13b556c59664b42a8a298a
diff --git a/dev-libs/zookeeper-c/zookeeper-c-3.4.9.ebuild b/dev-libs/zookeeper-c/zookeeper-c-3.4.9.ebuild
new file mode 100644
index 000000000000..c10114160eb1
--- /dev/null
+++ b/dev-libs/zookeeper-c/zookeeper-c-3.4.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="C client interface to Zookeeper server"
+HOMEPAGE="https://zookeeper.apache.org/"
+SRC_URI="mirror://apache/zookeeper/zookeeper-${PV}/zookeeper-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc static-libs test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}/zookeeper-${PV}/src/c"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with test cppunit)
+}
+
+src_compile() {
+ emake
+ use doc && emake doxygen-doc
+}
+
+src_install() {
+ default
+ use doc && dohtml docs/html/*
+}
diff --git a/dev-python/cherrypy/cherrypy-3.8.0.ebuild b/dev-python/cherrypy/cherrypy-3.8.0.ebuild
index beb5335e3bad..9a451038db15 100644
--- a/dev-python/cherrypy/cherrypy-3.8.0.ebuild
+++ b/dev-python/cherrypy/cherrypy-3.8.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy pypy3 )
inherit distutils-r1
diff --git a/dev-python/python-ddp/python-ddp-0.1.5.ebuild b/dev-python/python-ddp/python-ddp-0.1.5.ebuild
index 8a9c1faed5b1..fc834a061e41 100644
--- a/dev-python/python-ddp/python-ddp-0.1.5.ebuild
+++ b/dev-python/python-ddp/python-ddp-0.1.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit distutils-r1
diff --git a/dev-python/python-meteor/python-meteor-0.1.6.ebuild b/dev-python/python-meteor/python-meteor-0.1.6.ebuild
index 9c7cfa8a75f2..b638270d4854 100644
--- a/dev-python/python-meteor/python-meteor-0.1.6.ebuild
+++ b/dev-python/python-meteor/python-meteor-0.1.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit distutils-r1
diff --git a/dev-python/ws4py/ws4py-0.3.4.ebuild b/dev-python/ws4py/ws4py-0.3.4.ebuild
index fabf578d972c..1b69f7b37695 100644
--- a/dev-python/ws4py/ws4py-0.3.4.ebuild
+++ b/dev-python/ws4py/ws4py-0.3.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -8,7 +8,7 @@
# pypy is viable but better with a cutdown set of deps
EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
PYTHON_REQ_USE="threads?"
inherit distutils-r1
diff --git a/dev-python/ws4py/ws4py-9999.ebuild b/dev-python/ws4py/ws4py-9999.ebuild
index 7b17719d187d..187f0d768c32 100644
--- a/dev-python/ws4py/ws4py-9999.ebuild
+++ b/dev-python/ws4py/ws4py-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -8,7 +8,7 @@
# pypy is viable but better with a cutdown set of deps
EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
PYTHON_REQ_USE="threads?"
inherit distutils-r1
diff --git a/x11-misc/pcmanfm/Manifest b/x11-misc/pcmanfm/Manifest
index 2324e378fc87..10d7c8757d4f 100644
--- a/x11-misc/pcmanfm/Manifest
+++ b/x11-misc/pcmanfm/Manifest
@@ -2,3 +2,4 @@ DIST pcmanfm-0.9.10.tar.gz 565628 SHA256 f133c6f207f719d1fc69fe8bc07b2de6883c693
DIST pcmanfm-1.1.2.tar.gz 434785 SHA256 23ee33b34066ac83ce9a98bc9930049e69839438fb60489bd453bec8c2068950 SHA512 0640919477bef8a88b76eb96aaf7f261c423189b60b27f720514040b4006ab5d9d30db5f25380320efc322ca2631298c72ee52a92bebf11ebf162eaa577058e1 WHIRLPOOL e94311f287d1fecf85444e30038a8e6cc65942855c3a562c5fd3c86e53ec46adb4fcf732993857d6e0bb212d1dd49034efd0b9983edcc8f006c4481126e3c778
DIST pcmanfm-1.2.2.tar.xz 406584 SHA256 f620019ac0203b2d0e6eb8aa5a6a46e2bee15a43b4bdd9580db367b6325e9503 SHA512 a76be2e1e02d0e285b0ae239121260d438ae8fe96741d6cf24ddd554eb49187ae4a31d3193ebc688a4c042a96d35f3bfc6bb7c5af7fc288b08cd36711bd91e60 WHIRLPOOL 3bd00d760bd53f9bf010deddc39f7ac11e6c355908b72d258dd38fdf5227cfd2c33dd49d4b771b9ce7c8d64b6870ee5f39049e7b0bbee00834095e35deca6c5a
DIST pcmanfm-1.2.3.tar.xz 406756 SHA256 cfa8d82fc63be147045174bef074807e1e32ce8c6bf4dbd8fad49e260bcf6380 SHA512 b350566c3aee0fe857ed1f0df2ae7d2ce51caf1547b951b380145078ba60f2fe6e0490c4d4c19465c5b1e0a9966205db6f8fe4dafb7cb3e987b9157551df2b28 WHIRLPOOL b342745086bf00e294cf40115c08f63ee99bb67c7f4cb4a6527b56bc3c26f85f93953a4655d91c1186335872342ef05362530f56c865fe5e46d8220a02cc781a
+DIST pcmanfm-1.2.4.tar.xz 417316 SHA256 38cdbb5f01d24483b41b8e6846e4aa66a5751bb3982a8618899e88a853dbe313 SHA512 f4d0ed9d5dcc1b01643715fd54b94ff46967801f0c6d1dde6d196fadbedb5551cfda536d548237b187e5545cceea0a987f7c1c8e38659cae109b6483f14798f7 WHIRLPOOL ab2e6cac1a52c0f17c2469db0a8d8629c1a11fbefcc3bb0befe4ae55e0ed2905b476681e2fc67c8292667c8a2c384df7c10f48cfc0be7ed1bbab384d0ebc0aef
diff --git a/x11-misc/pcmanfm/files/pcmanfm-1.2.4-fix-no-common.patch b/x11-misc/pcmanfm/files/pcmanfm-1.2.4-fix-no-common.patch
new file mode 100644
index 000000000000..46b0ac876f95
--- /dev/null
+++ b/x11-misc/pcmanfm/files/pcmanfm-1.2.4-fix-no-common.patch
@@ -0,0 +1,11 @@
+--- a/src/tab-page.h 2014-08-24 00:46:28.000000000 +0200
++++ b/src/tab-page.h 2016-08-21 18:12:33.509482924 +0200
+@@ -147,7 +147,7 @@
+ #if FM_CHECK_VERSION(1, 2, 0)
+ #include "pcmanfm-modules.h"
+
+-GList *_tab_page_modules; /* in pcmanfm.c */
++extern GList *_tab_page_modules; /* in pcmanfm.c */
+ #endif
+
+ G_END_DECLS
diff --git a/x11-misc/pcmanfm/pcmanfm-1.2.4.ebuild b/x11-misc/pcmanfm/pcmanfm-1.2.4.ebuild
new file mode 100644
index 000000000000..81eafd6feec8
--- /dev/null
+++ b/x11-misc/pcmanfm/pcmanfm-1.2.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+PLOCALES="ar be bg bn ca cs da de el en_GB es et eu fa fi fo fr gl he hr hu id
+is it ja kk km ko lg lt lv ms nl pa pl pt pt_BR ro ru si sk sl sr sr@latin sv
+te th tr tt_RU ug uk vi zh_CN zh_TW"
+PLOCALE_BACKUP="en_GB"
+
+inherit eutils fdo-mime l10n readme.gentoo-r1
+
+MY_PV="${PV/_/}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Fast lightweight tabbed filemanager"
+HOMEPAGE="http://pcmanfm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~x86"
+IUSE="debug"
+# Upstream report:
+# https://sourceforge.net/p/pcmanfm/bugs/1026/
+PATCHES=( "${FILESDIR}/${P}-fix-no-common.patch" )
+
+RDEPEND=">=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.16:2
+ >=lxde-base/menu-cache-0.3.2
+ x11-misc/shared-mime-info
+ >=x11-libs/libfm-${PV}:=[gtk(+)]
+ virtual/eject
+ virtual/freedesktop-icon-theme"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( AUTHORS )
+
+DOC_CONTENTS="PCmanFM can optionally support the menu://applications/
+ location. You should install lxde-base/lxmenu-data for that functionality."
+
+src_prepare() {
+ export LINGUAS="${LINGUAS:-${PLOCALE_BACKUP}}"
+ l10n_get_locales > "${S}"/po/LINGUAS
+ default
+}
+
+src_configure() {
+ econf --sysconfdir=/etc $(use_enable debug)
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}