summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 12:18:55 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:03:04 +0100
commit7e002ad4fd0e400a1eb34dc3be46123519953a19 (patch)
treeb8664c9d116e4c12077275b9be0921a0412a8c2d
parentdev-haskell/pantry: add package (diff)
downloadgentoo-7e002ad4fd0e400a1eb34dc3be46123519953a19.tar.gz
gentoo-7e002ad4fd0e400a1eb34dc3be46123519953a19.tar.bz2
gentoo-7e002ad4fd0e400a1eb34dc3be46123519953a19.zip
dev-haskell/path-io: bump up to 1.6.0
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/path-io/Manifest1
-rw-r--r--dev-haskell/path-io/path-io-1.6.0-r1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/path-io/Manifest b/dev-haskell/path-io/Manifest
index 23f8f8e2d062..e82504fe5938 100644
--- a/dev-haskell/path-io/Manifest
+++ b/dev-haskell/path-io/Manifest
@@ -1 +1,2 @@
DIST path-io-1.2.2.tar.gz 17818 BLAKE2B 5a4a39ff0282e2d2294b8392af954fd0bba036ff223b95dca1951b202b6a4be14373bf439b826d4fb868e4378f9beb45488a77955a6c8e10bd5af70ea72fb57d SHA512 910af5fd9345daa815235027992e6ab4af3784da7afa314644abaf8acb5bee59f3f1444449ce55e88961c86031cf4537c855e13ba2e777348d9fe4c0104fb6d1
+DIST path-io-1.6.0.tar.gz 20848 BLAKE2B 89236aca7c41b5095bb989c7638640ce6735843db36028b2b9d4f0427b0bb94403d915eb3abdfd34cf02f5b6b02cb02e57525eb9e056c942481802b24401117c SHA512 dcafbbfe1531d7b00a9df751c093e6affdefafe7589c0243530579b9f5733ef1357b1085cfd88bf53ff9794accddbc789b927a199f4c4a2b7778268cf1719477
diff --git a/dev-haskell/path-io/path-io-1.6.0-r1.ebuild b/dev-haskell/path-io/path-io-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..fdde596e893d
--- /dev/null
+++ b/dev-haskell/path-io/path-io-1.6.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1.9999
+#hackport: flags: -dev
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Interface to 'directory' package for users of 'path'"
+HOMEPAGE="https://github.com/mrkkrp/path-io"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/dlist-0.8:=[profile?] <dev-haskell/dlist-0.9:=[profile?]
+ >=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/path-0.6:=[profile?]
+ >=dev-haskell/temporary-1.1:=[profile?] <dev-haskell/temporary-1.4:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ >=dev-lang/ghc-8.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4.0.1
+ test? ( >=dev-haskell/hspec-2.0 <dev-haskell/hspec-3.0 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'path >= 0.6 && < 0.7' 'path >= 0.6'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-dev
+}