summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2021-12-11 02:36:55 +0100
committerSam James <sam@gentoo.org>2022-02-19 05:14:37 +0000
commit8012d5042f1bc8501a33aa371bd63a495f6d8a25 (patch)
tree416316ec51af0a09385b9be200ab4f50931148f4
parentmedia-libs/amf-headers: new package (diff)
downloadgentoo-8012d5042f1bc8501a33aa371bd63a495f6d8a25.tar.gz
gentoo-8012d5042f1bc8501a33aa371bd63a495f6d8a25.tar.bz2
gentoo-8012d5042f1bc8501a33aa371bd63a495f6d8a25.zip
media-video/ffmpeg: add AMF useflag
Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com> Closes: https://github.com/gentoo/gentoo/pull/23250 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-video/ffmpeg/ffmpeg-4.4.1-r2.ebuild (renamed from media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild)2
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild2
-rw-r--r--media-video/ffmpeg/metadata.xml1
-rw-r--r--profiles/arch/alpha/package.use.mask5
-rw-r--r--profiles/arch/amd64/package.use.stable.mask4
-rw-r--r--profiles/arch/arm/package.use.mask5
-rw-r--r--profiles/arch/arm64/package.use.mask5
-rw-r--r--profiles/arch/hppa/package.use.mask5
-rw-r--r--profiles/arch/ia64/package.use.mask5
-rw-r--r--profiles/arch/m68k/package.use.mask5
-rw-r--r--profiles/arch/mips/package.use.mask5
-rw-r--r--profiles/arch/powerpc/package.use.mask5
-rw-r--r--profiles/arch/riscv/package.use.mask5
-rw-r--r--profiles/arch/s390/package.use.mask5
-rw-r--r--profiles/arch/sparc/package.use.mask5
-rw-r--r--profiles/arch/x86/package.use.mask5
16 files changed, 67 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild b/media-video/ffmpeg/ffmpeg-4.4.1-r2.ebuild
index 4b206f39f2ff..cdeca0585041 100644
--- a/media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.4.1-r2.ebuild
@@ -98,7 +98,7 @@ FFMPEG_ENCODER_FLAG_MAP=(
amrenc:libvo-amrwbenc mp3:libmp3lame
kvazaar:libkvazaar libaom
openh264:libopenh264 rav1e:librav1e snappy:libsnappy svt-av1:libsvtav1 theora:libtheora twolame:libtwolame
- webp:libwebp x264:libx264 x265:libx265 xvid:libxvid
+ webp:libwebp x264:libx264 x265:libx265 xvid:libxvid amf:amf
)
IUSE="
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 2bbf416f9474..36170fad64a2 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -98,7 +98,7 @@ FFMPEG_ENCODER_FLAG_MAP=(
amrenc:libvo-amrwbenc mp3:libmp3lame
kvazaar:libkvazaar libaom
openh264:libopenh264 rav1e:librav1e snappy:libsnappy svt-av1:libsvtav1 theora:libtheora twolame:libtwolame
- webp:libwebp x264:libx264 x265:libx265 xvid:libxvid
+ webp:libwebp x264:libx264 x265:libx265 xvid:libxvid amf:amf
)
IUSE="
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index d9838e4cabf7..2f0738126047 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -5,6 +5,7 @@
<email>media-video@gentoo.org</email>
</maintainer>
<use>
+ <flag name="amf">Enables support for AMD's Advanced Media Framework (AMF)</flag>
<flag name="amr">Enables Adaptive Multi-Rate Audio support</flag>
<flag name="amrenc">Enables Adaptive Multi-Rate Audio encoding support with <pkg>media-libs/vo-amrwbenc</pkg>.</flag>
<flag name="appkit">Enables Apple AppKit framework</flag>
diff --git a/profiles/arch/alpha/package.use.mask b/profiles/arch/alpha/package.use.mask
index 735b7ff9ab9e..c985051a75e2 100644
--- a/profiles/arch/alpha/package.use.mask
+++ b/profiles/arch/alpha/package.use.mask
@@ -1,6 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Adel Kara Slimane <adel.ks@zegrapher.com> (2022-02-17)
+# Mask AMF keyword on non-amd64 arches
+# It is unusable, for now, in other arches
+media-video/ffmpeg amf
+
# Sam James <sam@gentoo.org> (2022-02-10)
# app-crypt/tpm2-tss is not keyworded here
app-crypt/gnupg tpm
diff --git a/profiles/arch/amd64/package.use.stable.mask b/profiles/arch/amd64/package.use.stable.mask
index 7b7773646bab..5bb6f797a889 100644
--- a/profiles/arch/amd64/package.use.stable.mask
+++ b/profiles/arch/amd64/package.use.stable.mask
@@ -17,6 +17,10 @@
#--- END OF EXAMPLES ---
+# Adel Kara Slimane <adel.ks@zegrapher.com> (2022-02-17)
+# needs stabilizing
+media-video/ffmpeg amf
+
# Sam James <sam@gentoo.org> (2022-02-01)
# sys-cluster/ucx is not marked stable on amd64
sys-cluster/slurm ucx
diff --git a/profiles/arch/arm/package.use.mask b/profiles/arch/arm/package.use.mask
index 2ebd5f8b73fd..364bde4349c1 100644
--- a/profiles/arch/arm/package.use.mask
+++ b/profiles/arch/arm/package.use.mask
@@ -1,6 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Adel Kara Slimane <adel.ks@zegrapher.com> (2022-01-17)
+# Mask AMF keyword on non-amd64 arches
+# It is unusable, for now, in other arches
+media-video/ffmpeg amf
+
# Sam James <sam@gentoo.org> (2022-01-15)
# Deps not yet stable:
# app-emulation/spice
diff --git a/profiles/arch/arm64/package.use.mask b/profiles/arch/arm64/package.use.mask
index 184daef975e2..162cb7a46a7c 100644
--- a/profiles/arch/arm64/package.use.mask
+++ b/profiles/arch/arm64/package.use.mask
@@ -1,6 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Adel Kara Slimane <adel.ks@zegrapher.com> (2022-01-11)
+# Mask AMF keyword on non-amd64 arches
+# It is unusable, for now, in other arches
+media-video/ffmpeg amf
+
# Sam James <sam@gentoo.org> (2022-02-02)
# sys-cluster/knem is not keyworded on arm64
sys-cluster/openmpi openmpi_fabrics_knem
diff --git a/profiles/arch/hppa/package.use.mask b/profiles/arch/hppa/package.use.mask
index 6b91be0cb07e..6f919ffb1c90 100644
--- a/profiles/arch/hppa/package.use.mask
+++ b/profiles/arch/hppa/package.use.mask
@@ -4,6 +4,11 @@
# NOTE: When masking a USE flag due to missing keywords, please file a keyword
# request bug for the hppa arch.
+# Adel Kara Slimane <adel.ks@zegrapher.com> (2022-02-17)
+# Mask AMF keyword on non-amd64 arches
+# It is unusable, for now, in other arches
+media-video/ffmpeg amf
+
# Sam James <sam@gentoo.org> (2022-02-10)
# app-crypt/tpm2-tss is not keyworded here
app-crypt/gnupg tpm
diff --git a/profiles/arch/ia64/package.use.mask b/profiles/arch/ia64/package.use.mask
index dc3a9060ff10..23fb24163308 100644
--- a/profiles/arch/ia64/package.use.mask
+++ b/profiles/arch/ia64/package.use.mask
@@ -1,6 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Adel Kara Slimane <adel.ks@zegrapher.com> (2022-01-11)
+# Mask AMF keyword on non-amd64 arches
+# It is unusable, for now, in other arches
+media-video/ffmpeg amf
+
# Sam James <sam@gentoo.org> (2022-02-10)
# app-crypt/tpm2-tss is not keyworded here
app-crypt/gnupg tpm
diff --git a/profiles/arch/m68k/package.use.mask b/profiles/arch/m68k/package.use.mask
index 3ecf60896168..6a163838c340 100644
--- a/profiles/arch/m68k/package.use.mask
+++ b/profiles/arch/m68k/package.use.mask
@@ -1,6 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Adel Kara Slimane <adel.ks@zegrapher.com> (2022-01-11)
+# Mask AMF keyword on non-amd64 arches
+# It is unusable, for now, in other arches
+media-video/ffmpeg amf
+
# James Le Cuirot <chewi@gentoo.org> (2022-01-09)
# Most usage of KMS requires GBM, which is provided by Mesa, which currently
# doesn't work on m68k.
diff --git a/profiles/arch/mips/package.use.mask b/profiles/arch/mips/package.use.mask
index ef70ab6ee944..67d60f06c16b 100644
--- a/profiles/arch/mips/package.use.mask
+++ b/profiles/arch/mips/package.use.mask
@@ -1,6 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Adel Kara Slimane <adel.ks@zegrapher.com> (2022-01-17)
+# Mask AMF keyword on non-amd64 arches
+# It is unusable, for now, in other arches
+media-video/ffmpeg amf
+
# Fabian Groffen <grobian@gentoo.org> (2022-02-13)
# needs unkeyworded virtual/gsasl
mail-client/mutt gsasl
diff --git a/profiles/arch/powerpc/package.use.mask b/profiles/arch/powerpc/package.use.mask
index aae9f12e576d..3a8eb1ccdb67 100644
--- a/profiles/arch/powerpc/package.use.mask
+++ b/profiles/arch/powerpc/package.use.mask
@@ -1,6 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Adel Kara Slimane <adel.ks@zegrapher.com> (2021-12-11)
+# Mask AMF keyword on non-amd64 arches
+# It is unusable, for now, in other arches
+media-video/ffmpeg amf
+
# Sam James <sam@gentoo.org> (2021-11-15)
# librtas is available on (only) ppc*
sys-apps/util-linux -rtas
diff --git a/profiles/arch/riscv/package.use.mask b/profiles/arch/riscv/package.use.mask
index 2d28eabfc390..5a2ccc07484a 100644
--- a/profiles/arch/riscv/package.use.mask
+++ b/profiles/arch/riscv/package.use.mask
@@ -1,6 +1,11 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Adel Kara Slimane <adel.ks@zegrapher.com> (2022-02-17)
+# Mask AMF keyword on non-amd64 arches
+# It is unusable, for now, in other arches
+media-video/ffmpeg amf
+
# Sam James <sam@gentoo.org> (2022-01-29)
# app-text/ronn-ng not keyworded here, bug #801103
app-accessibility/espeak-ng man
diff --git a/profiles/arch/s390/package.use.mask b/profiles/arch/s390/package.use.mask
index 0fc4971c703e..e92a5a5fa6d1 100644
--- a/profiles/arch/s390/package.use.mask
+++ b/profiles/arch/s390/package.use.mask
@@ -1,6 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Adel Kara Slimane <adel.ks@zegrapher.com> (2021-12-11)
+# Mask AMF keyword on non-amd64 arches
+# It is unusable, for now, in other arches
+media-video/ffmpeg amf
+
# Sam James <sam@gentoo.org> (2021-11-05)
# Avoid keywording unnecessary depenencies for now, bug #804115
dev-python/scipy pythran
diff --git a/profiles/arch/sparc/package.use.mask b/profiles/arch/sparc/package.use.mask
index 475e38e100d7..0632616f9ffc 100644
--- a/profiles/arch/sparc/package.use.mask
+++ b/profiles/arch/sparc/package.use.mask
@@ -1,6 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Adel Kara Slimane <adel.ks@zegrapher.com> (2022-02-17)
+# Mask AMF keyword on non-amd64 arches
+# It is unusable, for now, in other arches
+media-video/ffmpeg amf
+
# Sam James <sam@gentoo.org> (2022-02-10)
# app-crypt/tpm2-tss is not keyworded here
app-crypt/gnupg tpm
diff --git a/profiles/arch/x86/package.use.mask b/profiles/arch/x86/package.use.mask
index e968773153c9..db25a611d6b1 100644
--- a/profiles/arch/x86/package.use.mask
+++ b/profiles/arch/x86/package.use.mask
@@ -1,6 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Adel Kara Slimane <adel.ks@zegrapher.com> (2021-02-17)
+# Mask AMF keyword on non-amd64 arches
+# It is unusable, for now, in other arches
+media-video/ffmpeg amf
+
# Sam James <sam@gentoo.org> (2022-01-20)
# Only supports cpu_flags_x86_aes in 64-bit mode
net-fs/samba cpu_flags_x86_aes