summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-09-08 21:35:13 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-09-08 21:35:13 +0000
commit84e85bddd9d3b9377f32947f307507957467e97d (patch)
tree2b799e588f0a0b587913571d2d6b01ecfa264979
parent2020-09-08 21:05:39 UTC (diff)
parentapp-editors/hteditor: remove unused patches (diff)
downloadgentoo-84e85bddd9d3b9377f32947f307507957467e97d.tar.gz
gentoo-84e85bddd9d3b9377f32947f307507957467e97d.tar.bz2
gentoo-84e85bddd9d3b9377f32947f307507957467e97d.zip
Merge updates from master
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-AR.patch14
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-format-security.patch57
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch36
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch32
-rw-r--r--dev-haskell/hashtables/Manifest4
-rw-r--r--dev-haskell/hashtables/hashtables-1.1.2.1.ebuild35
-rw-r--r--dev-haskell/hashtables/hashtables-1.2.1.0.ebuild36
-rw-r--r--dev-haskell/hashtables/hashtables-1.2.4.1.ebuild (renamed from dev-haskell/hashtables/hashtables-1.2.3.4.ebuild)14
-rw-r--r--dev-haskell/io-streams/Manifest2
-rw-r--r--dev-haskell/io-streams/io-streams-1.5.2.0.ebuild (renamed from dev-haskell/io-streams/io-streams-1.5.1.0-r1.ebuild)26
-rw-r--r--dev-haskell/io-streams/metadata.xml87
-rw-r--r--dev-haskell/openssl-streams/Manifest3
-rw-r--r--dev-haskell/openssl-streams/openssl-streams-1.2.1.0.ebuild30
-rw-r--r--dev-haskell/openssl-streams/openssl-streams-1.2.3.0.ebuild (renamed from dev-haskell/openssl-streams/openssl-streams-1.2.2.0.ebuild)4
-rw-r--r--dev-libs/elfutils/Manifest1
-rw-r--r--dev-libs/elfutils/elfutils-0.181.ebuild86
-rw-r--r--dev-libs/elfutils/files/elfutils-0.181-CC-in-tests-p2.patch34
-rw-r--r--dev-python/cryptography/cryptography-3.0.ebuild2
18 files changed, 162 insertions, 341 deletions
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-AR.patch b/app-editors/hteditor/files/hteditor-2.1.0-AR.patch
deleted file mode 100644
index 60a0427a2125..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-AR.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://bugs.gentoo.org/722040
---- a/configure.ac
-+++ b/configure.ac
-@@ -104,8 +104,8 @@ AC_PROG_CPP
- AC_PROG_CXX
- AC_PROG_YACC
- AM_PROG_LEX
--AC_PATH_PROG(AR, ar)
--AC_PATH_PROG(AR, gar)
-+AC_CHECK_TOOL(AR, ar)
-+AC_CHECK_TOOL(AR, gar)
-
- if test "x$AR" = "x"; then
- AC_MSG_ERROR([*** 'ar' and 'gar' missing, please install one of them or fix your \$PATH ***])
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-format-security.patch b/app-editors/hteditor/files/hteditor-2.1.0-format-security.patch
deleted file mode 100644
index 408d1b9b1be3..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-format-security.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-https://bugs.gentoo.org/521018
-
-From 5839355d67ff822593190473a41512ca19e4280a Mon Sep 17 00:00:00 2001
-From: Anton Gladky <gladk@debian.org>
-Date: Wed, 18 Feb 2015 21:20:39 +0100
-Subject: [PATCH] Fix "format not a string" compilation failure
-
-Compilation with the flag -Werror=format-security fails with
-the message:
-
-error: format not a string literal and no format arguments
-
-This patch solves the issue.
----
- asm/x86dis.cc | 6 +++---
- htpal.cc | 2 +-
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/asm/x86dis.cc b/asm/x86dis.cc
-index 0830d9c..bb9028f 100644
---- a/asm/x86dis.cc
-+++ b/asm/x86dis.cc
-@@ -1218,15 +1218,15 @@ void x86dis::str_op(char *opstr, int *opstrlen, x86dis_insn *insn, x86_insn_op *
- default: {assert(0);}
- }
- if (!insn->rexprefix) {
-- sprintf(opstr, x86_regs[j][op->reg]);
-+ sprintf(opstr, "%s", x86_regs[j][op->reg]);
- } else {
-- sprintf(opstr, x86_64regs[j][op->reg]);
-+ sprintf(opstr, "%s", x86_64regs[j][op->reg]);
- }
- break;
- }
- case X86_OPTYPE_SEG:
- if (x86_segs[op->seg]) {
-- sprintf(opstr, x86_segs[op->seg]);
-+ sprintf(opstr, "%s", x86_segs[op->seg]);
- }
- break;
- case X86_OPTYPE_CRX:
-diff --git a/htpal.cc b/htpal.cc
-index 03dea18..3d5f51e 100644
---- a/htpal.cc
-+++ b/htpal.cc
-@@ -307,7 +307,7 @@ void palette_entry::strvalue(char *buf32bytes)
- text = "normal";
- }
- p = tag_make_color(p, 32, VCP(fg, bg));
-- p += sprintf(p, text);
-+ p += sprintf(p, "%s", text);
- p = tag_make_default_color(p, 32);
- *p = 0;
- }
---
-2.16.2
-
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch b/app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch
deleted file mode 100644
index 3516efd2871b..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Backport a subset of upstream c++11 fixes.
---- a/htmacho.cc
-+++ b/htmacho.cc
-@@ -146,7 +146,7 @@ void ht_macho::init(Bounds *b, File *f, format_viewer_if **ifs, ht_format_group
- break;
- case MACHO_CPU_TYPE_I386:
- switch (c->flavor) {
-- case -1:
-+ default:
- createHostStruct(&c->state, MACHO_I386_THREAD_STATE_struct, image_endianess);
- break;
- }
---- a/htmachohd.cc
-+++ b/htmachohd.cc
-@@ -313,7 +313,7 @@ static ht_view *htmachoheader_init(Bounds *b, File *file, ht_format_group *group
- switch (macho_shared->header.cputype) {
- case MACHO_CPU_TYPE_I386:
- switch (c->flavor) {
-- case -1:
-+ default:
- m->add_staticmask_ptable(macho_i386_thread_state, ofs+4*4/*4 32bit words in thread_header*/, isbigendian);
- break;
- }
---- a/io/types.h
-+++ b/io/types.h
-@@ -87,8 +87,8 @@ union htmsg_param {
- };
-
- struct htmsg {
-- int msg;
-- int type;
-+ unsigned int msg;
-+ unsigned int type;
- htmsg_param data1;
- htmsg_param data2;
- };
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch b/app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch
deleted file mode 100644
index ebcc3c0aa43e..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=620732
-
-Fixes build failure on gcc-7:
-
- htapp.cc: In function 'uint isqr(uint)':
- htapp.cc:3026:18: error: call of overloaded 'abs(uint)' is ambiguous
- while (abs(a - b) > 1) {
- ^
-
-Picked upstream patch that fixes it:
-
-commit 3b62f2f7e49e024ec9d3c5ffc8ff9cd87a107af6
-Author: Sebastian Biallas <sb@biallas.net>
-Date: Sun Nov 13 15:25:26 2016 +0100
-
- use unsigned variables
-
-diff --git a/htapp.cc b/htapp.cc
-index 53d8725..03236e2 100644
---- a/htapp.cc
-+++ b/htapp.cc
-@@ -3021,8 +3021,8 @@ void do_modal_resize()
-
- static uint isqr(uint u)
- {
-- uint a = 2;
-- uint b = u/a;
-+ int a = 2;
-+ int b = u/a;
- while (abs(a - b) > 1) {
- a = (a+b)/2;
- b = u/a;
diff --git a/dev-haskell/hashtables/Manifest b/dev-haskell/hashtables/Manifest
index 41e467988645..1fe7076067dc 100644
--- a/dev-haskell/hashtables/Manifest
+++ b/dev-haskell/hashtables/Manifest
@@ -1,3 +1 @@
-DIST hashtables-1.1.2.1.tar.gz 48553 BLAKE2B eff3d256a6e0bbf3ac31e6d26c43efce9bc06ba09d14b22a6a5bd1d0ea17b81912590739376a6912990501d33598e39e4f92818dceb8c89a8e57853dffbc4373 SHA512 87739d4021b705e40982e66925400eea38efd2f2a11dc46626f33d2a9c9287a5a323d93c82d6e8415aef0434350256fda80819a4bbb58ff2afee74ed755c266a
-DIST hashtables-1.2.1.0.tar.gz 53706 BLAKE2B 5bc1d17fdf80f561fa7d6e9a9010025098579694356484bdaf41ebf6e5e2a03dd6983cb653eef553fb41be99aaa3ce11b2004efe62a585b0ec34f7c4fa12cefe SHA512 2c6cd17434402ff963a1b3357e58dfab3d4b60f5a2848b5433dcbbc1705d24707eacfc36af5dfb461ab03ce678c0736f3277292677e8ab297b306bd14e797e64
-DIST hashtables-1.2.3.4.tar.gz 58458 BLAKE2B ea57de50f1bc02107b06ea57f215aa8b7bc97ae658a43e2e57481c097452ee5b9bf2b8d67e0656c7b94830cb7bd4ed7d2e8f3f5b1c3b2070fcc3f1ed1d5f7acc SHA512 4723540f930edd1d5fd5cf58eadf7ed24fcd7761b90f303d559bc617737ec30cee2e9571ecced61fd369a933ae95b4386e48b122b876e73d0ad4bb65df16b76e
+DIST hashtables-1.2.4.1.tar.gz 58425 BLAKE2B 1e7d0e0f80e2e8ef17370f7019f802989c12eb7a7e340cfac44fa4138baa105985846262b0d5eeb1f59ee21d27a5036dce9c45623fecf6ecdf319ed8d4e36bc8 SHA512 e88fb8f9c8a51be31e5d07ca1fef3d1a05a347942878f84a500d8c224b1118a2be97f9a947f17834a8331f296f302eafeef34d1f151360361675ecf5204b38f6
diff --git a/dev-haskell/hashtables/hashtables-1.1.2.1.ebuild b/dev-haskell/hashtables/hashtables-1.1.2.1.ebuild
deleted file mode 100644
index c9196569efdb..000000000000
--- a/dev-haskell/hashtables/hashtables-1.1.2.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.4.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Mutable hash tables in the ST monad"
-HOMEPAGE="https://github.com/gregorycollins/hashtables"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="bounds-checking portable cpu_flags_x86_sse4_1 +unsafe-tricks"
-
-RDEPEND="dev-haskell/primitive:=[profile?]
- >=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.12:=[profile?]
- >=dev-lang/ghc-6.10.4:=
- >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag bounds-checking bounds-checking) \
- $(cabal_flag portable portable) \
- $(cabal_flag cpu_flags_x86_sse4_1 sse41) \
- $(cabal_flag unsafe-tricks unsafe-tricks)
-}
diff --git a/dev-haskell/hashtables/hashtables-1.2.1.0.ebuild b/dev-haskell/hashtables/hashtables-1.2.1.0.ebuild
deleted file mode 100644
index c308cbd93bfe..000000000000
--- a/dev-haskell/hashtables/hashtables-1.2.1.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.6.9999
-#hackport: flags: sse42:cpu_flags_x86_sse4_2
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Mutable hash tables in the ST monad"
-HOMEPAGE="https://github.com/gregorycollins/hashtables"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="bounds-checking cpu_flags_x86_sse4_2 portable +unsafe-tricks"
-
-RDEPEND="dev-haskell/primitive:=[profile?]
- >=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.12:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag bounds-checking bounds-checking) \
- $(cabal_flag portable portable) \
- $(cabal_flag cpu_flags_x86_sse4_2 sse42) \
- $(cabal_flag unsafe-tricks unsafe-tricks)
-}
diff --git a/dev-haskell/hashtables/hashtables-1.2.3.4.ebuild b/dev-haskell/hashtables/hashtables-1.2.4.1.ebuild
index b1ef85e089ff..b4558c556890 100644
--- a/dev-haskell/hashtables/hashtables-1.2.3.4.ebuild
+++ b/dev-haskell/hashtables/hashtables-1.2.4.1.ebuild
@@ -3,10 +3,10 @@
EAPI=7
-# ebuild generated by hackport 0.6.1.9999
+# ebuild generated by hackport 0.6.6
#hackport: flags: sse42:cpu_flags_x86_sse4_2
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Mutable hash tables in the ST monad"
@@ -18,13 +18,19 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="bounds-checking cpu_flags_x86_sse4_2 debug detailed-profiling portable +unsafe-tricks"
-RDEPEND=">=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
- dev-haskell/primitive:=[profile?]
+RDEPEND="dev-haskell/primitive:=[profile?]
>=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.13:=[profile?]
>=dev-lang/ghc-7.8.2:=
+ >=dev-haskell/hashable-1.2.1:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-2
+ >=dev-haskell/mwc-random-0.8 <dev-haskell/mwc-random-0.16
+ >=dev-haskell/quickcheck-2.3.0.2
+ >=dev-haskell/test-framework-0.3.1 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.6 <dev-haskell/test-framework-hunit-3
+ >=dev-haskell/test-framework-quickcheck2-0.2.6 <dev-haskell/test-framework-quickcheck2-0.4 )
"
src_configure() {
diff --git a/dev-haskell/io-streams/Manifest b/dev-haskell/io-streams/Manifest
index 3cb233c7ae27..65f4b82a101e 100644
--- a/dev-haskell/io-streams/Manifest
+++ b/dev-haskell/io-streams/Manifest
@@ -1,2 +1,2 @@
DIST io-streams-1.3.6.0.tar.gz 61651 BLAKE2B d71a5ba3d264b98d3284470021fc1d9622700b37ef1a67142d12d4d6321233eb28ad5274925e08f9d0c251ee77e25e2187c811d197a9f7b68e33479d8ea602ab SHA512 9ef5a2daa43600796b48104771c71d698f40e29def536e785421b53a310683e7db202b254310a0a5f2d1fa507dcad27c25f328c64fffe796c06d4c0d98ca982d
-DIST io-streams-1.5.1.0.tar.gz 64044 BLAKE2B 9a1a4dce626f3a569f4a7866f93d5663e9e4e8b863d1c2332bffbeb2e4481e0a250c84b75ae375144a32473b62538dbd87b53dd0a08034daea855484660aa07a SHA512 01ddf89f09cba429ab600e55994cb6740d4fcdeb23ce85822098d39dbe530a74256d66ea52429798787d9d549db3cd99a5078362b333a7f49c4926e74e0b460c
+DIST io-streams-1.5.2.0.tar.gz 63812 BLAKE2B a555bc0bc365e4e2c28570da34e6c2891ff56a7460ec8a857285a22ea3a4a2b8975139c3024fd90ffec51386646d9ed632754971abef04fd2c358cba5e0a19c6 SHA512 2cb6c9cded0077f1501b0fba576b79e5ebf21ccc2711a91552ec46ef6d5e943e0c1255cdfda381aa8e4d7691b1e450956bedd2fbd4414b13ef7926b0cc3dc4c3
diff --git a/dev-haskell/io-streams/io-streams-1.5.1.0-r1.ebuild b/dev-haskell/io-streams/io-streams-1.5.2.0.ebuild
index 001dda035c1c..0d44d531e46d 100644
--- a/dev-haskell/io-streams/io-streams-1.5.1.0-r1.ebuild
+++ b/dev-haskell/io-streams/io-streams-1.5.2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-# ebuild generated by hackport 0.5.6.9999
+# ebuild generated by hackport 0.6.6.9999
#hackport: flags: +nointeractivetests
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
@@ -16,18 +16,18 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="+network +zlib"
-RESTRICT=test # one test case requires network access
+RESTRICT=test # requires network access
RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
>=dev-haskell/bytestring-builder-0.10:=[profile?] <dev-haskell/bytestring-builder-0.11:=[profile?]
- >=dev-haskell/network-2.3:=[profile?]
- >=dev-haskell/primitive-0.2:=[profile?]
+ >=dev-haskell/primitive-0.2:=[profile?] <dev-haskell/primitive-0.8:=[profile?]
>=dev-haskell/text-0.10:=[profile?] <dev-haskell/text-1.3:=[profile?]
>=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.13:=[profile?]
- >=dev-haskell/zlib-bindings-0.1:=[profile?] <dev-haskell/zlib-bindings-0.2:=[profile?]
>=dev-lang/ghc-7.8.2:=
+ network? ( >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-3.2:=[profile?] )
+ zlib? ( >=dev-haskell/zlib-bindings-0.1:=[profile?] <dev-haskell/zlib-bindings-0.2:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
@@ -37,18 +37,12 @@ DEPEND="${RDEPEND}
>=dev-haskell/test-framework-0.6 <dev-haskell/test-framework-0.9
>=dev-haskell/test-framework-hunit-0.2.7 <dev-haskell/test-framework-hunit-0.4
>=dev-haskell/test-framework-quickcheck2-0.2.12.1 <dev-haskell/test-framework-quickcheck2-0.4
- >=dev-haskell/zlib-0.5 <dev-haskell/zlib-0.7 )
+ zlib? ( >=dev-haskell/zlib-0.5 <dev-haskell/zlib-0.7 ) )
"
-src_prepare() {
- default
-
- cabal_chdeps \
- 'network >= 2.3 && <3.1' 'network >= 2.3' \
- 'primitive >= 0.2 && <0.7' 'primitive >= 0.2'
-}
-
src_configure() {
haskell-cabal_src_configure \
- --flag=nointeractivetests
+ $(cabal_flag network network) \
+ --flag=nointeractivetests \
+ $(cabal_flag zlib zlib)
}
diff --git a/dev-haskell/io-streams/metadata.xml b/dev-haskell/io-streams/metadata.xml
index 7852149c9343..a86f42647c54 100644
--- a/dev-haskell/io-streams/metadata.xml
+++ b/dev-haskell/io-streams/metadata.xml
@@ -5,20 +5,24 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <use>
+ <flag name="network">Include network support</flag>
+ <flag name="zlib">Include zlib support</flag>
+ </use>
<longdescription>
/Overview/
The io-streams library contains simple and easy-to-use primitives for I/O
using streams. Most users will want to import the top-level convenience
- module "System.IO.Streams", which re-exports most of the library:
+ module &quot;System.IO.Streams&quot;, which re-exports most of the library:
@
- import "System.IO.Streams" (InputStream, OutputStream)
- import qualified "System.IO.Streams" as Streams
+ import System.IO.Streams (InputStream, OutputStream)
+ import qualified System.IO.Streams as Streams
@
For first-time users, @io-streams@ comes with an included tutorial, which can
- be found in the "System.IO.Streams.Tutorial" module.
+ be found in the &quot;System.IO.Streams.Tutorial&quot; module.
/Features/
@@ -27,13 +31,13 @@
@
\-\- read an item from an input stream
- Streams.'System.IO.Streams.read' :: 'System.IO.Streams.InputStream' a -&gt; IO (Maybe a)
+ Streams.read :: InputStream a -&gt; IO (Maybe a)
\-\- push an item back to an input stream
- Streams.'System.IO.Streams.unRead' :: a -&gt; 'System.IO.Streams.InputStream' a -&gt; IO ()
+ Streams.unRead :: a -&gt; InputStream a -&gt; IO ()
\-\- write to an output stream
- Streams.'System.IO.Streams.write' :: Maybe a -&gt; 'System.IO.Streams.OutputStream' a -&gt; IO ()
+ Streams.write :: Maybe a -&gt; OutputStream a -&gt; IO ()
@
Streams can be transformed by composition and hooked together with provided combinators:
@@ -46,19 +50,19 @@
Stream composition leaves the original stream accessible:
@
- ghci&gt; input \&lt;- Streams.fromByteString \"long string\"
+ ghci&gt; input \&lt;- Streams.fromByteString \&quot;long string\&quot;
ghci&gt; wrapped \&lt;- Streams.takeBytes 4 input
ghci&gt; Streams.read wrapped
- Just \"long\"
+ Just \&quot;long\&quot;
ghci&gt; Streams.read wrapped
Nothing
ghci&gt; Streams.read input
- Just \" string\"
+ Just \&quot; string\&quot;
@
Simple types and operations in the IO monad mean straightforward and simple
exception handling and resource cleanup using Haskell standard library
- facilities like 'Control.Exception.bracket'.
+ facilities like &#39;Control.Exception.bracket&#39;.
@io-streams@ comes with:
@@ -73,66 +77,5 @@
* support for parsing from streams using @attoparsec@.
* support for spawning processes and communicating with them using streams.
-
- /ChangeLog/
-
- [@1.1.4.2@] Fixed a build error with network versions older than 2.4.
-
- [@1.1.4.1@] @System.IO.Streams.Network@: scalability improvement: buffers
- for socket reads are now allocated by system malloc rather than
- by pinned pointers in GHC (currently pinned pointer allocation
- takes a global lock).
-
- [@1.1.4.0@] Widened @attoparsec@ and @text@ library dependencies to allow
- the latest versions.
-
- [@1.1.3.0@] Added @System.IO.Streams.ByteString.takeExactly@. Widened
- @network@ dependency to include 2.3. Added a
- @NoInteractiveTests@ flag to selectively disable some tests for
- environments where spawning interactive processes is
- impossible.
-
- [@1.1.2.2@] Allowed newest versions of the @process@, @test-framework@,
- and @text@ libraries.
-
- [@1.1.2.1@] Fixed build error when compiled against attoparsec-0.10.0.x.
-
- [@1.1.2.0@] Added @System.IO.Streams.Concurrent.makeChanPipe@, to create a
- simple concurrent pipe between an @InputStream@/@OutputStream@
- pair.
-
- [@1.1.1.0@] Added @System.IO.Streams.Network.socketToStreamsWithBufferSize@,
- allowing control over the size of the receive buffers used when
- reading from sockets.
-
- [@1.1.0.3@] Fixed an inconsistent version upper bound in the test suite.
-
- [@1.1.0.2@] Fixed a typo in the tutorial.
-
- [@1.1.0.1@] A couple of Haddock markup fixes.
-
- [@1.1.0.0@] Reworked, simplified, and streamlined the internals of the
- library. Exports from "System.IO.Streams.Internal" relying on
- Sources and Sinks were deleted because they are no longer
- necessary: Source(..), Sink(..), defaultPushback,
- withDefaultPushback, nullSource, nullSink, singletonSource,
- simpleSource, sourceToStream, sinkToStream, generatorToSource,
- and consumerToSink.
-
- [@1.0.2.2@] Fixed a bug in which \"takeBytes 0\" was erroneously requesting
- input from the wrapped stream.
-
- [@1.0.2.1@] Fixed a compile error on GHC 7.0.x.
-
- [@1.0.2.0@] Added "System.IO.Streams.Process" (support for communicating
- with system processes using streams), added new functions to
- "System.IO.Streams.Handle" for converting @io-streams@ types to
- 'System.IO.Handle's. (Now you can pass streams from this
- library to places that expect Handles and everything will
- work.)
-
- [@1.0.1.0@] Added 'System.IO.Streams.Combinators.ignoreEof'.
-
- [@1.0.0.1@] Fixed some haddock markup.
</longdescription>
</pkgmetadata>
diff --git a/dev-haskell/openssl-streams/Manifest b/dev-haskell/openssl-streams/Manifest
index df261113ddb4..e38e0c7d52e5 100644
--- a/dev-haskell/openssl-streams/Manifest
+++ b/dev-haskell/openssl-streams/Manifest
@@ -1,2 +1 @@
-DIST openssl-streams-1.2.1.0.tar.gz 6266 BLAKE2B 2d7866b7667547f5c4f2c2873471c7ff9ac60ee89e9c791d816b46185bda456d4bdd13ce5894688ff56926b337d38208719f8c3d22cfd0606529732cfcec3235 SHA512 c429bdcbb4ce893d79941eccb849f7064fb88073423b4395e0f50795ddef699934c148549f800b551914c7983cb2b8fc988dccfb4e0363f422726c0cdeaa5018
-DIST openssl-streams-1.2.2.0.tar.gz 6376 BLAKE2B f0d0684c3ed5e13de4d4745d16cf6bccc75961e57d164cc3a5620d1de0b0cbb40acdf4819266c45ceacd4473bdd831ec9ca92aa086e01eab55408e2588f9a0eb SHA512 ff1262afd26c82e97ed0a8bc7237728b47341968e8c6fe4a2351780508241f1588d12b32709d9be3b385db14b9b56eee77676cacb1c0a6bf632a8f25bdb775eb
+DIST openssl-streams-1.2.3.0.tar.gz 6304 BLAKE2B c957be3a5d45f8785220f1bf645ab49df17f3c21dc609810651bc345c9bf6e576cbbb3a35f46b9f979ed48b525caaf8bd6c75f1fc41a38407fa8948b2719f17b SHA512 86c5f9348af82ad0ac9e8103ee078c78647e61345ecf0c48b02749206147a82a3a798f681b9cd20ec866276aca75a3739965ca2b76a0b302da4792bf1fc4917e
diff --git a/dev-haskell/openssl-streams/openssl-streams-1.2.1.0.ebuild b/dev-haskell/openssl-streams/openssl-streams-1.2.1.0.ebuild
deleted file mode 100644
index 058b082d55fe..000000000000
--- a/dev-haskell/openssl-streams/openssl-streams-1.2.1.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.5.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="OpenSSL network support for io-streams"
-HOMEPAGE="https://hackage.haskell.org/package/openssl-streams"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/hsopenssl-0.10.3:=[profile?] <dev-haskell/hsopenssl-0.12:=[profile?]
- >=dev-haskell/io-streams-1.0:=[profile?] <dev-haskell/io-streams-1.4:=[profile?]
- >=dev-haskell/network-2.4:=[profile?] <dev-haskell/network-2.7:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
- test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-2
- >=dev-haskell/test-framework-0.8.0.3 <dev-haskell/test-framework-0.9
- >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4 )
-"
diff --git a/dev-haskell/openssl-streams/openssl-streams-1.2.2.0.ebuild b/dev-haskell/openssl-streams/openssl-streams-1.2.3.0.ebuild
index 79422fe4d712..7e5e5490e1ff 100644
--- a/dev-haskell/openssl-streams/openssl-streams-1.2.2.0.ebuild
+++ b/dev-haskell/openssl-streams/openssl-streams-1.2.3.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-# ebuild generated by hackport 0.6.9999
+# ebuild generated by hackport 0.6.6
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -21,7 +21,7 @@ RESTRICT=test # requires network access
RDEPEND=">=dev-haskell/hsopenssl-0.10.3:=[profile?] <dev-haskell/hsopenssl-0.12:=[profile?]
>=dev-haskell/io-streams-1.0:=[profile?] <dev-haskell/io-streams-1.6:=[profile?]
- >=dev-haskell/network-2.4:=[profile?] <dev-haskell/network-3.1:=[profile?]
+ >=dev-haskell/network-2.4:=[profile?] <dev-haskell/network-3.2:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
diff --git a/dev-libs/elfutils/Manifest b/dev-libs/elfutils/Manifest
index f8c5896077eb..f54bc77fa62c 100644
--- a/dev-libs/elfutils/Manifest
+++ b/dev-libs/elfutils/Manifest
@@ -1 +1,2 @@
DIST elfutils-0.180.tar.bz2 9079640 BLAKE2B bd7863b82a71d2932a23c9d125d5eb6485977a3256a8a0b25980183d33f7345c3d9fae78277de5c955eb0ceeb955f8fa71d209f4f39bcf6dd49e46a8bbd7efcf SHA512 62e96035ccfe8928baca2285decbe8b8703a2daa956df81ece18fecf643272fb68955806b3e807a514141a7a9bf44520bf09461672aa580bd6807485fb604d25
+DIST elfutils-0.181.tar.bz2 9088984 BLAKE2B 3f35f1a494986ff23d755188aab2b8f5ca9729927dd0e01725abf8477ac09721f751ff79686aafeff3878cf52e0c3f3e06d794fdf6371382a1bffc85c0de3411 SHA512 d565541d5817f409dc89ebb1ee593366f69c371a1531308eeb67ff934b14a0fab0c9009fd7c23240efbaa1b4e04edac5c425e47d80e3e66ba03dcaf000afea36
diff --git a/dev-libs/elfutils/elfutils-0.181.ebuild b/dev-libs/elfutils/elfutils-0.181.ebuild
new file mode 100644
index 000000000000..e0947ea4dfd8
--- /dev/null
+++ b/dev-libs/elfutils/elfutils-0.181.ebuild
@@ -0,0 +1,86 @@
+# Copyright 2003-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib-minimal toolchain-funcs
+
+DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
+HOMEPAGE="http://elfutils.org/"
+SRC_URI="https://sourceware.org/elfutils/ftp/${PV}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2+ LGPL-3+ ) utils? ( GPL-3+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 lzma nls static-libs test +threads +utils valgrind"
+
+RDEPEND=">=sys-libs/zlib-1.2.8-r1[static-libs?,${MULTILIB_USEDEP}]
+ bzip2? ( >=app-arch/bzip2-1.0.6-r4[static-libs?,${MULTILIB_USEDEP}] )
+ lzma? ( >=app-arch/xz-utils-5.0.5-r1[static-libs?,${MULTILIB_USEDEP}] )
+ !dev-libs/libelf"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )
+"
+BDEPEND="nls? ( sys-devel/gettext )
+ >=sys-devel/flex-2.5.4a
+ sys-devel/m4"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.175-disable-biarch-test-PR24158.patch
+ "${FILESDIR}"/${PN}-0.177-disable-large.patch
+ "${FILESDIR}"/${PN}-0.180-PaX-support.patch
+ "${FILESDIR}"/${PN}-0.179-CC-in-tests.patch
+ "${FILESDIR}"/${PN}-0.181-CC-in-tests-p2.patch
+)
+
+src_prepare() {
+ default
+
+ if ! use static-libs; then
+ sed -i -e '/^lib_LIBRARIES/s:=.*:=:' -e '/^%.os/s:%.o$::' lib{asm,dw,elf}/Makefile.in || die
+ fi
+ # https://sourceware.org/PR23914
+ sed -i 's:-Werror::' */Makefile.in || die
+}
+
+src_configure() {
+ use test && append-flags -g #407135
+
+ # Symbol aliases are implemented as asm statements.
+ # Will require porting: https://gcc.gnu.org/PR48200
+ filter-flags '-flto*'
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable nls) \
+ $(use_enable threads thread-safety) \
+ $(use_enable valgrind) \
+ --disable-debuginfod \
+ --program-prefix="eu-" \
+ --with-zlib \
+ $(use_with bzip2 bzlib) \
+ $(use_with lzma)
+}
+
+multilib_src_test() {
+ # CC is a workaround for tests using ${CC-gcc}
+ env LD_LIBRARY_PATH="${BUILD_DIR}/libelf:${BUILD_DIR}/libebl:${BUILD_DIR}/libdw:${BUILD_DIR}/libasm" \
+ LC_ALL="C" \
+ CC="$(tc-getCC)" \
+ emake check VERBOSE=1
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dodoc NOTES
+ # These build quick, and are needed for most tests, so don't
+ # disable their building when the USE flag is disabled.
+ if ! use utils; then
+ rm -rf "${ED}"/usr/bin || die
+ fi
+}
diff --git a/dev-libs/elfutils/files/elfutils-0.181-CC-in-tests-p2.patch b/dev-libs/elfutils/files/elfutils-0.181-CC-in-tests-p2.patch
new file mode 100644
index 000000000000..63c0ed0cb608
--- /dev/null
+++ b/dev-libs/elfutils/files/elfutils-0.181-CC-in-tests-p2.patch
@@ -0,0 +1,34 @@
+--- a/tests/run-test-includes.sh
++++ b/tests/run-test-includes.sh
+@@ -3,24 +3,24 @@
+ . $srcdir/test-subr.sh
+
+ echo '#include "libelf.h"' \
+- | gcc -c -o /dev/null -I ${abs_srcdir}/../libelf -xc -
++ | ${CC-gcc} -c -o /dev/null -I ${abs_srcdir}/../libelf -xc -
+ echo '#include "gelf.h"' \
+- | gcc -c -o /dev/null -I ${abs_srcdir}/../libelf -xc -
++ | ${CC-gcc} -c -o /dev/null -I ${abs_srcdir}/../libelf -xc -
+
+ echo '#include "dwarf.h"' \
+- | gcc -c -o /dev/null -I ${abs_srcdir}/../libelf \
++ | ${CC-gcc} -c -o /dev/null -I ${abs_srcdir}/../libelf \
+ -I ${abs_srcdir}/../libdw -xc -
+ echo '#include "libdw.h"' \
+- | gcc -c -o /dev/null -I ${abs_srcdir}/../libelf \
++ | ${CC-gcc} -c -o /dev/null -I ${abs_srcdir}/../libelf \
+ -I ${abs_srcdir}/../libdw -xc -
+
+ echo '#include "libdwfl.h"' \
+- | gcc -c -o /dev/null -I ${abs_srcdir}/../libelf \
++ | ${CC-gcc} -c -o /dev/null -I ${abs_srcdir}/../libelf \
+ -I ${abs_srcdir}/../libdw -I ${abs_srcdir}/../libdwfl -xc -
+ echo '#include "libdwelf.h"' \
+- | gcc -c -o /dev/null -I ${abs_srcdir}/../libelf \
++ | ${CC-gcc} -c -o /dev/null -I ${abs_srcdir}/../libelf \
+ -I ${abs_srcdir}/../libdw -I ${abs_srcdir}/../libdwelf -xc -
+
+ echo '#include "libasm.h"' \
+- | gcc -c -o /dev/null -I ${abs_srcdir}/../libelf \
++ | ${CC-gcc} -c -o /dev/null -I ${abs_srcdir}/../libelf \
+ -I ${abs_srcdir}/../libasm -xc -
diff --git a/dev-python/cryptography/cryptography-3.0.ebuild b/dev-python/cryptography/cryptography-3.0.ebuild
index c2571ae27052..3ef9492b98fb 100644
--- a/dev-python/cryptography/cryptography-3.0.ebuild
+++ b/dev-python/cryptography/cryptography-3.0.ebuild
@@ -16,7 +16,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
LICENSE="|| ( Apache-2.0 BSD )"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="libressl idna test"
RESTRICT="!test? ( test )"