summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-29 16:21:41 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-29 16:21:49 +0100
commit867f3b9b49b4651d0c4ca6f92f9f0cf2c7a48dc0 (patch)
tree0e9265cbe27b2b8087a883f003bfbcda3286252a
parentdev-lua/luaexpat: update ebuilds (diff)
downloadgentoo-867f3b9b49b4651d0c4ca6f92f9f0cf2c7a48dc0.tar.gz
gentoo-867f3b9b49b4651d0c4ca6f92f9f0cf2c7a48dc0.tar.bz2
gentoo-867f3b9b49b4651d0c4ca6f92f9f0cf2c7a48dc0.zip
dev-lua/luaexpat: drop old version
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/luaexpat/luaexpat-1.3.0-r100.ebuild78
-rw-r--r--dev-lua/luaexpat/luaexpat-1.3.3-r100.ebuild82
-rw-r--r--profiles/package.mask2
3 files changed, 0 insertions, 162 deletions
diff --git a/dev-lua/luaexpat/luaexpat-1.3.0-r100.ebuild b/dev-lua/luaexpat/luaexpat-1.3.0-r100.ebuild
deleted file mode 100644
index 28ce6e137095..000000000000
--- a/dev-lua/luaexpat/luaexpat-1.3.0-r100.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..3} )
-LUA_REQ_USE="${MULTILIB_USEDEP}"
-
-inherit lua multilib-minimal toolchain-funcs
-
-DESCRIPTION="LuaExpat is a SAX XML parser based on the Expat library"
-HOMEPAGE="https://matthewwild.co.uk/projects/luaexpat/"
-SRC_URI="https://matthewwild.co.uk/projects/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="
- dev-libs/expat[${MULTILIB_USEDEP}]
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-HTML_DOCS=( "doc/us/." )
-
-src_prepare() {
- default
-
- # Respect users CFLAGS
- # Add '-DLUA_32BITS' for fixing compilation with lua5.3
- sed -e 's/-O2/-DLUA_32BITS/g' -i Makefile || die
-
- multilib_copy_sources
-}
-
-lua_multilib_src_compile() {
- # Clean project, to compile it for every lua slot
- emake clean
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LUA_INC=$(lua_get_CFLAGS)"
- )
-
- emake "${myemakeargs[@]}"
-
- # Copy module to match the choosen LUA implementation
- cp "src/lxp.so" "src/lxp-${ELUA}.so" || die
-}
-
-multilib_src_compile() {
- lua_foreach_impl lua_multilib_src_compile
-}
-
-lua_multilib_src_install() {
- # Use correct module for the choosen LUA implementation
- cp "src/lxp-${ELUA}.so" "src/lxp.so" || die
-
- local myemakeargs=(
- "DESTDIR=${ED}"
- "LUA_CDIR=$(lua_get_cmod_dir)"
- "LUA_INC=$(lua_get_include_dir)"
- "LUA_LDIR=$(lua_get_lmod_dir)"
- )
-
- emake "${myemakeargs[@]}" install
-}
-
-multilib_src_install() {
- lua_foreach_impl lua_multilib_src_install
-}
-
-multilib_src_install_all() {
- einstalldocs
-}
diff --git a/dev-lua/luaexpat/luaexpat-1.3.3-r100.ebuild b/dev-lua/luaexpat/luaexpat-1.3.3-r100.ebuild
deleted file mode 100644
index 7674c7cd76ab..000000000000
--- a/dev-lua/luaexpat/luaexpat-1.3.3-r100.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..3} )
-LUA_REQ_USE="${MULTILIB_USEDEP}"
-
-inherit lua multilib-minimal toolchain-funcs
-
-DESCRIPTION="LuaExpat is a SAX XML parser based on the Expat library"
-HOMEPAGE="https://github.com/tomasguisasola/luaexpat"
-SRC_URI="https://github.com/tomasguisasola/luaexpat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="
- dev-libs/expat[${MULTILIB_USEDEP}]
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-HTML_DOCS=( "doc/us/." )
-
-PATCHES=(
- "${FILESDIR}/${P}_makefile.patch"
- "${FILESDIR}/${P}_getcurrentbytecount.patch"
- "${FILESDIR}/${P}_restore_functionality.patch"
-)
-
-src_prepare() {
- default
-
- # Respect users CFLAGS
- sed -e 's/-O2//g' -i makefile || die
-
- multilib_copy_sources
-}
-
-lua_multilib_src_compile() {
- # Clean project, to compile it for every lua slot
- emake clean
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LUA_INC=$(lua_get_include_dir)"
- )
-
- emake "${myemakeargs[@]}"
-
- # Copy module to match the choosen LUA implementation
- cp "src/lxp.so.${PV}" "src/lxp-${ELUA}.so.${PV}" || die
-}
-
-multilib_src_compile() {
- lua_foreach_impl lua_multilib_src_compile
-}
-
-lua_multilib_src_install() {
- # Use correct module for the choosen LUA implementation
- cp "src/lxp-${ELUA}.so.${PV}" "src/lxp.so.${PV}" || die
-
- local myemakeargs=(
- "LUA_DIR=${ED}/$(lua_get_lmod_dir)"
- "LUA_INC=${ED}/$(lua_get_include_dir)"
- "LUA_LIBDIR=${ED}/$(lua_get_cmod_dir)"
- )
-
- emake "${myemakeargs[@]}" install
-}
-
-multilib_src_install() {
- lua_foreach_impl lua_multilib_src_install
-}
-
-multilib_src_install_all() {
- einstalldocs
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 361f08c5e0ab..4633518e7f1a 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -528,9 +528,7 @@ dev-lua/luacrypto
>=dev-lua/luacheck-0.23.0-r100
>=dev-lua/luadbi-0.7.2-r100
>=dev-lua/luaevent-0.4.6-r100
-=dev-lua/luaexpat-1.3.0-r100
=dev-lua/luaexpat-1.3.0-r101
-=dev-lua/luaexpat-1.3.3-r100
=dev-lua/luaexpat-1.3.3-r101
>=dev-lua/lua_cliargs-3.0_p2-r100
>=dev-lua/lua-term-0.7-r100