summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-08-01 15:05:09 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-08-01 15:05:09 +0000
commit8747b9d5a7eb52058ca7d041c7a2cf35048ec4b6 (patch)
tree6c02aa67d23f19dbbf1110d4ab556be10b47159b
parent2020-08-01 14:35:18 UTC (diff)
parentmedia-libs/glm-0.9.9.8: fixes Fixed installation of provided CMake configurat... (diff)
downloadgentoo-8747b9d5a7eb52058ca7d041c7a2cf35048ec4b6.tar.gz
gentoo-8747b9d5a7eb52058ca7d041c7a2cf35048ec4b6.tar.bz2
gentoo-8747b9d5a7eb52058ca7d041c7a2cf35048ec4b6.zip
Merge updates from master
-rw-r--r--media-libs/glm/glm-0.9.9.8-r1.ebuild59
-rw-r--r--sys-kernel/gentoo-kernel-bin/Manifest2
-rw-r--r--sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-5.7.12.ebuild53
-rw-r--r--sys-kernel/gentoo-kernel/Manifest2
-rw-r--r--sys-kernel/gentoo-kernel/gentoo-kernel-5.7.12.ebuild85
-rw-r--r--sys-kernel/vanilla-kernel/Manifest1
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-5.7.12.ebuild77
-rw-r--r--xfce-base/xfwm4/Manifest2
-rw-r--r--xfce-base/xfwm4/xfwm4-4.14.4.ebuild70
-rw-r--r--xfce-base/xfwm4/xfwm4-4.15.0.ebuild70
10 files changed, 421 insertions, 0 deletions
diff --git a/media-libs/glm/glm-0.9.9.8-r1.ebuild b/media-libs/glm/glm-0.9.9.8-r1.ebuild
new file mode 100644
index 000000000000..d247d9fdf8e6
--- /dev/null
+++ b/media-libs/glm/glm-0.9.9.8-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="OpenGL Mathematics"
+HOMEPAGE="http://glm.g-truc.net/"
+SRC_URI="https://github.com/g-truc/glm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( HappyBunny MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_avx cpu_flags_x86_avx2"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.9.6-simd.patch
+ "${FILESDIR}"/${P}-clang.patch
+)
+
+src_configure() {
+ # Header-only library
+ if use test; then
+ local mycmakeargs=(
+ -DGLM_TEST_ENABLE=ON
+ -DGLM_TEST_ENABLE_SIMD_SSE2="$(usex cpu_flags_x86_sse2 ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_SSE3="$(usex cpu_flags_x86_sse3 ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_AVX="$(usex cpu_flags_x86_avx ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_AVX2="$(usex cpu_flags_x86_avx2 ON OFF)"
+ )
+ cmake_src_configure
+ fi
+
+ sed \
+ -e "s:@CMAKE_INSTALL_PREFIX@:${EPREFIX}/usr:" \
+ -e "s:@GLM_VERSION@:$(ver_cut 1-3):" \
+ "${FILESDIR}"/glm.pc.in \
+ > "${BUILD_DIR}/glm.pc" || die
+}
+
+src_compile() {
+ # Header-only library
+ if use test; then
+ cmake_src_compile
+ fi
+}
+
+src_install() {
+ doheader -r glm
+ insinto /usr/share/pkgconfig
+ doins "${BUILD_DIR}/glm.pc"
+ insinto /usr/share
+ doins -r cmake
+ dodoc readme.md manual.md
+}
diff --git a/sys-kernel/gentoo-kernel-bin/Manifest b/sys-kernel/gentoo-kernel-bin/Manifest
index d7ce006a34e5..cc8c3a14c070 100644
--- a/sys-kernel/gentoo-kernel-bin/Manifest
+++ b/sys-kernel/gentoo-kernel-bin/Manifest
@@ -8,5 +8,7 @@ DIST gentoo-kernel-5.4.55-1.amd64.xpak 61924753 BLAKE2B 7674db9b6da853e1782fef90
DIST gentoo-kernel-5.4.55-1.x86.xpak 53203656 BLAKE2B 4f7a52537a3f2578eeb4275cc285d4f7c695764cd4d68885627b86920b74680eba36b03f5e5d6caab3ffa2aaf1fa72812306d179b0b01bb608a400c4dee504f3 SHA512 5e94e83426d3b359935b7a7073ca1e9e6dd33b1207f9be59581f4bec5a5b74035a0cd4944207d2f3d8e2f31dc540298e02d12afafe549d311a8633a75824d6a9
DIST gentoo-kernel-5.7.10-1.amd64.xpak 62959097 BLAKE2B 7d10cd9af73be952e521afd696ecc9cac69e855284997ffc48cfb374ef45e379be721d6d71db6e81911c797597cea54dbca92c64aa1b774be89d6d9c8d64452b SHA512 34db8816fe6f2d125cd737eee207fb16c75ed061837b8e3d67b4aa8887942aa727869a725018bddf9b6b1928d3a0e093a0f441f7c49dc17e46364c523a56135f
DIST gentoo-kernel-5.7.10-1.x86.xpak 54968846 BLAKE2B e33923959281e22b40ca5205097938671aae0967e9a32a5c63628f2ef285b10cb0672ae2a59cbf641fea2521dab439a163e0c624ffb4788b0a8bf333db5efa73 SHA512 728d3eeb66c9bc8940cc3d745055d66c368c9bd7f133f903087b09655fd441a47ff75b48d6b2887a2d0be607de3a361c12dc8f5fb1ee58e74dcfa916dfa1f667
+DIST gentoo-kernel-5.7.12-1.amd64.xpak 63454910 BLAKE2B 6b7cd4c1070bce50ccb049285e475d00920552b2f4e11a9fba10894f7281f6a928c66f81dc19af6bb9cfe7c215a719c71fe3a9a1c0c8956bfa67283367be09cf SHA512 478a5cae6c31a1d09f9b57bda8a861f465b8d6aead7c231a08bb50f6e17c40d9f55b705f205fc9dfcf165173f1a5d2643e13cc565bc6bce51d3534e30f2e9976
+DIST gentoo-kernel-5.7.12-1.x86.xpak 54969313 BLAKE2B c8a74f8979c912a1a503b856c7fe0f8f4db05618cd9fc3fb94ddfa082b16e17621d24bdef9fc20384ddd465ec4df3ea29017bb4eded70b56e73172afdfa64558 SHA512 be88ebe1d9c79f9de339b4fddac73db1f12cedfbdcaebd8d5220747d0897360864b56fe821749d8d320eb219b05dff0d7afb2152eefdfe791b28c615d5cd69f2
DIST tinycorelinux-10.1-amd64.qcow2 16842752 BLAKE2B e013e76503c335739a9623c0901ca791937a0e6b177854535cadec1e2c2cd2df588283ed3128cf652595f32264fbfe5b3bd3a8c97665fd4da344e308535be366 SHA512 c3aeb20ff8769da9211694b7f701907cc7ae7582cdfad2c2fdc008d97ebcbd9dc08245b4e8f8450e1cb304bd705345a11fe79f901a47979fee91443841d55641
DIST tinycorelinux-10.1-x86.qcow2 14876672 BLAKE2B 3c760eb7438b13261e52ecfaa33a53649ced95f1ab40aae52134b8cdc31a16d7aa0d6a6dd716e268ed148e9d77a10b7c700b141b61d70c82d271ffe88e8e2a3c SHA512 9964538dc42f232a11949f74b61d46422ea5da3bdc253a217119bd0b8a750c40fd2da0b07157067be9ac0226472614f210a1248114df0d331df390979867a895
diff --git a/sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-5.7.12.ebuild b/sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-5.7.12.ebuild
new file mode 100644
index 000000000000..dca6aedbd789
--- /dev/null
+++ b/sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-5.7.12.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-install
+
+MY_P=${P/-bin/}-1
+DESCRIPTION="Pre-built Linux kernel with genpatches"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI+="
+ amd64? (
+ https://dev.gentoo.org/~mgorny/binpkg/amd64/kernel/sys-kernel/gentoo-kernel/${MY_P}.xpak
+ -> ${MY_P}.amd64.xpak
+ )
+ x86? (
+ https://dev.gentoo.org/~mgorny/binpkg/x86/kernel/sys-kernel/gentoo-kernel/${MY_P}.xpak
+ -> ${MY_P}.x86.xpak
+ )"
+S=${WORKDIR}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ !sys-kernel/gentoo-kernel:${SLOT}
+ !sys-kernel/vanilla-kernel:${SLOT}
+ !sys-kernel/vanilla-kernel-bin:${SLOT}"
+
+QA_PREBUILT='*'
+
+pkg_pretend() {
+ ewarn "Starting with 5.7.9, Distribution Kernels are switching from Arch"
+ ewarn "Linux configs to Fedora. Please keep a backup kernel just in case."
+
+ kernel-install_pkg_pretend
+}
+
+src_unpack() {
+ ebegin "Unpacking ${MY_P}.${ARCH}.xpak"
+ tar -x < <(xz -c -d --single-stream "${DISTDIR}/${MY_P}.${ARCH}.xpak")
+ eend ${?} || die "Unpacking ${MY_P} failed"
+}
+
+src_test() {
+ kernel-install_test "${PV}" \
+ "${WORKDIR}/usr/src/linux-${PV}/$(kernel-install_get_image_path)" \
+ "lib/modules/${PV}"
+}
+
+src_install() {
+ mv * "${ED}" || die
+}
diff --git a/sys-kernel/gentoo-kernel/Manifest b/sys-kernel/gentoo-kernel/Manifest
index d69a8f84e99d..5603341f59f9 100644
--- a/sys-kernel/gentoo-kernel/Manifest
+++ b/sys-kernel/gentoo-kernel/Manifest
@@ -8,6 +8,8 @@ DIST genpatches-5.4-55.base.tar.xz 2129856 BLAKE2B a9c688be16c22e0e563c0fa3c9439
DIST genpatches-5.4-55.extras.tar.xz 1768 BLAKE2B 195b5747cee6c3302bdcc2cb9b05f0cb87c367bb63e7a0afdc93127cf2844e8babf9bd378370217d57364c9a3bd0eccf01a41b40606ef1feb96ef90e9e67f91a SHA512 32bfd86dad656b6f9878df9c7bf17557cb553e540c34ba8f4fe9bd9b4d42c006a62c29d465d91a67933e27bdbf9a1e35c3b87d95166822b48bdde2584bc8edf1
DIST genpatches-5.7-11.base.tar.xz 532736 BLAKE2B 9f5b5d8304c22cac1e081be759a6731c5902e2afc241c79dad2518083b9d56edb34f5ca2d9b39fea84cbe0e6569314e0db84eb69027830b997a6e318b6e27c13 SHA512 43bd55fef87afc5e97fc9d4d13705f6790eca5c1874fd266da2109ea0ac913e812e156cd231d67d3494f743f2263d33292770c4be9a8009e0c6f85704d77b21e
DIST genpatches-5.7-11.extras.tar.xz 1764 BLAKE2B 655bba046d32ee61d8b026f462e35c4e58536afbfdb37de32380a253fedceeac2da42a1366ecbe0b7e156f25319f67ad61a5eb51ba762fd8958068f1f1c0d0bf SHA512 b26c720473ffdef3ac40955692660ee4645a93e2cb86a76d1583d878c3832f3c8bdcbdc23bc6838c1d0255ec86a5671d4e205cb6e99dd5a1d64405fe0081a355
+DIST genpatches-5.7-13.base.tar.xz 581360 BLAKE2B 16841cdedf5ac9fd897e6c3ea6f428a4bbde48dca1c5f6d432d1c63248d6cec9157d4f0680cf340cc08703715afb32db342aa837a978c29b1874917d13454dd6 SHA512 aa15be557a74258476d777575cbe98148bb99104f221206e5d1589dfee89ab7ed2637a4e6dd044f477e3c5b0388faf399dc7241951c37a1df405981927f9973c
+DIST genpatches-5.7-13.extras.tar.xz 1768 BLAKE2B 49f3af716da6e9029ca774056259e2f4521dbbcde9d453c71987d105b628934738eb96cd622ec92d338ed7fd9c17b0f99d82154b240258c299f1e55ecee938e3 SHA512 0cb1d9affd59a93596ea0c41f888a451440b6efd0788b47cfecbf6ee41b24685cf0b7c9ac43a0cb1375086809fc1423c3c2ef1bffa93eb60c4f653d473441d66
DIST kernel-i686-fedora.config.5.7.8 191864 BLAKE2B 217857254ffd12e987a5bd573e2520508bc70764b6363fc2c6bda1e5be46b70528616b26167150cba32f9e57fe17883c455fed34615a216b2398017d307971db SHA512 b90c6f2cdb55bcb115d7b92752a6efd8fdc09f68acbf365b08c9ff89732745f26d2644e18cb097ffd92d75cff07dbd98a9723179a35dc72ce01a732bdd632592
DIST kernel-i686.config.5.4.21 183910 BLAKE2B 185126ffb85718bb73761d01683def80b6f002d7a7a6eddd8e858a30d8eadc863fb378d83a1cd2ed82b3540337fa66ae44475e31fb41ebc46d77005b6f54e5c0 SHA512 6307afc2295902e44fe65b1cccaa7a0260b295a5f21f1d67ec66197bd972bd3f5675b624f08d9da8b224cb3ec987d5c21cbd743599aeab9ac6214bc651f43476
DIST kernel-x86_64-fedora.config.5.7.8 192882 BLAKE2B 23044bd3625d1ced686950c1322e91dd99eddb3128ab830c8862f5c949b66df67bc9ce38b810f4d54a35f9b9f11feb58d01450593ec513e132d789e3a50ac48b SHA512 b7770da1f608e8f0ec227dbeaf66491815e9fc4f8f08f01d2ad5877dd1946e73b315e8834f35cb5fc035fc3ac52ede8365107515d54b0792f326ad937d901625
diff --git a/sys-kernel/gentoo-kernel/gentoo-kernel-5.7.12.ebuild b/sys-kernel/gentoo-kernel/gentoo-kernel-5.7.12.ebuild
new file mode 100644
index 000000000000..f0988ba69fb4
--- /dev/null
+++ b/sys-kernel/gentoo-kernel/gentoo-kernel-5.7.12.ebuild
@@ -0,0 +1,85 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-build
+
+MY_P=linux-${PV%.*}
+GENPATCHES_P=genpatches-${PV%.*}-$(( ${PV##*.} + 1 ))
+# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
+CONFIG_VER=5.7.8
+CONFIG_HASH=14d239184a721485a823f30f5aede1c6190558ad
+
+DESCRIPTION="Linux kernel built with Gentoo patches"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ https://dev.gentoo.org/~mpagano/dist/genpatches/${GENPATCHES_P}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/dist/genpatches/${GENPATCHES_P}.extras.tar.xz
+ amd64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-x86_64-fedora.config
+ -> kernel-x86_64-fedora.config.${CONFIG_VER}
+ )
+ x86? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-i686-fedora.config
+ -> kernel-i686-fedora.config.${CONFIG_VER}
+ )"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="debug"
+REQUIRED_USE="
+ arm? ( savedconfig )
+ arm64? ( savedconfig )"
+
+RDEPEND="
+ !sys-kernel/vanilla-kernel:${SLOT}
+ !sys-kernel/vanilla-kernel-bin:${SLOT}"
+BDEPEND="
+ debug? ( dev-util/dwarves )"
+
+pkg_pretend() {
+ ewarn "Starting with 5.7.9, Distribution Kernels are switching from Arch"
+ ewarn "Linux configs to Fedora. Please keep a backup kernel just in case."
+
+ kernel-install_pkg_pretend
+}
+
+src_prepare() {
+ local PATCHES=(
+ # meh, genpatches have no directory
+ "${WORKDIR}"/*.patch
+ )
+ default
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ x86)
+ cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ arm|arm64)
+ return
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ local config_tweaks=(
+ # shove arch under the carpet!
+ -e 's:^CONFIG_DEFAULT_HOSTNAME=:&"gentoo":'
+ # we do support x32
+ -e '/CONFIG_X86_X32/s:.*:CONFIG_X86_X32=y:'
+ # disable signatures
+ -e '/CONFIG_MODULE_SIG/d'
+ -e '/CONFIG_SECURITY_LOCKDOWN/d'
+ )
+ use debug || config_tweaks+=(
+ -e '/CONFIG_DEBUG_INFO/d'
+ )
+ sed -i "${config_tweaks[@]}" .config || die
+}
diff --git a/sys-kernel/vanilla-kernel/Manifest b/sys-kernel/vanilla-kernel/Manifest
index 127ff100cf42..4feb7c5b8a3a 100644
--- a/sys-kernel/vanilla-kernel/Manifest
+++ b/sys-kernel/vanilla-kernel/Manifest
@@ -9,5 +9,6 @@ DIST linux-5.4.52.tar.xz 109563772 BLAKE2B 32995d32bfc9ee5d6a5669941897890fc7657
DIST linux-5.4.53.tar.xz 109574076 BLAKE2B 3e15c19449149415e560cf2b602fec20d60d2b35187283edb4421e4909c3fc8d9c734eba60e7fcca6f3694feb95246cb7295b57e96773fc8d69b8a5ef14e55be SHA512 bf0c0164969ffe52792c15d24f630cb33cee60801252fb6e45b751f5cf6cf807dc8c97c77caff6fdc53d754b87715f27779978f0f5ecfb83836f9a8342f21615
DIST linux-5.4.55.tar.xz 109570356 BLAKE2B 87ae06ef810727428acd8d7b823309c71b36d6cbf4614e3230d632aecc74bfc45cc7b363a77062f26073dae3d5199200908e21a64e276bfaa66e71648a3c91fe SHA512 6ce15984395698b28932ab1d66165e491588fd924e4880e4dca2c5665b636fb271b8028dd23354b81640ce7e12989807a71360144cb87708b7f239e021b2b56c
DIST linux-5.7.10.tar.xz 112722840 BLAKE2B 5b76a6b99ea0b1e38278db62951147edd2f0dcbc7c28d6fbf955beaa25344c62ee5b4d8c1c80e9e980a44d77b31dfc152b7e1d0fe0e57f5968f25b0d8a6d2dca SHA512 9568f87d593ae56dee4c7b8594f495a9c971558a3c73de8bb27336877bd5e71500ec08d880c5854e52ce338775bb9c30a98c1b9cdb789dbedba95bd3d86362ca
+DIST linux-5.7.12.tar.xz 112734632 BLAKE2B fb8f51e370f420a6f18329945addb05df3c264d06bcd7f03b6a9582ab2a13f843cd3ce99f6ce39546f882775ef473f335185ea54f38aab03e8956ae946f1e28f SHA512 8630936f2ea67fa4eaeea759f91dd71e35c294947ae6f71953ac3d99e5f93971f8c2b9e0eb18b09a35a3993e7ef648ca17160600aa07ea24f3beed44f3ed5a75
DIST tinycorelinux-10.1-amd64.qcow2 16842752 BLAKE2B e013e76503c335739a9623c0901ca791937a0e6b177854535cadec1e2c2cd2df588283ed3128cf652595f32264fbfe5b3bd3a8c97665fd4da344e308535be366 SHA512 c3aeb20ff8769da9211694b7f701907cc7ae7582cdfad2c2fdc008d97ebcbd9dc08245b4e8f8450e1cb304bd705345a11fe79f901a47979fee91443841d55641
DIST tinycorelinux-10.1-x86.qcow2 14876672 BLAKE2B 3c760eb7438b13261e52ecfaa33a53649ced95f1ab40aae52134b8cdc31a16d7aa0d6a6dd716e268ed148e9d77a10b7c700b141b61d70c82d271ffe88e8e2a3c SHA512 9964538dc42f232a11949f74b61d46422ea5da3bdc253a217119bd0b8a750c40fd2da0b07157067be9ac0226472614f210a1248114df0d331df390979867a895
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-5.7.12.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-5.7.12.ebuild
new file mode 100644
index 000000000000..079fc98c2af1
--- /dev/null
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-5.7.12.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-build
+
+MY_P=linux-${PV}
+# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
+CONFIG_VER=5.7.8
+CONFIG_HASH=14d239184a721485a823f30f5aede1c6190558ad
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ amd64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-x86_64-fedora.config
+ -> kernel-x86_64-fedora.config.${CONFIG_VER}
+ )
+ x86? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-i686-fedora.config
+ -> kernel-i686-fedora.config.${CONFIG_VER}
+ )"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="debug"
+REQUIRED_USE="
+ arm? ( savedconfig )
+ arm64? ( savedconfig )"
+
+RDEPEND="
+ !sys-kernel/vanilla-kernel-bin:${SLOT}"
+BDEPEND="
+ debug? ( dev-util/dwarves )"
+
+pkg_pretend() {
+ ewarn "Starting with 5.7.9, Distribution Kernels are switching from Arch"
+ ewarn "Linux configs to Fedora. Please keep a backup kernel just in case."
+
+ kernel-install_pkg_pretend
+}
+
+src_prepare() {
+ default
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ x86)
+ cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ arm|arm64)
+ return
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ local config_tweaks=(
+ # shove arch under the carpet!
+ -e 's:^CONFIG_DEFAULT_HOSTNAME=:&"gentoo":'
+ # we do support x32
+ -e '/CONFIG_X86_X32/s:.*:CONFIG_X86_X32=y:'
+ # disable signatures
+ -e '/CONFIG_MODULE_SIG/d'
+ -e '/CONFIG_SECURITY_LOCKDOWN/d'
+ )
+ use debug || config_tweaks+=(
+ -e '/CONFIG_DEBUG_INFO/d'
+ )
+ sed -i "${config_tweaks[@]}" .config || die
+}
diff --git a/xfce-base/xfwm4/Manifest b/xfce-base/xfwm4/Manifest
index 5996d1caa9fd..e92693d811aa 100644
--- a/xfce-base/xfwm4/Manifest
+++ b/xfce-base/xfwm4/Manifest
@@ -1,3 +1,5 @@
DIST xfwm4-4.14.0.tar.bz2 1122735 BLAKE2B 1865c0714ddd4107e806de5607ef0e260c3fd1b6c9abcbec112a126bf780f456873786595a4cb924ce2154a40868670699519e4bb4576d971f853f7d3f63e98c SHA512 27261b08b53ba7e70db547db81775154c2f4285ab0f1f8336bd9ef0aeacb3ab705ae8ac5b05f9ac23de550a9065e76487dc93a99e553549bff1c25ceb5216939
DIST xfwm4-4.14.2.tar.bz2 1158799 BLAKE2B 87270997688a44e1476935f2158842999befebf18628f6cd92131d81beac2f0a91db0a6522f86340688285fd67cf48e94259bdb2e4ce8df567eba83319bb31e3 SHA512 9e28f7782ce6c1734f9a50efec75d4c03a193bf078fd29f42c11770cef134c4516c256cb9c4b92a71bbbbfca81f37ba0ce19477831bb1da858c839135005b8f2
DIST xfwm4-4.14.3.tar.bz2 1164653 BLAKE2B 24db309df708164bd0554fb96499205b4f1437023c014d571ba86f7419e09e23ffdacbf31d3afd05b7bd4f4e8e88394cfe34ec233518078b88eb8c0c640b8af7 SHA512 eb27c9d540a4b1d773f31c16dd8e7e4cd8fb833514ecc62251c68b53e88440beccb4923c49c66a29b387c77e2e69cb36e83d0a3d457ef8e7fdd5d2b925fdfda6
+DIST xfwm4-4.14.4.tar.bz2 1164972 BLAKE2B 5bdf4837bd19708c975d6400750059c5182b9d1b1a0b7b30e8721e1c443d9f78c1ea1c868ad7ceb384e442b94139b89d50327dc6413e938348816a311cada2b2 SHA512 ca3c94d1835076b904aca9f531dccebd9d78a1c85e0f7af7ac7aaba1a067e0f11f5224bdc20dc233038dc752ae1ac85602608c168a4d91643ac7538b448c04bf
+DIST xfwm4-4.15.0.tar.bz2 1179779 BLAKE2B c12ec365218b8afda7b01706d4f2822b4663d327aad482e89f8c8b2811b687594c6f58ea0b5be79eabe3771c125edb111c3b03a708dcfbf720eef993181b0e14 SHA512 8359c8e9414bc7a66a95c4b9eb98da7a3ba08c0e15752c2ebb4a569f9afcd50697d37685c786d6a4c23f1bfa12f8782293923fde309c7d027cf66dd4db44340e
diff --git a/xfce-base/xfwm4/xfwm4-4.14.4.ebuild b/xfce-base/xfwm4/xfwm4-4.14.4.ebuild
new file mode 100644
index 000000000000..77ed670eb91b
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.14.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="opengl startup-notification +xcomposite +xpresent"
+
+RDEPEND=">=dev-libs/glib-2.20
+ >=x11-libs/gtk+-3.20:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXres
+ x11-libs/pango
+ >=x11-libs/libwnck-3.14:3
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfconf-4.13:=
+ opengl? ( media-libs/libepoxy:=[X(+)] )
+ startup-notification? ( x11-libs/startup-notification )
+ xpresent? ( x11-libs/libXpresent )
+ xcomposite? (
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ )"
+# libICE/libSM: not really used anywhere but checked by configure
+# https://bugzilla.xfce.org/show_bug.cgi?id=11914
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ x11-libs/libICE
+ x11-libs/libSM
+ xfce-base/exo
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog COMPOSITOR NEWS README TODO )
+
+src_configure() {
+ local myconf=(
+ $(use_enable opengl epoxy)
+ $(use_enable startup-notification)
+ --enable-xsync
+ --enable-render
+ --enable-randr
+ $(use_enable xpresent)
+ $(use_enable xcomposite compositor)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/xfce-base/xfwm4/xfwm4-4.15.0.ebuild b/xfce-base/xfwm4/xfwm4-4.15.0.ebuild
new file mode 100644
index 000000000000..77ed670eb91b
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.15.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="opengl startup-notification +xcomposite +xpresent"
+
+RDEPEND=">=dev-libs/glib-2.20
+ >=x11-libs/gtk+-3.20:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXres
+ x11-libs/pango
+ >=x11-libs/libwnck-3.14:3
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfconf-4.13:=
+ opengl? ( media-libs/libepoxy:=[X(+)] )
+ startup-notification? ( x11-libs/startup-notification )
+ xpresent? ( x11-libs/libXpresent )
+ xcomposite? (
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ )"
+# libICE/libSM: not really used anywhere but checked by configure
+# https://bugzilla.xfce.org/show_bug.cgi?id=11914
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ x11-libs/libICE
+ x11-libs/libSM
+ xfce-base/exo
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog COMPOSITOR NEWS README TODO )
+
+src_configure() {
+ local myconf=(
+ $(use_enable opengl epoxy)
+ $(use_enable startup-notification)
+ --enable-xsync
+ --enable-render
+ --enable-randr
+ $(use_enable xpresent)
+ $(use_enable xcomposite compositor)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}