summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-14 21:37:43 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-14 21:37:43 +0100
commit8b99fef75a03d35148b40b12858edaa273ebaf50 (patch)
tree3c3d31b1620163a479c9b9529592de32d9544069
parentdev-util/cutter: add 2.0.5 (diff)
downloadgentoo-8b99fef75a03d35148b40b12858edaa273ebaf50.tar.gz
gentoo-8b99fef75a03d35148b40b12858edaa273ebaf50.tar.bz2
gentoo-8b99fef75a03d35148b40b12858edaa273ebaf50.zip
dev-ml/bos: CFLAGS not applicable
Closes: https://bugs.gentoo.org/821715 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/bos/bos-0.1.6.ebuild4
-rw-r--r--dev-ml/bos/bos-0.2.0-r1.ebuild4
-rw-r--r--dev-ml/bos/bos-0.2.1.ebuild7
3 files changed, 10 insertions, 5 deletions
diff --git a/dev-ml/bos/bos-0.1.6.ebuild b/dev-ml/bos/bos-0.1.6.ebuild
index 1c8791ab0f6b..5f7598f42cb0 100644
--- a/dev-ml/bos/bos-0.1.6.ebuild
+++ b/dev-ml/bos/bos-0.1.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,6 +28,8 @@ DEPEND="${RDEPEND}
test? ( dev-ml/mtime )
"
+QA_FLAGS_IGNORED='.*'
+
src_compile() {
ocaml pkg/pkg.ml build --tests $(usex test true false) || die
}
diff --git a/dev-ml/bos/bos-0.2.0-r1.ebuild b/dev-ml/bos/bos-0.2.0-r1.ebuild
index b4f383fa7696..f855848aa0a6 100644
--- a/dev-ml/bos/bos-0.2.0-r1.ebuild
+++ b/dev-ml/bos/bos-0.2.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,8 @@ BDEPEND="dev-ml/findlib
dev-ml/topkg
test? ( dev-ml/mtime )"
+QA_FLAGS_IGNORED='.*'
+
src_compile() {
ocaml pkg/pkg.ml build --tests $(usex test true false) || die
}
diff --git a/dev-ml/bos/bos-0.2.1.ebuild b/dev-ml/bos/bos-0.2.1.ebuild
index c994f58f5094..0d5451288a35 100644
--- a/dev-ml/bos/bos-0.2.1.ebuild
+++ b/dev-ml/bos/bos-0.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,8 +23,9 @@ RDEPEND="dev-lang/ocaml:=
DEPEND="${RDEPEND}"
BDEPEND="dev-ml/findlib
dev-ml/ocamlbuild
- dev-ml/topkg
- test? ( dev-ml/mtime )"
+ dev-ml/topkg"
+
+QA_FLAGS_IGNORED='.*'
src_compile() {
ocaml pkg/pkg.ml build --tests $(usex test true false) || die