summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-03-20 10:19:25 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-03-20 10:19:25 +0000
commit8f7a2a58ec45038f0cbc2f899f87f689fdf3e79d (patch)
treef388aa80e91d2a18202e50badde447c1a5eb382b
parent2022-03-20 09:34:26 UTC (diff)
parentwww-servers/adsf: add ruby30; EAPI 8 (diff)
downloadgentoo-8f7a2a58ec45038f0cbc2f899f87f689fdf3e79d.tar.gz
gentoo-8f7a2a58ec45038f0cbc2f899f87f689fdf3e79d.tar.bz2
gentoo-8f7a2a58ec45038f0cbc2f899f87f689fdf3e79d.zip
Merge updates from master
-rw-r--r--dev-ruby/abstract/abstract-1.0.0-r5.ebuild23
-rw-r--r--dev-ruby/activesupport/activesupport-6.1.5.ebuild2
-rw-r--r--dev-ruby/bacon/bacon-1.2.0-r4.ebuild20
-rw-r--r--dev-ruby/capybara/capybara-3.36.0.ebuild6
-rw-r--r--dev-ruby/dalli/Manifest1
-rw-r--r--dev-ruby/dalli/dalli-3.2.1.ebuild38
-rw-r--r--dev-ruby/erubis/erubis-2.7.0-r4.ebuild39
-rw-r--r--dev-ruby/excon/Manifest3
-rw-r--r--dev-ruby/excon/excon-0.88.0.ebuild40
-rw-r--r--dev-ruby/excon/excon-0.89.0.ebuild40
-rw-r--r--dev-ruby/excon/excon-0.90.0.ebuild40
-rw-r--r--dev-ruby/rack-test/rack-test-1.1.0-r1.ebuild38
-rw-r--r--dev-ruby/rash_alt/rash_alt-0.4.12.ebuild2
-rw-r--r--dev-ruby/sinatra/sinatra-2.1.0-r1.ebuild34
-rw-r--r--dev-ruby/slim/slim-4.1.0-r2.ebuild55
-rw-r--r--dev-ruby/temple/temple-0.8.2-r1.ebuild27
-rw-r--r--dev-ruby/tilt/files/tilt-2.0.10-ruby30.patch37
-rw-r--r--dev-ruby/tilt/tilt-2.0.10-r1.ebuild46
-rw-r--r--dev-ruby/treetop/treetop-1.6.11-r1.ebuild37
-rw-r--r--dev-ruby/typhoeus/Manifest1
-rw-r--r--dev-ruby/typhoeus/typhoeus-1.3.1.ebuild30
-rw-r--r--www-servers/adsf/adsf-1.4.6-r1.ebuild40
22 files changed, 440 insertions, 159 deletions
diff --git a/dev-ruby/abstract/abstract-1.0.0-r5.ebuild b/dev-ruby/abstract/abstract-1.0.0-r5.ebuild
new file mode 100644
index 000000000000..1febb53a86ce
--- /dev/null
+++ b/dev-ruby/abstract/abstract-1.0.0-r5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library which enable you to define abstract method in Ruby"
+HOMEPAGE="https://rubygems.org/gems/abstract"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test.rb || die "tests failed"
+}
diff --git a/dev-ruby/activesupport/activesupport-6.1.5.ebuild b/dev-ruby/activesupport/activesupport-6.1.5.ebuild
index cfa49feb955e..e5022b82fb44 100644
--- a/dev-ruby/activesupport/activesupport-6.1.5.ebuild
+++ b/dev-ruby/activesupport/activesupport-6.1.5.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
diff --git a/dev-ruby/bacon/bacon-1.2.0-r4.ebuild b/dev-ruby/bacon/bacon-1.2.0-r4.ebuild
new file mode 100644
index 000000000000..ead575f2f4a5
--- /dev/null
+++ b/dev-ruby/bacon/bacon-1.2.0-r4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Small RSpec clone weighing less than 350 LoC"
+HOMEPAGE="http://chneukirchen.org/repos/bacon"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rdoc )"
diff --git a/dev-ruby/capybara/capybara-3.36.0.ebuild b/dev-ruby/capybara/capybara-3.36.0.ebuild
index f397a281989d..3a96df44af06 100644
--- a/dev-ruby/capybara/capybara-3.36.0.ebuild
+++ b/dev-ruby/capybara/capybara-3.36.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30"
RUBY_FAKEGEM_EXTRADOC="History.md README.md"
@@ -24,7 +24,7 @@ DEPEND="${DEPEND} test? ( || ( www-client/firefox www-client/firefox-bin ) )"
ruby_add_bdepend "test? (
dev-ruby/rspec:3
>=dev-ruby/launchy-2.4.0
- >=dev-ruby/selenium-webdriver-3.5:3
+ || ( dev-ruby/selenium-webdriver:4 >=dev-ruby/selenium-webdriver-3.142.7:3 )
dev-ruby/sinatra:2
www-servers/puma
)"
diff --git a/dev-ruby/dalli/Manifest b/dev-ruby/dalli/Manifest
index 055e499960b6..e1622680a215 100644
--- a/dev-ruby/dalli/Manifest
+++ b/dev-ruby/dalli/Manifest
@@ -1,2 +1,3 @@
DIST dalli-2.7.11.tar.gz 52341 BLAKE2B 5b3a2bc57f4b0e3a9ac0d24ffa3bba89ea38665ac08ef3d7760fa6ce74db21d323a18e74a4f3009165364332731d7c6890df36c68409afbe21d3ac096275f028 SHA512 8f299a19d95293370564b6337bbdfeb32d928e0a95bf5f5df962ea20b039f4765da1797513ca96cabf93309484575481a02fb1e0c6d227f74c81fc72f95be22a
DIST dalli-3.0.3.tar.gz 47633 BLAKE2B ee47bc7e4efcbd0d60c1663bf514f5a21d0fdeb70cfcf13ba46ae3c39926fd216db992c7ac1750d73ecf453d32feea9d2c22625b737e0bcbb8ae0d6870536828 SHA512 1feaecca963a6a4aa2f21e02302ddb5865fec0f5779911b4ec38a1199533b82edca46057355fa463353a8c7a6da3bf7c835ce51ca538bc38eb6014d4d362acb3
+DIST dalli-3.2.1.tar.gz 69926 BLAKE2B c3cd0c6d817b04aed786df7792b84c8659fa1ea79d69d2fc477549869fb5d7d4880c1d897f90c35020c04babc17f16ee55724339b150eec1a8b887de27b4d02e SHA512 5328ea5aecb4270a33ca08f498588f08259b56e36e1ed404f062d39b8693874878f019dbfe154892b1d192ec136f5473da5612ee7d095b8760caf628be3c67a7
diff --git a/dev-ruby/dalli/dalli-3.2.1.ebuild b/dev-ruby/dalli/dalli-3.2.1.ebuild
new file mode 100644
index 000000000000..369cc09700c0
--- /dev/null
+++ b/dev-ruby/dalli/dalli-3.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=true test"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.md Performance.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance pure Ruby client for accessing memcached servers"
+HOMEPAGE="https://github.com/petergoldstein/dalli"
+SRC_URI="https://github.com/petergoldstein/dalli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND+="${DEPEND} test? ( >=net-misc/memcached-1.5.4[ssl(-)] )"
+
+ruby_add_bdepend "test? (
+ dev-ruby/minitest:5
+ dev-ruby/rack
+)"
+
+all_ruby_prepare() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ sed -i -e '/\(appraisal\|bundler\)/ s:^:#:' Rakefile || die
+
+ sed -i -e '3igem "minitest", "~> 5.0"; require "dalli"' \
+ -e '/bundler/ s:^:#:' test/helper.rb || die
+}
diff --git a/dev-ruby/erubis/erubis-2.7.0-r4.ebuild b/dev-ruby/erubis/erubis-2.7.0-r4.ebuild
new file mode 100644
index 000000000000..92f69e6d44fe
--- /dev/null
+++ b/dev-ruby/erubis/erubis-2.7.0-r4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Erubis is an implementation of eRuby"
+HOMEPAGE="http://www.kuwata-lab.com/erubis/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# http://rubyforge.org/tracker/index.php?func=detail&aid=29484&group_id=1320&atid=5201
+# Tests are not compatible with Psych as YAML module.
+RESTRICT="test"
+
+ruby_add_rdepend ">=dev-ruby/abstract-1.0.0"
+
+all_ruby_prepare() {
+ # These tests now fail due to other ordering and fact that sym
+ # are now returned.
+ rm test/test-users-guide.rb || die
+ sed -i -e '/test-users-guide/ s:^:#:' test/test.rb || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -I. test/test.rb || die
+}
diff --git a/dev-ruby/excon/Manifest b/dev-ruby/excon/Manifest
index 77b19b8e1a7f..6037f17e2438 100644
--- a/dev-ruby/excon/Manifest
+++ b/dev-ruby/excon/Manifest
@@ -1,5 +1,2 @@
-DIST excon-0.88.0.tar.gz 210056 BLAKE2B abffad837a6a2a7337e43fc73d1f4004f6df01113f475e44daa48e21cef95f363bd5fbf88be0093fb18564d382fae5f4409e23689e11b5c47bc900f708ea7455 SHA512 5cb664e64973959dffb80f421bd70c300303fb6c4083b06f6bb42be8987a8822dc4ae38892467576583ec5dccd696b68dee7a946c3917df2066ebfc2afb72209
-DIST excon-0.89.0.tar.gz 210503 BLAKE2B 3988bdff1db39a84ba6230bb8d789662bbf589e89ea637a8b3208095d0d26f4bc83f0994fca5db92de162e2882d2a519f2d9f3c4f535d123d2b018d4abd82d60 SHA512 36e23d93983098ad14b9169b7ae65c28903e8a46a2d8cd341ce111387a83fb90a7f01973d401c8089844355d18a6e53da117df3c3fcb82cf66eb5367e065e2ee
-DIST excon-0.90.0.tar.gz 210538 BLAKE2B a3e5898e3985ebdfc4026355f4761b1b0d9367408e01a119101fa2453924ff751d888ab976382b654b846e0ed9908054aab6ac1f6410a2a96056b7c8d8d977ad SHA512 efcc9a13b8715306f980cd4593c44befcf895f5c42f9475211420e67247d9eeefecddae53ba771710a6894ca23bf880158e7cdf9db895baa42ef3c5436ac846a
DIST excon-0.91.0.tar.gz 214359 BLAKE2B 82e0ee05c0f2e9eb0bbf9371459e43d02e75d72063f24738b0230272aaeeef5f5985eedf5c0e72a2962a093ee5bc2431b4de171835067a23f1b2fe26a1a7f609 SHA512 ab5b535bbc6f1bad408481c2496a101a198de3899fc185df6aff4377c5c22dcf39af5e022ee52fff111f84f20fed11f75237da0ede0237c3a3ffc5eb405db923
DIST excon-0.92.0.tar.gz 214364 BLAKE2B b0909aa0976085a7b720951623b7d341e370e23fc15972d955c9175f396a91bac3d22d244c092828532f3ad79d71ef77835d03e658c359f69c1d945c5fe25b42 SHA512 4e9ce9e0dceb9ff2983e6e10cd1224035a44b658398a3a0fb2fd13f1c36682965be383d4580c901551b4e503f3e9ac72a20bdbb31bbb690b781103866824e540
diff --git a/dev-ruby/excon/excon-0.88.0.ebuild b/dev-ruby/excon/excon-0.88.0.ebuild
deleted file mode 100644
index fa5718fb67c2..000000000000
--- a/dev-ruby/excon/excon-0.88.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="changelog.txt README.md"
-RUBY_FAKEGEM_GEMSPEC="excon.gemspec"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-inherit ruby-fakegem
-
-DESCRIPTION="EXtended http(s) CONnections"
-HOMEPAGE="https://github.com/excon/excon"
-SRC_URI="https://github.com/excon/excon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-ruby_add_bdepend "
- dev-ruby/rake
- test? (
- dev-ruby/activesupport
- >=dev-ruby/eventmachine-1.0.4
- >=dev-ruby/json-1.8.5
- dev-ruby/open4
- dev-ruby/rdoc
- dev-ruby/sinatra
- )
-"
-all_ruby_prepare() {
- sed -i -e 's/git ls-files --/find */' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # test that need network
- rm -f spec/excon/test/server_spec.rb || die
-}
diff --git a/dev-ruby/excon/excon-0.89.0.ebuild b/dev-ruby/excon/excon-0.89.0.ebuild
deleted file mode 100644
index fa5718fb67c2..000000000000
--- a/dev-ruby/excon/excon-0.89.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="changelog.txt README.md"
-RUBY_FAKEGEM_GEMSPEC="excon.gemspec"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-inherit ruby-fakegem
-
-DESCRIPTION="EXtended http(s) CONnections"
-HOMEPAGE="https://github.com/excon/excon"
-SRC_URI="https://github.com/excon/excon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-ruby_add_bdepend "
- dev-ruby/rake
- test? (
- dev-ruby/activesupport
- >=dev-ruby/eventmachine-1.0.4
- >=dev-ruby/json-1.8.5
- dev-ruby/open4
- dev-ruby/rdoc
- dev-ruby/sinatra
- )
-"
-all_ruby_prepare() {
- sed -i -e 's/git ls-files --/find */' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # test that need network
- rm -f spec/excon/test/server_spec.rb || die
-}
diff --git a/dev-ruby/excon/excon-0.90.0.ebuild b/dev-ruby/excon/excon-0.90.0.ebuild
deleted file mode 100644
index 84ee1858942c..000000000000
--- a/dev-ruby/excon/excon-0.90.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="changelog.txt README.md"
-RUBY_FAKEGEM_GEMSPEC="excon.gemspec"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-inherit ruby-fakegem
-
-DESCRIPTION="EXtended http(s) CONnections"
-HOMEPAGE="https://github.com/excon/excon"
-SRC_URI="https://github.com/excon/excon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-ruby_add_bdepend "
- dev-ruby/rake
- test? (
- dev-ruby/activesupport
- >=dev-ruby/eventmachine-1.0.4
- >=dev-ruby/json-1.8.5
- dev-ruby/open4
- dev-ruby/rdoc
- dev-ruby/sinatra
- )
-"
-all_ruby_prepare() {
- sed -i -e 's/git ls-files --/find */' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # test that need network
- rm -f spec/excon/test/server_spec.rb || die
-}
diff --git a/dev-ruby/rack-test/rack-test-1.1.0-r1.ebuild b/dev-ruby/rack-test/rack-test-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..fff17aea6b0d
--- /dev/null
+++ b/dev-ruby/rack-test/rack-test-1.1.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="History.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rack::Test is a small, simple testing API for Rack apps"
+HOMEPAGE="https://github.com/rack-test/rack-test"
+SRC_URI="https://github.com/rack-test/rack-test/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rack-1.0:* <dev-ruby/rack-3:*"
+ruby_add_bdepend "
+ test? ( dev-ruby/sinatra:2 )"
+
+all_ruby_prepare() {
+ rm Gemfile* || die
+ sed -e '/bundler/d' \
+ -e '/[Cc]ode[Cc]limate/d' \
+ -e '/simplecov/,/^end/ s:^:#:' \
+ -i spec/spec_helper.rb || die
+ sed -i -e 's/git ls-files --/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid test broken with rack 2.2
+ sed -i -e '/closes response.s body/askip "rack 2.2 compatibility"' spec/rack/test_spec.rb || die
+}
diff --git a/dev-ruby/rash_alt/rash_alt-0.4.12.ebuild b/dev-ruby/rash_alt/rash_alt-0.4.12.ebuild
index e9c9d59125c5..a1598d3aa00c 100644
--- a/dev-ruby/rash_alt/rash_alt-0.4.12.ebuild
+++ b/dev-ruby/rash_alt/rash_alt-0.4.12.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
diff --git a/dev-ruby/sinatra/sinatra-2.1.0-r1.ebuild b/dev-ruby/sinatra/sinatra-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..16a511abe9e4
--- /dev/null
+++ b/dev-ruby/sinatra/sinatra-2.1.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=true test:core"
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS.md CHANGELOG.md"
+
+RUBY_FAKEGEM_GEMSPEC="sinatra.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A DSL for quickly creating web applications in Ruby with minimal effort"
+HOMEPAGE="http://www.sinatrarb.com/"
+SRC_URI="https://github.com/sinatra/sinatra/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/mustermann:1
+ dev-ruby/rack:2.2
+ ~dev-ruby/rack-protection-${PV}
+ dev-ruby/tilt:2"
+ruby_add_bdepend "test? ( >=dev-ruby/rack-test-0.5.6 dev-ruby/erubis dev-ruby/builder <dev-ruby/activesupport-7 )"
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i -e '/active_support\/core_ext\/hash/igem "activesupport", "<7"' test/helper.rb || die
+}
diff --git a/dev-ruby/slim/slim-4.1.0-r2.ebuild b/dev-ruby/slim/slim-4.1.0-r2.ebuild
new file mode 100644
index 000000000000..5ff227866234
--- /dev/null
+++ b/dev-ruby/slim/slim-4.1.0-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_RECIPE_DOC="rake"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A template language aiming to reduce the syntax to the essential parts"
+HOMEPAGE="http://slim-lang.com/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+SLOT="$(ver_cut 1)"
+IUSE="doc"
+
+ruby_add_rdepend ">=dev-ruby/tilt-2.0.6:* =dev-ruby/tilt-2.0*:*
+ >=dev-ruby/temple-0.7.6:0.7
+ !!<dev-ruby/slim-3.0.9-r1"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/redcarpet )"
+
+ruby_add_bdepend "test? ( dev-ruby/redcarpet dev-ruby/sassc )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # This sinatra code expects tests to be installed but we strip those.
+ sed -i -e "s/require 'sinatra'/require 'bogussinatra'/" Rakefile || die
+
+ # Add missing include, bug 816573
+ sed -i -e "1irequire 'ostruct'" test/core/test_code_evaluation.rb || die
+
+ # Avoid tests for things we don't have. The builder test does not pass with tilt 2.x
+ sed -i -e '/test_wip_render_with_asciidoc/,/^ end/ s:^:#:' \
+ -e '/test_render_with_wiki/,/^ end/ s:^:#:' \
+ -e '/test_render_with_creole/,/^ end/ s:^:#:' \
+ -e '/test_render_with_builder/,/^ end/ s:^:#:' \
+ -e '/test_render_with_org/,/^ end/ s:^:#:' test/core/test_embedded_engines.rb || die
+
+ sed -i -e '/s\.files/ s/git ls-files/find . -type f -print/' \
+ -e '/s\.executables/ s:git ls-files -- bin/\*:find bin -type f -print:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_prepare() {
+ sed -i -e '/Open3/ s:ruby:'${RUBY}':' test/core/test_commands.rb || die
+}
diff --git a/dev-ruby/temple/temple-0.8.2-r1.ebuild b/dev-ruby/temple/temple-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..9a7616a68d2b
--- /dev/null
+++ b/dev-ruby/temple/temple-0.8.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="An abstraction and a framework for compiling templates to pure Ruby"
+HOMEPAGE="https://github.com/judofyr/temple"
+
+LICENSE="MIT"
+SLOT="0.7"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bacon
+ dev-ruby/erubis
+ >=dev-ruby/tilt-2.0.1 )"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Ilib -Itest --automatic --quiet || die
+}
diff --git a/dev-ruby/tilt/files/tilt-2.0.10-ruby30.patch b/dev-ruby/tilt/files/tilt-2.0.10-ruby30.patch
new file mode 100644
index 000000000000..27e4d821f64f
--- /dev/null
+++ b/dev-ruby/tilt/files/tilt-2.0.10-ruby30.patch
@@ -0,0 +1,37 @@
+From 91838d57aa35ba5341368ead0d442e1dc1eb8730 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
+Date: Mon, 18 Jan 2021 12:49:31 +0100
+Subject: [PATCH] Fix Ruby 3.0 compatibility.
+
+This fixes issues such as:
+
+~~~
+ 1) Error:
+CSVTemplateTest#test_compiles_and_evaluates_the_template_on_render:
+TypeError: no implicit conversion of Hash into String
+ /usr/share/ruby/csv.rb:1273:in `initialize'
+ /usr/share/ruby/csv.rb:1273:in `new'
+ /usr/share/ruby/csv.rb:1273:in `generate'
+ (__TEMPLATE__):in `__tilt_920'
+ /builddir/build/BUILD/tilt-2.0.10/usr/share/gems/gems/tilt-2.0.10/lib/tilt/template.rb:170:in `call'
+ /builddir/build/BUILD/tilt-2.0.10/usr/share/gems/gems/tilt-2.0.10/lib/tilt/template.rb:170:in `evaluate'
+ /builddir/build/BUILD/tilt-2.0.10/usr/share/gems/gems/tilt-2.0.10/lib/tilt/template.rb:109:in `render'
+ /builddir/build/BUILD/tilt-2.0.10/usr/share/gems/gems/tilt-2.0.10/test/tilt_csv_test.rb:15:in `block in <class:CSVTemplateTest>'
+~~~
+---
+ lib/tilt/csv.rb | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/tilt/csv.rb b/lib/tilt/csv.rb
+index fd0e602..7dfa220 100644
+--- a/lib/tilt/csv.rb
++++ b/lib/tilt/csv.rb
+@@ -50,7 +50,7 @@ def prepare
+
+ def precompiled_template(locals)
+ <<-RUBY
+- #{@outvar} = #{self.class.engine}.generate(#{options}) do |csv|
++ #{@outvar} = #{self.class.engine}.generate(**#{options}) do |csv|
+ #{data}
+ end
+ RUBY
diff --git a/dev-ruby/tilt/tilt-2.0.10-r1.ebuild b/dev-ruby/tilt/tilt-2.0.10-r1.ebuild
new file mode 100644
index 000000000000..00b33d3ba691
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.0.10-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+RUBY_FAKEGEM_GEMSPEC="tilt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/rtomayko/tilt"
+SRC_URI="https://github.com/rtomayko/tilt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-ruby30.patch" )
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/erubis
+ dev-ruby/nokogiri
+)"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ sed -e '/test_smarty_pants_true/,/^ end/ s:^:#:' \
+ -e '/test_smart_quotes_true/,/^ end/ s:^:#:' -i test/tilt_markdown_test.rb || die
+ sed -e '/smartypants when :smart is set/,/^ end/ s:^:#:' -i test/tilt_rdiscounttemplate_test.rb || die
+
+ # Skip tests for unpackaged asciidoctor converter
+ sed -i -e '/docbook 4.5/askip' test/tilt_asciidoctor_test.rb || die
+}
diff --git a/dev-ruby/treetop/treetop-1.6.11-r1.ebuild b/dev-ruby/treetop/treetop-1.6.11-r1.ebuild
new file mode 100644
index 000000000000..4eb6fb5a2f01
--- /dev/null
+++ b/dev-ruby/treetop/treetop-1.6.11-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="treetop.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Treetop is a language for describing languages"
+HOMEPAGE="https://github.com/cjheath/treetop"
+SRC_URI="https://github.com/cjheath/treetop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.0 dev-ruby/activesupport )"
+ruby_add_rdepend ">=dev-ruby/polyglot-0.3.1:0"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r examples
+}
diff --git a/dev-ruby/typhoeus/Manifest b/dev-ruby/typhoeus/Manifest
index d88d42e730de..9dde4234ab8e 100644
--- a/dev-ruby/typhoeus/Manifest
+++ b/dev-ruby/typhoeus/Manifest
@@ -1,2 +1 @@
-DIST typhoeus-1.3.1.gem 55808 BLAKE2B e3153870bfe2d5187aa433d81a287c2f9e9e6cf3caaf52b0f542fd35e4ac812786abc389c47ab56dd4267adb5206a5ce25c5ab6cc8559fa8dfbbd6b78e53fc16 SHA512 f826cdb7e48577226b12fc2715123e13519148f67d036470e385f80f8f3112d1ad24bf580c2ed0d213242c9afc1bdf868084266d430858b2cf6de73e50a11422
DIST typhoeus-1.4.0.gem 56832 BLAKE2B 1f188a2c174a9d0e2cc0afc10f96d98a8c78278c1fa53eeb88da6f4f3986c8e204171a9bb817c95a217360346bda319711e7c89095ad48e878cbc3efc21e9887 SHA512 f48a99fd554f4d06d37a0a804ee79dd8423d9bff765394537ab0edba615e132d25660a6eb455e8628f59bd56c7ea26f4a195827d5287a53e58e3aeb394477284
diff --git a/dev-ruby/typhoeus/typhoeus-1.3.1.ebuild b/dev-ruby/typhoeus/typhoeus-1.3.1.ebuild
deleted file mode 100644
index f351f3b1aade..000000000000
--- a/dev-ruby/typhoeus/typhoeus-1.3.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md UPGRADE.md"
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Runs HTTP requests in parallel while cleanly encapsulating handling logic"
-HOMEPAGE="https://rubygems.org/gems/typhoeus/
- https://github.com/typhoeus/typhoeus"
-
-LICENSE="Ruby"
-SLOT="1"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/ethon-0.9.0"
-
-ruby_add_bdepend "test? ( dev-ruby/json >=dev-ruby/faraday-0.9 >=dev-ruby/sinatra-1.3 >=dev-ruby/redis-3.0 >=dev-ruby/dalli-2.7.9 )"
-
-all_ruby_prepare() {
- sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die
-}
diff --git a/www-servers/adsf/adsf-1.4.6-r1.ebuild b/www-servers/adsf/adsf-1.4.6-r1.ebuild
new file mode 100644
index 000000000000..0d67069e41bf
--- /dev/null
+++ b/www-servers/adsf/adsf-1.4.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md ../README.md"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+
+RUBY_FAKEGEM_GEMSPEC="adsf.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Dead Simple Fileserver is a static file server that can launch in a directory"
+HOMEPAGE="https://github.com/ddfreyne/adsf/"
+SRC_URI="https://github.com/ddfreyne/adsf/archive/${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${P}/adsf"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~riscv"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rack-1.0.0:*"
+
+ruby_add_bdepend "test? ( dev-ruby/rack-test )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/SimpleCov.command_name/ s:^:#:' \
+ -e '/websocket/ s:^:#:' test/helper.rb || die
+ sed -e '/test_receives_update/,/^ end/ s:^:#:' \
+ -e '/test_non_local_interfaces/askip "networking"' \
+ -e '/test_default_config__serve_index_html_in_subdir_missing_slash/askip "encoding"' \
+ -i test/test_server.rb || die
+ sed -i -e '/rubocop/I s:^:#:' Rakefile || die
+ rm -f test/test_version.rb || die
+
+ sed -i -e "s:require_relative ':require './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+}