summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-23 06:41:43 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-23 07:41:14 +0100
commit90cca3c1d0f325a3988fab1d7bfb7365971850ab (patch)
tree56961c2e89f45bb7303f87df5a92719800fb7c65
parentdev-python/botocore: Bump to 1.34.69 (diff)
downloadgentoo-90cca3c1d0f325a3988fab1d7bfb7365971850ab.tar.gz
gentoo-90cca3c1d0f325a3988fab1d7bfb7365971850ab.tar.bz2
gentoo-90cca3c1d0f325a3988fab1d7bfb7365971850ab.zip
dev-python/boto3: Bump to 1.34.69
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.69.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index e7d3bb3c1969..bacc29f25f15 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.34.65.gh.tar.gz 785163 BLAKE2B 15596df62933b72311f7f6cb7a9c710355ad
DIST boto3-1.34.66.gh.tar.gz 785695 BLAKE2B b11aebb785ca7cf93f8eeffef7d96a698a3073e4144131c6e786518a957b5a346f4fb67a306461b25db3821e04ff5687c680a5f816c3c587b9196d77961d501f SHA512 80570ee5a0b7beaac71784a4edca2c5504a7d0e1195c919ddf9a90ae7b0dab30d7798082948678f7bd61e701006c7f35d417e905df5be7027e0341f9c649b724
DIST boto3-1.34.67.gh.tar.gz 786594 BLAKE2B 633bcdefdd9753cacd2ca101ed72a544e11b2fa9137320b0c259808369ac017ec65e7d9dcd14daa3ac7e9f6dee23459ed6c119458b8d885efa77f27f2dddb029 SHA512 8c10d5ae3498191c2199ea4535b180d0f0cb4ac07c698970a2664ef8837c81ed8e23d1fefefd0ea79135fd0da68a60b92137a382daaff8ba306a977821a623f6
DIST boto3-1.34.68.gh.tar.gz 786741 BLAKE2B f71aa7473d01a9a7f8904c8e27474e7c3794bfe5e9fdfef66e3d43c551c4d79104f6d73d390b1dba83e40ff41ca44dda7cde9f1651a3d6924a5b11afe12b8566 SHA512 77b8e4875bebccf1a35834629974fe195119759f739c01f811c61557cbcc3e09bba612ab0e7c236737fc5dd18d059bfc4c2eb337dc5bb4eafb58fe6ccbaf38ea
+DIST boto3-1.34.69.gh.tar.gz 787293 BLAKE2B 9e46a959f3efdc3e673d38c8e3c30b8ceed1c1f47d685466e4164bcc1000381710bf8d8b6afff0999185ccddf38da591df004c54709729f2181308cb2279c43f SHA512 ef765518de95468e66270cea6dc93ede48547fb37db3ed9429659d85fb25174162cd062814c6adefeb8385c14079e7927f52d66501ab45f8d251ccfc830465e4
diff --git a/dev-python/boto3/boto3-1.34.69.ebuild b/dev-python/boto3/boto3-1.34.69.ebuild
new file mode 100644
index 000000000000..b64e7191fd19
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.69.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}