summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-09-18 18:14:05 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-09-18 18:14:05 +0200
commit9279ea0a1258ddf538f766a093de27f62557d596 (patch)
treee0b1c3788d154c49801b202e0c9835622954e06b
parentdev-python/pytest-httpbin: Bump to 2.1.0 (diff)
downloadgentoo-9279ea0a1258ddf538f766a093de27f62557d596.tar.gz
gentoo-9279ea0a1258ddf538f766a093de27f62557d596.tar.bz2
gentoo-9279ea0a1258ddf538f766a093de27f62557d596.zip
app-text/pdfjam: add 3.12
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--app-text/pdfjam/Manifest1
-rw-r--r--app-text/pdfjam/pdfjam-3.12.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-text/pdfjam/Manifest b/app-text/pdfjam/Manifest
index 90a6f52c291f..9b8802a5990c 100644
--- a/app-text/pdfjam/Manifest
+++ b/app-text/pdfjam/Manifest
@@ -1,3 +1,4 @@
DIST pdfjam-3.10.tar.gz 121928 BLAKE2B 5ff82abba43becb2792ff9e6a13dd3458d4b884e9e2361d116c638bb8a396fd8ca833361dfbc981433ebf445cfa8bfe99bb5fc7f1a76a35361666b91acef934e SHA512 dd69d8e5f86bb4fcb8db0e71454fdb0f2dd75e222d68e8cf3870d9f318aa7e8ccf51f87977ad71ddba1d78569e358044b111b8014f88dddf86654dc5bc334e90
+DIST pdfjam-3.12.tar.gz 162802 BLAKE2B d22e78cdb1e0135b2d2a9d1269a7467417a2fd3f984e969434d59db82f94a6575ff12bf814c3f90081e8e08823d68577e43b243fb2f52160dffc9d425fc84f0e SHA512 c801f5dbfb2eebf185734d14974a00c3ca3b8edda349ed7d6e0017ac80136ea10cab7ab0dc77ec1a712f7e338c8c9e58d24d7b8b69a3b2116e0a6473fc0b1317
DIST pdfjam-extra-20191118.tar.gz 15457 BLAKE2B 3d673ba68a1ee89cec7af0ec7d7fc61c8993b9ae328d3362a6bbbae47cbda2caa2e8f4ecd28424dd894c31d14754228b067389b61fa7845cfe5dfc0e2b5d9b8d SHA512 1d02abb9d81baf6edf3e51e2c7838df191a7a18b4b50518ee1ae3108020a274d7608570654ab540539d3717e51ef10f548c83c3480681bc20c9702280f694b8f
DIST pdfjam_208.tgz 180725 BLAKE2B 903ce4f0874c9fc9ad23f3db37b882596589d6470dfe9289f65a72fb66ff843bbd49b52086d7b2d2cbbfb1b6406cbbda64d46b933a853d5d681ef88d4033372c SHA512 728c8d304c6d2af773980d20ef4a4be6e0a5dad286ad8cd00be9b1687f5024e00032a750c10c74dcd24431f081368d02b76f03cc5bb1c8725a060cd70be0fd8c
diff --git a/app-text/pdfjam/pdfjam-3.12.ebuild b/app-text/pdfjam/pdfjam-3.12.ebuild
new file mode 100644
index 000000000000..3d40ca2a3833
--- /dev/null
+++ b/app-text/pdfjam/pdfjam-3.12.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PDFJAM_EXTRAS_COMMIT=622e03add59db004144c0b41722a09b3b29d6d3e
+
+DESCRIPTION="Allows the manipulation of PDF files"
+HOMEPAGE="https://github.com/rrthomas/pdfjam"
+SRC_URI="
+ https://github.com/rrthomas/pdfjam/releases/download/v${PV}/pdfjam-${PV}.tar.gz
+ extra? (
+ https://github.com/rrthomas/pdfjam-extras/archive/${PDFJAM_EXTRAS_COMMIT}.tar.gz
+ -> pdfjam-extra-20191118.tar.gz
+ )
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+IUSE="extra test"
+RESTRICT="!test? ( test )"
+
+DEPEND="virtual/latex-base"
+RDEPEND="
+ ${DEPEND}
+ !<dev-texlive/texlive-binextra-2023_p69527-r4
+"
+BDEPEND="test? ( app-arch/unzip )"
+
+src_prepare() {
+ default
+ if use test; then
+ unzip tests.zip || die
+ fi
+}
+
+src_test() {
+ ./tests/run.sh || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README.md
+ doman man1/*
+
+ insinto usr/share/etc
+ doins pdfjam.conf
+
+ if use extra; then
+ cd ../pdfjam-extras-${PDFJAM_EXTRAS_COMMIT} || die
+
+ dobin bin/*
+ newdoc README.md README-extras.md
+ doman man1/*
+ fi
+}