summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-05-24 12:31:56 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-05-24 12:31:56 +0000
commit92cca18f6180e0abdc307ff809539dfabdcc4a83 (patch)
treeafeb6758f1b9df3f46299e006a38cad50216f0e7
parent2023-05-24 12:17:04 UTC (diff)
parentdev-python/distlib: Reenable more tests (diff)
downloadgentoo-92cca18f6180e0abdc307ff809539dfabdcc4a83.tar.gz
gentoo-92cca18f6180e0abdc307ff809539dfabdcc4a83.tar.bz2
gentoo-92cca18f6180e0abdc307ff809539dfabdcc4a83.zip
Merge updates from master
-rw-r--r--dev-python/distlib/distlib-0.3.6.ebuild14
-rw-r--r--dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r2.ebuild2
2 files changed, 2 insertions, 14 deletions
diff --git a/dev-python/distlib/distlib-0.3.6.ebuild b/dev-python/distlib/distlib-0.3.6.ebuild
index 96bce0617735..6f1be5b2fb7b 100644
--- a/dev-python/distlib/distlib-0.3.6.ebuild
+++ b/dev-python/distlib/distlib-0.3.6.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
inherit distutils-r1
@@ -24,11 +24,9 @@ IUSE="test"
RESTRICT="!test? ( test )"
# pypiserver is called as external executable
-# openpyxl installs invalid metadata that breaks distlib
BDEPEND="
test? (
dev-python/pypiserver
- !!<dev-python/openpyxl-3.0.3[${PYTHON_USEDEP}]
)
"
@@ -39,16 +37,6 @@ src_prepare() {
# use system pypiserver instead of broken bundled one
eapply "${FILESDIR}"/distlib-0.3.2-system-pypiserver.py || die
- # doesn't work with our patched pip
- sed -i -e '/PIP_AVAIL/s:True:False:' tests/test_wheel.py || die
-
- # broken with pypy3
- sed -i -e 's:test_custom_shebang:_&:' tests/test_scripts.py || die
- # broken with py3.11, doesn't look important
- sed -i -e 's:test_sequencer_basic:_&:' tests/test_util.py || die
- # https://bugs.gentoo.org/843839
- sed -i -e 's:test_interpreter_args:_&:' tests/test_scripts.py || die
-
distutils-r1_src_prepare
}
diff --git a/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r2.ebuild b/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r2.ebuild
index acfe021202d4..3364df7e0250 100644
--- a/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r2.ebuild
+++ b/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 pypi