summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-11 16:41:45 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-14 14:39:03 +0200
commit94713d649fa2b3c14e2331b19ab124816ef09108 (patch)
treedb87fca6b6b2e8b870728d8e44d6675176f7b8e8
parentdev-python/six: Enable python3_13t (diff)
downloadgentoo-94713d649fa2b3c14e2331b19ab124816ef09108.tar.gz
gentoo-94713d649fa2b3c14e2331b19ab124816ef09108.tar.bz2
gentoo-94713d649fa2b3c14e2331b19ab124816ef09108.zip
dev-python/python-dateutil: Enable python3_13t
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-dateutil/python-dateutil-2.9.0_p0.ebuild19
1 files changed, 17 insertions, 2 deletions
diff --git a/dev-python/python-dateutil/python-dateutil-2.9.0_p0.ebuild b/dev-python/python-dateutil/python-dateutil-2.9.0_p0.ebuild
index 6b3ced20bfc3..74059ed6728c 100644
--- a/dev-python/python-dateutil/python-dateutil-2.9.0_p0.ebuild
+++ b/dev-python/python-dateutil/python-dateutil-2.9.0_p0.ebuild
@@ -5,7 +5,8 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_FULLY_TESTED=( python3_{10..13} pypy3 )
+PYTHON_COMPAT=( "${PYTHON_FULLY_TESTED[@]}" python3_13t )
inherit distutils-r1 pypi
@@ -28,7 +29,9 @@ BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ ' "${PYTHON_FULLY_TESTED[@]}")
)
"
@@ -45,3 +48,15 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+
+python_test() {
+ local EPYTEST_IGNORE=()
+ if ! has_version "dev-python/hypothesis[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/property
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}