summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2019-04-17 19:04:08 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2019-04-17 19:04:08 +0000
commit99c2329da0580f7b793e11077ed3631dc35bdfb2 (patch)
treebbefd48bbb2777b3f3a57efd19ab72eeda55d7b8
parent2019-04-17 18:48:11 UTC (diff)
parentvirtual/jre: require gentoo-vm useflag (diff)
downloadgentoo-99c2329da0580f7b793e11077ed3631dc35bdfb2.tar.gz
gentoo-99c2329da0580f7b793e11077ed3631dc35bdfb2.tar.bz2
gentoo-99c2329da0580f7b793e11077ed3631dc35bdfb2.zip
Merge updates from master
-rw-r--r--dev-java/openjdk-jre-bin/Manifest1
-rw-r--r--dev-java/openjdk-jre-bin/files/openjdk-jre-bin-11.env.sh16
-rw-r--r--dev-java/openjdk-jre-bin/openjdk-jre-bin-11.0.2_p9.ebuild93
-rw-r--r--dev-java/openjdk-jre-bin/openjdk-jre-bin-8.202_p08.ebuild4
-rw-r--r--profiles/arch/arm64/package.use.mask7
-rw-r--r--profiles/base/package.use.mask5
-rw-r--r--sys-libs/libcap/libcap-2.26-r2.ebuild4
-rw-r--r--virtual/jre/jre-1.8.0-r2.ebuild2
-rw-r--r--virtual/jre/jre-11-r1.ebuild (renamed from virtual/jre/jre-11.ebuild)3
9 files changed, 123 insertions, 12 deletions
diff --git a/dev-java/openjdk-jre-bin/Manifest b/dev-java/openjdk-jre-bin/Manifest
index cb18026f0a45..d9d0ed15a238 100644
--- a/dev-java/openjdk-jre-bin/Manifest
+++ b/dev-java/openjdk-jre-bin/Manifest
@@ -1 +1,2 @@
+DIST OpenJDK11U-jre_x64_linux_hotspot_11.0.2_9.tar.gz 41525058 BLAKE2B da456e8415ef45d07968c12082f2351910284b47bac92a952d4962fbc4c63cb2fa006696b6b175e0d1073b1fca76cca61460465d0959afe80d2f5ce9006d9350 SHA512 96b527be34c49e6351bed0d000153c1bc9491cf89f8a7f90190feccd2984cce1e3d18747e108d476c4417f15947d436f20cd34fe88f8126edecf4a789d725b0a
DIST OpenJDK8U-jre_x64_linux_hotspot_8u202b08.tar.gz 40856726 BLAKE2B d9d4599989a0232bcc145aaf58b20dbfcedbe33adb2b3ee65b7e726dea350210f66eb81b321268a29d3234244c517642cfe908531242afb220509666e02c0617 SHA512 f9bb03cd0876f6b3b36d8ba821a14648b5ac2ec6dc6eefb95dc333aae77b55c940153cdd1715b21feaf7d7f2148bf8c272777c8afab911965e514f9792287962
diff --git a/dev-java/openjdk-jre-bin/files/openjdk-jre-bin-11.env.sh b/dev-java/openjdk-jre-bin/files/openjdk-jre-bin-11.env.sh
new file mode 100644
index 000000000000..ec0dca401e6f
--- /dev/null
+++ b/dev-java/openjdk-jre-bin/files/openjdk-jre-bin-11.env.sh
@@ -0,0 +1,16 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+VERSION="AdoptOpenJDK JRE ${PV}"
+JAVA_HOME="${EPREFIX}/opt/${P}"
+JDK_HOME="${EPREFIX}/opt/${P}"
+JAVAC="\${JAVA_HOME}/bin/javac"
+PATH="\${JAVA_HOME}/bin"
+ROOTPATH="\${JAVA_HOME}/bin"
+LDPATH="\${JAVA_HOME}/lib/:\${JAVA_HOME}/lib/server/"
+MANPATH="\${JAVA_HOME}/man"
+PROVIDES_TYPE="JRE"
+PROVIDES_VERSION="${SLOT}"
+BOOTCLASSPATH=""
+GENERATION="2"
+ENV_VARS="JAVA_HOME JDK_HOME JAVAC PATH ROOTPATH LDPATH MANPATH"
diff --git a/dev-java/openjdk-jre-bin/openjdk-jre-bin-11.0.2_p9.ebuild b/dev-java/openjdk-jre-bin/openjdk-jre-bin-11.0.2_p9.ebuild
new file mode 100644
index 000000000000..1f10efc02641
--- /dev/null
+++ b/dev-java/openjdk-jre-bin/openjdk-jre-bin-11.0.2_p9.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-vm-2
+
+abi_uri() {
+ echo "${2-$1}? (
+ https://github.com/AdoptOpenJDK/openjdk${SLOT}-binaries/releases/download/jdk-${MY_PV}/OpenJDK${SLOT}U-jre_${1}_linux_hotspot_${MY_PV//+/_}.tar.gz
+ )"
+}
+
+MY_PV=${PV/_p/+}
+SLOT=${MY_PV%%[.+]*}
+
+SRC_URI="
+ $(abi_uri x64 amd64)
+"
+
+DESCRIPTION="Prebuilt Java JRE binaries provided by AdoptOpenJDK"
+HOMEPAGE="https://adoptopenjdk.net"
+LICENSE="GPL-2-with-classpath-exception"
+KEYWORDS="~amd64"
+IUSE="alsa cups +gentoo-vm headless-awt nsplugin selinux +webstart"
+
+RDEPEND="
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ >net-libs/libnet-1.1
+ >=sys-libs/glibc-2.2.5:*
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ cups? ( net-print/cups )
+ selinux? ( sec-policy/selinux-java )
+ !headless-awt? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ )"
+
+PDEPEND="webstart? ( >=dev-java/icedtea-web-1.6.1:0 )
+ nsplugin? ( >=dev-java/icedtea-web-1.6.1:0[nsplugin] )"
+
+RESTRICT="preserve-libs splitdebug"
+QA_PREBUILT="*"
+
+S="${WORKDIR}/jdk-${MY_PV}-jre"
+
+src_install() {
+ local dest="/opt/${P}"
+ local ddest="${ED}${dest#/}"
+
+ # Not sure why they bundle this as it's commonly available and they
+ # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
+ # also has an explicit dependency while Oracle seemingly dlopens it.
+ rm -vf lib/libfreetype.so || die
+
+ # Oracle and IcedTea have libjsoundalsa.so depending on
+ # libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
+ if ! use alsa ; then
+ rm -v lib/libjsound.* || die
+ fi
+
+ if use headless-awt ; then
+ rm -v lib/lib*{[jx]awt,splashscreen}* || die
+ fi
+
+ dodir "${dest}"
+ cp -pPR * "${ddest}" || die
+
+ use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+ java-vm_set-pax-markings "${ddest}"
+ java-vm_revdep-mask
+ java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
+}
+
+pkg_postinst() {
+ java-vm-2_pkg_postinst
+
+ if use gentoo-vm ; then
+ ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JRE"
+ ewarn "recognised by the system. This will almost certainly break things."
+ else
+ ewarn "The experimental gentoo-vm USE flag has not been enabled so this JRE"
+ ewarn "will not be recognised by the system. For example, simply calling"
+ ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
+ ewarn "fully supports Java 11. This JRE must therefore be invoked using its"
+ ewarn "absolute location under ${EPREFIX}/opt/${P}."
+ fi
+}
diff --git a/dev-java/openjdk-jre-bin/openjdk-jre-bin-8.202_p08.ebuild b/dev-java/openjdk-jre-bin/openjdk-jre-bin-8.202_p08.ebuild
index 89b46c775338..2af8e9e8e29d 100644
--- a/dev-java/openjdk-jre-bin/openjdk-jre-bin-8.202_p08.ebuild
+++ b/dev-java/openjdk-jre-bin/openjdk-jre-bin-8.202_p08.ebuild
@@ -82,10 +82,10 @@ pkg_postinst() {
java-vm-2_pkg_postinst
if use gentoo-vm ; then
- ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
+ ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JRE"
ewarn "recognised by the system. This will almost certainly break things."
else
- ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
+ ewarn "The experimental gentoo-vm USE flag has not been enabled so this JRE"
ewarn "will not be recognised by the system. For example, simply calling"
ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
ewarn "fully supports OpenJDK 8. This JRE must therefore be invoked using its"
diff --git a/profiles/arch/arm64/package.use.mask b/profiles/arch/arm64/package.use.mask
index 57012eb3a60e..b4580a44019a 100644
--- a/profiles/arch/arm64/package.use.mask
+++ b/profiles/arch/arm64/package.use.mask
@@ -178,10 +178,6 @@ sys-devel/clang-runtime crt
# Boost.Context can be built on arm64
dev-libs/boost -context
-# Michał Górny <mgorny@gentoo.org> (12 Mar 2018)
-# Requires masked net-misc/curl with libressl.
-dev-libs/libgit2 libressl
-
# Michał Górny <mgorny@gentoo.org> (03 Mar 2018)
# Requires masked dependent flags.
net-fs/samba addc addns ads cluster python test
@@ -439,8 +435,7 @@ www-client/chromium tcmalloc
# Mike Frysinger <vapier@gentoo.org> (20 Jul 2015)
# Mart Raudsepp <leio@gentoo.org> (04 Feb 2017)
# Needs deps tested.
-dev-python/pycurl curl_ssl_libressl
-net-misc/curl curl_ssl_libressl metalink
+net-misc/curl metalink
# Mike Frysinger <vapier@gentoo.org> (16 Mar 2015)
# Needs sci-physics/bullet tested #499974
diff --git a/profiles/base/package.use.mask b/profiles/base/package.use.mask
index 42af96322d38..6c79c31ef125 100644
--- a/profiles/base/package.use.mask
+++ b/profiles/base/package.use.mask
@@ -7,6 +7,11 @@
# This file is only for generic masks. For arch-specific masks (i.e.
# mask everywhere, unmask on arch/*) use arch/base.
+# Georgy Yakovlev <gyakovlev@gentoo.org> (17 Apr 2019)
+# Mask jre useflags for use as system java-vm until it's proven to work
+dev-java/openjdk-jre-bin:8 gentoo-vm
+dev-java/openjdk-jre-bin:11 gentoo-vm
+
# Michał Górny <mgorny@gentoo.org> (13 Apr 2019)
# net-libs/ftplib is slated for removal.
app-cdr/xbiso ftp
diff --git a/sys-libs/libcap/libcap-2.26-r2.ebuild b/sys-libs/libcap/libcap-2.26-r2.ebuild
index 27c8f7ee0891..2a54d4ded401 100644
--- a/sys-libs/libcap/libcap-2.26-r2.ebuild
+++ b/sys-libs/libcap/libcap-2.26-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ SRC_URI="mirror://kernel/linux/libs/security/linux-privs/libcap2/${P}.tar.xz"
# it's available under either of the licenses
LICENSE="|| ( GPL-2 BSD )"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="pam static-libs"
# While the build system optionally uses gperf, we don't DEPEND on it because
diff --git a/virtual/jre/jre-1.8.0-r2.ebuild b/virtual/jre/jre-1.8.0-r2.ebuild
index a630eb760722..04cc21959e21 100644
--- a/virtual/jre/jre-1.8.0-r2.ebuild
+++ b/virtual/jre/jre-1.8.0-r2.ebuild
@@ -9,6 +9,6 @@ KEYWORDS="~amd64 ~arm ~arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-m
RDEPEND="|| (
virtual/jdk:1.8
- dev-java/openjdk-jre-bin:8
+ dev-java/openjdk-jre-bin:8[gentoo-vm(+)]
dev-java/oracle-jre-bin:1.8
)"
diff --git a/virtual/jre/jre-11.ebuild b/virtual/jre/jre-11-r1.ebuild
index ebd9c8db284f..fbc640b49acc 100644
--- a/virtual/jre/jre-11.ebuild
+++ b/virtual/jre/jre-11-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,5 +9,6 @@ KEYWORDS="~amd64 ~arm64 ~ppc64"
RDEPEND="|| (
virtual/jdk:${SLOT}
+ dev-java/openjdk-jre-bin:${SLOT}[gentoo-vm(+)]
dev-java/oracle-jre-bin:${SLOT}[gentoo-vm(+)]
)"