summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2023-12-08 08:32:26 +0100
committerSam James <sam@gentoo.org>2023-12-15 03:22:04 +0000
commit9dec5127f70b51ed6003d8ce061f176c188a05a7 (patch)
tree25650bc1f3f5fd87ffba248b8e683e4e36c5853a
parentapp-misc/cdargs: vbump to 2.1 (diff)
downloadgentoo-9dec5127f70b51ed6003d8ce061f176c188a05a7.tar.gz
gentoo-9dec5127f70b51ed6003d8ce061f176c188a05a7.tar.bz2
gentoo-9dec5127f70b51ed6003d8ce061f176c188a05a7.zip
dev-python/chainstream: new package, add 1.0.1
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/rpl/Manifest1
-rw-r--r--app-text/rpl/rpl-1.15.5.ebuild26
-rw-r--r--dev-python/chainstream/Manifest1
-rw-r--r--dev-python/chainstream/chainstream-1.0.1.ebuild29
-rw-r--r--dev-python/chainstream/metadata.xml11
5 files changed, 68 insertions, 0 deletions
diff --git a/app-text/rpl/Manifest b/app-text/rpl/Manifest
index 6ce738310437..663bf3fe4630 100644
--- a/app-text/rpl/Manifest
+++ b/app-text/rpl/Manifest
@@ -1,2 +1,3 @@
DIST rpl-1.15.2.gh.tar.gz 25452 BLAKE2B 95c826723683786411ff4ff5fe3a31ef4784fd682a735c369b758137aaf94b936aa4c714ed5db51c987710bb79dfeb46a8ec5837f97242d488ea4d92d980f202 SHA512 67418a89e3ab8770dce4945d3db5d7a54986ba4357a902249062d28d9abda5856c82e41092b703e138fe6d70e6ea3c5f5cd57eead83d0d39addda6c746e85d81
+DIST rpl-1.15.5.gh.tar.gz 24401 BLAKE2B 91f0914ce80167305f9b403f691e58cd3f219d9e22f0ae7587b6dc5c60809e03bf38bd3878696916026b7cd0e597b67a6fcbb97d55005fd113e80aa7296f0e95 SHA512 1669a2de5b09090a3058421e2f9560f9b155151ec6d91f9d4f3b43070082d2541981de7754f047771c515e6d1450998c55e3b018a589a5ae4bd48e28464bb858
DIST rpl-1.9.1.gh.tar.gz 22858 BLAKE2B 583a29fd34d7a0d2b3a35b0966a6bd42ac2851750806a97846785dc0331bd5d2199ffba3309184e64a4aa7194f9ae4b9ecb2acc500830b841bd34e2184ec1798 SHA512 be480c6788fa1eb672b892d798deb7d263eae227dac5d93a55f28ebf3b4a43f896eb10edd00e52aad1cd57f4a80faf4a4552b4762b26da273cd05f0c5bce754a
diff --git a/app-text/rpl/rpl-1.15.5.ebuild b/app-text/rpl/rpl-1.15.5.ebuild
new file mode 100644
index 000000000000..902a5491d3c1
--- /dev/null
+++ b/app-text/rpl/rpl-1.15.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Intelligent recursive search/replace utility"
+HOMEPAGE="http://rpl.sourceforge.net/
+ https://github.com/rrthomas/rpl"
+SRC_URI="
+ https://github.com/rrthomas/rpl/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/argparse-manpage[${PYTHON_USEDEP}]
+ sys-apps/help2man[nls]
+"
diff --git a/dev-python/chainstream/Manifest b/dev-python/chainstream/Manifest
new file mode 100644
index 000000000000..e6d953adc625
--- /dev/null
+++ b/dev-python/chainstream/Manifest
@@ -0,0 +1 @@
+DIST chainstream-1.0.1.tar.gz 3160 BLAKE2B 1aa8f9323cbb0f71c4bb7ab1aa709f369cc836b12b946de3d5e4a9beb4acb4d6a7d63642285fc3572eb6d85243bb08d9d387c02e768342cb1a90f91bf7b404bc SHA512 5badc4ef451ea208acf5acfe80a24541e2bbb8edfe43cca0cdac7d229d6a68c2df07d2c83d71d8d4251bc0d4b443952d0cdad638f603a85f4f4657717d0bcbac
diff --git a/dev-python/chainstream/chainstream-1.0.1.ebuild b/dev-python/chainstream/chainstream-1.0.1.ebuild
new file mode 100644
index 000000000000..09d1d0761c2e
--- /dev/null
+++ b/dev-python/chainstream/chainstream-1.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Chain I/O-Streams together into a single stream"
+HOMEPAGE="https://github.com/rrthomas/chainstream"
+SRC_URI="https://github.com/rrthomas/chainstream/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+src_configure() {
+ # upstream doesn't provide build system in pyproject.toml
+ cat >> pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["setuptools", "wheel"]
+ build-backend = "setuptools.build_meta"
+ EOF
+}
diff --git a/dev-python/chainstream/metadata.xml b/dev-python/chainstream/metadata.xml
new file mode 100644
index 000000000000..67609af55f0e
--- /dev/null
+++ b/dev-python/chainstream/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rrthomas/chainstream</remote-id>
+ </upstream>
+</pkgmetadata>