summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-09-12 20:58:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-09-12 21:28:53 +0200
commitaa5306eb91ded8076ed14700571fb28c71306663 (patch)
tree9f43176e96fdca9255c216d27db71e13c6e71473
parentkde-plasma/kdesu-gui: Re-apply cmake.patch (diff)
downloadgentoo-aa5306eb91ded8076ed14700571fb28c71306663.tar.gz
gentoo-aa5306eb91ded8076ed14700571fb28c71306663.tar.bz2
gentoo-aa5306eb91ded8076ed14700571fb28c71306663.zip
dev-libs/plasma-wayland-protocols: add 1.14.0
See also: https://blogs.kde.org/2024/09/12/plasma-wayland-protocols-1.14.0/ Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/plasma-wayland-protocols/Manifest1
-rw-r--r--dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.14.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/plasma-wayland-protocols/Manifest b/dev-libs/plasma-wayland-protocols/Manifest
index 41c71f0aadf5..a28ea4701ed5 100644
--- a/dev-libs/plasma-wayland-protocols/Manifest
+++ b/dev-libs/plasma-wayland-protocols/Manifest
@@ -1 +1,2 @@
DIST plasma-wayland-protocols-1.13.0.tar.xz 45016 BLAKE2B 179bc29e79c210008e9f0b54cd50ce6350b0e575f746dbb6d2fe0dc0db4c4c1b98e29cd2b2faa98ce2049b001f2b2e8cbef9cded64db6823f8f56973e92cea8e SHA512 7e335df79a9b614701330d1dd4aa37803a35a5fa409f4d9456f487383c9c3c02414f74551363b22694e7fea9c4c2427ead3213d984c3673c90348e7f890826af
+DIST plasma-wayland-protocols-1.14.0.tar.xz 45776 BLAKE2B 1b2373b87ea7c6c0d82fd527ad07450747b4dda5d7b1ef73d122243f2ce4959b7ed32ead265cd93f9466802d84fb7486d123803c6665525b67b65d935b23014a SHA512 6f5acfa6fdbe7c4b362698c7fbfc6011c342fe9aadebc9677b21960887249ede876062eb1d5103b4440b577bd5add90a61c21ca7d7300c8b374129e50e621911
diff --git a/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.14.0.ebuild b/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.14.0.ebuild
new file mode 100644
index 000000000000..05f74e583c2b
--- /dev/null
+++ b/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.14.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake kde.org
+
+DESCRIPTION="Plasma Specific Protocols for Wayland"
+HOMEPAGE="https://invent.kde.org/libraries/plasma-wayland-protocols"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+BDEPEND="
+ dev-libs/libpcre2:*
+ >=kde-frameworks/extra-cmake-modules-5.115.0:*
+ || (
+ dev-qt/qtbase:6
+ dev-qt/qtcore:5
+ )
+"
+
+ecm_src_configure() {
+ local mycmakeargs=(
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON # ecm.eclass
+ -DKDE_INSTALL_DOCBUNDLEDIR="${EPREFIX}/usr/share/help" # ecm.eclass
+ )
+
+ cmake_src_configure
+}