summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-02-23 21:01:57 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-02-23 21:01:57 +0000
commitacea47c5379fe05aaf1ee36e956b858948cda985 (patch)
tree35de940deb28cdb7f8dab5e511e9efbd2fdfaa5f
parent2023-02-23 20:47:00 UTC (diff)
parentmedia-video/pipewire: Stabilize 0.3.65-r3 ppc64, #896026 (diff)
downloadgentoo-acea47c5379fe05aaf1ee36e956b858948cda985.tar.gz
gentoo-acea47c5379fe05aaf1ee36e956b858948cda985.tar.bz2
gentoo-acea47c5379fe05aaf1ee36e956b858948cda985.zip
Merge updates from master
-rw-r--r--dev-cpp/folly/files/folly-2023.01.16.00-gcc13.patch24
-rw-r--r--dev-cpp/folly/files/folly-2023.01.16.00-liburing.patch54
-rw-r--r--dev-libs/libbsd/libbsd-0.11.7-r2.ebuild2
-rw-r--r--dev-python/bleach/Manifest1
-rw-r--r--dev-python/bleach/bleach-5.0.1.ebuild46
-rw-r--r--dev-python/bleach/bleach-6.0.0.ebuild3
-rw-r--r--dev-python/h5py/h5py-3.8.0.ebuild2
-rw-r--r--dev-python/prometheus_client/Manifest1
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.15.0.ebuild30
-rw-r--r--dev-python/versioningit/versioningit-2.1.0.ebuild2
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.151.0.ebuild2
-rw-r--r--dev-util/watchman/files/watchman-2023.01.16.00-gcc13.patch23
-rw-r--r--gui-apps/waypipe/files/waypipe-0.7.2-no-simd.patch38
-rw-r--r--media-video/pipewire/pipewire-0.3.65-r3.ebuild2
-rw-r--r--net-analyzer/arping/files/arping-tests.patch190
-rw-r--r--net-dns/resolv_wrapper/resolv_wrapper-1.1.8.ebuild2
-rw-r--r--net-fs/samba/samba-4.16.8.ebuild2
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.4.0.ebuild2
-rw-r--r--net-misc/streamlink/streamlink-5.2.1.ebuild2
-rw-r--r--sys-libs/ldb/ldb-2.5.2.ebuild2
-rw-r--r--sys-libs/nss_wrapper/nss_wrapper-1.1.15.ebuild2
-rw-r--r--sys-libs/talloc/talloc-2.4.0.ebuild2
-rw-r--r--sys-libs/tdb/tdb-1.4.8.ebuild2
-rw-r--r--sys-libs/tevent/tevent-0.14.1.ebuild2
-rw-r--r--sys-libs/uid_wrapper/uid_wrapper-1.3.0.ebuild2
25 files changed, 16 insertions, 424 deletions
diff --git a/dev-cpp/folly/files/folly-2023.01.16.00-gcc13.patch b/dev-cpp/folly/files/folly-2023.01.16.00-gcc13.patch
deleted file mode 100644
index 6779274d2fa1..000000000000
--- a/dev-cpp/folly/files/folly-2023.01.16.00-gcc13.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-https://github.com/facebook/folly/pull/1922
-
-From e3cba5dd4f59c695d9cbf6bd02249af7103cc300 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Sun, 22 Jan 2023 05:06:16 +0000
-Subject: [PATCH] Fix build with GCC 13 (add missing includes)
-
-GCC 13 (as usual for new compiler releases) shuffles around some
-internal includes and so <stdexcept> etc is no longer transitively included.
-
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/folly/system/AtFork.cpp
-+++ b/folly/system/AtFork.cpp
-@@ -14,6 +14,9 @@
- * limitations under the License.
- */
-
-+#include <stdexcept>
-+#include <system_error>
-+
- #include <folly/system/AtFork.h>
-
- #include <folly/ScopeGuard.h>
-
diff --git a/dev-cpp/folly/files/folly-2023.01.16.00-liburing.patch b/dev-cpp/folly/files/folly-2023.01.16.00-liburing.patch
deleted file mode 100644
index e2a692cea50c..000000000000
--- a/dev-cpp/folly/files/folly-2023.01.16.00-liburing.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-https://bugs.gentoo.org/891633
-https://github.com/facebook/folly/issues/1908
-https://github.com/facebook/folly/commit/259c9d6a4f0eb6d80e0263c2fe5d1af5bff116dc
-
-From 259c9d6a4f0eb6d80e0263c2fe5d1af5bff116dc Mon Sep 17 00:00:00 2001
-From: Dylan Yudaken <dylany@meta.com>
-Date: Mon, 16 Jan 2023 01:20:04 -0800
-Subject: [PATCH] io_uring: implement io_uring_enable_rings locally (#1915)
-
-Summary:
-Pull Request resolved: https://github.com/facebook/folly/pull/1915
-
-io_uring_enable_rings was missing from liburing upstream (see https://github.com/axboe/liburing/issues/773) which is breaking the open source build. See https://github.com/facebook/folly/issues/1908
-
-Instead just implement it locally, as it's trivial
-
-Reviewed By: dmm-fb
-
-Differential Revision: D42497664
-
-fbshipit-source-id: 7241785a36046e867f907bfe74623aaeb38c4b70
---- a/folly/experimental/io/IoUringBackend.cpp
-+++ b/folly/experimental/io/IoUringBackend.cpp
-@@ -56,6 +56,20 @@ namespace folly {
-
- namespace {
-
-+#if FOLLY_IO_URING_UP_TO_DATE
-+int ioUringEnableRings(FOLLY_MAYBE_UNUSED struct io_uring* ring) {
-+ // Ideally this would call ::io_uring_enable_rings directly which just runs
-+ // the below however this was missing from a stable version of liburing, which
-+ // means that some distributions were not able to compile it. see
-+ // https://github.com/axboe/liburing/issues/773
-+
-+ // since it is so simple, just implement it here until the fix rolls out to an
-+ // acceptable number of OSS distributions.
-+ return ::io_uring_register(
-+ ring->ring_fd, IORING_REGISTER_ENABLE_RINGS, nullptr, 0);
-+}
-+#endif
-+
- struct SignalRegistry {
- struct SigInfo {
- struct sigaction sa_ {};
-@@ -1360,7 +1374,7 @@ void IoUringBackend::delayedInit() {
- if (usingDeferTaskrun_) {
- // usingDeferTaskrun_ is guarded already on having an up to date liburing
- #if FOLLY_IO_URING_UP_TO_DATE
-- int ret = ::io_uring_enable_rings(&ioRing_);
-+ int ret = ioUringEnableRings(&ioRing_);
- if (ret) {
- LOG(ERROR) << "io_uring_enable_rings gave " << folly::errnoStr(-ret);
- }
-
diff --git a/dev-libs/libbsd/libbsd-0.11.7-r2.ebuild b/dev-libs/libbsd/libbsd-0.11.7-r2.ebuild
index 0d9e80bd9581..6ec3a448aa64 100644
--- a/dev-libs/libbsd/libbsd-0.11.7-r2.ebuild
+++ b/dev-libs/libbsd/libbsd-0.11.7-r2.ebuild
@@ -13,7 +13,7 @@ SRC_URI+=" verify-sig? ( https://${PN}.freedesktop.org/releases/${P}.tar.xz.asc
LICENSE="BSD BSD-2 BSD-4 ISC"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
IUSE="static-libs"
RDEPEND="app-crypt/libmd[${MULTILIB_USEDEP}]"
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
index 77a6e9c7d92d..75f60ce26c2b 100644
--- a/dev-python/bleach/Manifest
+++ b/dev-python/bleach/Manifest
@@ -1,2 +1 @@
-DIST bleach-5.0.1.tar.gz 199642 BLAKE2B 8d06dd38e89b91bf48f3481b5337b8d9700d8cc88faf3a260898b2b8f15ecf5c5160f96bff2c5ce02f361b773b0ce9a51322d9836dcc99b7878921846e8da182 SHA512 6c8e80eaf6db6f0e6d9066f3443192f44c489e079945b6d11b11e7eb270ea865011019e05d43c7896262dc11ca168e697630d9da8dca9f5bb48f0e2161fda6c8
DIST bleach-6.0.0.tar.gz 201298 BLAKE2B e4af5da351fdb63bc75b935f70f40434bd81c49cde4f584901397e5fd4ac4507d2e29eb283ff28a764018dbd795021e2edf1f43385ff8a2d7d8affd358fc0e31 SHA512 95900e4347c1f7d0aa5b2e8fbf43fac6410dd6bbbac988fb3f407a964d0aa1dc51fe3cf17459e6ce762a02b45bb3d20b539ca05727278d120aee9500cf0d208a
diff --git a/dev-python/bleach/bleach-5.0.1.ebuild b/dev-python/bleach/bleach-5.0.1.ebuild
deleted file mode 100644
index 42b516fd5ae9..000000000000
--- a/dev-python/bleach/bleach-5.0.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="An easy whitelist-based HTML-sanitizing tool"
-HOMEPAGE="
- https://github.com/mozilla/bleach/
- https://pypi.org/project/bleach/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/html5lib-1.0.1-r1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/bleach-4.1.0-py39.patch
-)
-
-src_prepare() {
- # unbundle unpatched broken html5lib
- rm -r bleach/_vendor || die
- sed -i -e 's:bleach\._vendor\.parse:urllib.parse:' \
- bleach/parse_shim.py || die
- sed -i -e 's:bleach\._vendor\.::' \
- bleach/html5lib_shim.py \
- bleach/sanitizer.py \
- tests/test_clean.py || die
- # indirect html5lib deps
- sed -i -e '/six/d' -e '/webencodings/d' setup.py || die
-
- distutils-r1_src_prepare
-}
diff --git a/dev-python/bleach/bleach-6.0.0.ebuild b/dev-python/bleach/bleach-6.0.0.ebuild
index becc07b3d78d..05c0eb3e2c36 100644
--- a/dev-python/bleach/bleach-6.0.0.ebuild
+++ b/dev-python/bleach/bleach-6.0.0.ebuild
@@ -6,14 +6,13 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} pypy3 )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="An easy whitelist-based HTML-sanitizing tool"
HOMEPAGE="
https://github.com/mozilla/bleach/
https://pypi.org/project/bleach/
"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
diff --git a/dev-python/h5py/h5py-3.8.0.ebuild b/dev-python/h5py/h5py-3.8.0.ebuild
index deb49bb9263e..ba2b73c2383a 100644
--- a/dev-python/h5py/h5py-3.8.0.ebuild
+++ b/dev-python/h5py/h5py-3.8.0.ebuild
@@ -18,7 +18,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm ~riscv x86 ~amd64-linux ~x86-linux"
# disable mpi until mpi4py gets python3_8
#IUSE="examples mpi"
IUSE="examples"
diff --git a/dev-python/prometheus_client/Manifest b/dev-python/prometheus_client/Manifest
index 8329fda62127..e7fd71fbabf7 100644
--- a/dev-python/prometheus_client/Manifest
+++ b/dev-python/prometheus_client/Manifest
@@ -1,2 +1 @@
-DIST prometheus_client-0.15.0.gh.tar.gz 82056 BLAKE2B d9d94fe823edf99d273e9a85c27a8363c59c24a7d125a62bbadecd9abc81485949a27dacfc5faec31f27fdb263fec412210545b18f72c40a357c24d380242200 SHA512 ea11cb2fc08bd5e10ea97ee3be3068a2c37cbaa45ab3e146f8a0080074f69e7744ff90d1a0fb4f01eaefd1efc5f76428d6c898bead85d5fa37b6a59e9f832134
DIST prometheus_client-0.16.0.gh.tar.gz 82473 BLAKE2B bf285f52ce3de4c55f681871b814fe0be8dbdf61ed3031570983325e193a9b34cafbc8526f545801ac8711cc8331cf3b0c8f157394feb9ad827ac97872397341 SHA512 511936758026b6d6f48f52d27b1cb964a03668054d7a3c5c82c4fa20800be3812150fca74ab46dad11ca12f2c9ce1a6951a82ae2bacf91b3761f7bf7ce75e0d2
diff --git a/dev-python/prometheus_client/prometheus_client-0.15.0.ebuild b/dev-python/prometheus_client/prometheus_client-0.15.0.ebuild
deleted file mode 100644
index 8edd5ebc00d9..000000000000
--- a/dev-python/prometheus_client/prometheus_client-0.15.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python client for the Prometheus monitoring system"
-HOMEPAGE="
- https://github.com/prometheus/client_python/
- https://pypi.org/project/prometheus-client/
-"
-SRC_URI="
- https://github.com/prometheus/client_python/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/client_python-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/twisted[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
diff --git a/dev-python/versioningit/versioningit-2.1.0.ebuild b/dev-python/versioningit/versioningit-2.1.0.ebuild
index 88cdc4b3b0d6..a0d4acc1502b 100644
--- a/dev-python/versioningit/versioningit-2.1.0.ebuild
+++ b/dev-python/versioningit/versioningit-2.1.0.ebuild
@@ -17,7 +17,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~riscv ~x86"
RDEPEND="
>=dev-python/packaging-17.1[${PYTHON_USEDEP}]
diff --git a/dev-util/stripe-mock/stripe-mock-0.151.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.151.0.ebuild
index 9f5ab653106f..6c666b489577 100644
--- a/dev-util/stripe-mock/stripe-mock-0.151.0.ebuild
+++ b/dev-util/stripe-mock/stripe-mock-0.151.0.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT ISC BSD-2"
SLOT="0"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="amd64 x86"
src_compile() {
emake build
diff --git a/dev-util/watchman/files/watchman-2023.01.16.00-gcc13.patch b/dev-util/watchman/files/watchman-2023.01.16.00-gcc13.patch
deleted file mode 100644
index 20c70d29e28b..000000000000
--- a/dev-util/watchman/files/watchman-2023.01.16.00-gcc13.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-https://github.com/facebook/watchman/pull/1089
-
-From 6535e011af5b89e9aa2a6faa60fc862f36f8b483 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Sun, 22 Jan 2023 05:09:25 +0000
-Subject: [PATCH] Fix build with GCC 13 (add missing <cstdint> include)
-
-GCC 13 (as usual for new compiler releases) shuffles around some
-internal includes and so <cstdint> is no longer transitively included.
-
-Explicitly include <cstdint> for uint32_t.
-
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/watchman/Errors.h
-+++ b/watchman/Errors.h
-@@ -8,6 +8,7 @@
- #pragma once
-
- #include <fmt/core.h>
-+#include <cstdint>
- #include <string>
- #include <system_error>
-
diff --git a/gui-apps/waypipe/files/waypipe-0.7.2-no-simd.patch b/gui-apps/waypipe/files/waypipe-0.7.2-no-simd.patch
deleted file mode 100644
index df464810e1b3..000000000000
--- a/gui-apps/waypipe/files/waypipe-0.7.2-no-simd.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-make simd instructions optional
-
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -5,3 +5,7 @@ option('with_lz4', type : 'feature', value : 'auto', description : 'Support LZ4
- option('with_zstd', type : 'feature', value : 'auto', description : 'Support ZStandard as a compression mechanism')
- option('with_vaapi', type : 'feature', value : 'auto', description : 'Link with libva and use VAAPI to perform hardware video output color space conversions on GPU')
- option('with_systemtap', type: 'boolean', value: true, description: 'Enable tracing using sdt and provide static tracepoints for profiling')
-+option('with_avx512f', type: 'boolean', value: true, description: 'Enable avx512f SIMD instructions')
-+option('with_avx2', type: 'boolean', value: true, description: 'Enable avx2 SIMD instructions')
-+option('with_sse3', type: 'boolean', value: true, description: 'Enable sse3 SIMD instructions')
-+option('with_neon_opts', type: 'boolean', value: true, description: 'Enable optimizations for ARM64 neon cpus')
---- a/src/meson.build
-+++ b/src/meson.build
-@@ -25,19 +25,19 @@ endif
- # Conditionally compile SIMD-optimized code.
- # (The meson simd module is a bit too limited for this)
- kernel_libs = []
--if cc.has_argument('-mavx512f') and cc.has_argument('-mlzcnt') and cc.has_argument('-mbmi')
-+if cc.has_argument('-mavx512f') and cc.has_argument('-mlzcnt') and cc.has_argument('-mbmi') and get_option('with_avx512f')
- kernel_libs += static_library('kernel_avx512f', 'kernel_avx512f.c', c_args:['-mavx512f', '-mlzcnt', '-mbmi'])
- config_data.set('HAVE_AVX512F', 1, description: 'Compiler supports AVX-512F')
- endif
--if cc.has_argument('-mavx2') and cc.has_argument('-mlzcnt') and cc.has_argument('-mbmi')
-+if cc.has_argument('-mavx2') and cc.has_argument('-mlzcnt') and cc.has_argument('-mbmi') and get_option('with_avx2')
- kernel_libs += static_library('kernel_avx2', 'kernel_avx2.c', c_args:['-mavx2', '-mlzcnt', '-mbmi'])
- config_data.set('HAVE_AVX2', 1, description: 'Compiler supports AVX2')
- endif
--if cc.has_argument('-msse3')
-+if cc.has_argument('-msse3') and get_option('with_sse3')
- kernel_libs += static_library('kernel_sse3', 'kernel_sse3.c', c_args:['-msse3'])
- config_data.set('HAVE_SSE3', 1, description: 'Compiler supports SSE 3')
- endif
--if host_machine.cpu_family() == 'aarch64' or cc.has_argument('-mfpu=neon')
-+if ( host_machine.cpu_family() == 'aarch64' or cc.has_argument('-mfpu=neon') ) and get_option('with_neon_opts')
- neon_args = host_machine.cpu_family() == 'aarch64' ? [] : ['-mfpu=neon']
-
- # Clang additionally enforces that NEON code only be compiled
diff --git a/media-video/pipewire/pipewire-0.3.65-r3.ebuild b/media-video/pipewire/pipewire-0.3.65-r3.ebuild
index 25e528688b6c..478bc4c00ace 100644
--- a/media-video/pipewire/pipewire-0.3.65-r3.ebuild
+++ b/media-video/pipewire/pipewire-0.3.65-r3.ebuild
@@ -29,7 +29,7 @@ else
SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.bz2"
fi
- KEYWORDS="~amd64 arm arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ KEYWORDS="amd64 arm arm64 ~loong ~ppc ppc64 ~riscv ~sparc x86"
fi
DESCRIPTION="Multimedia processing graphs"
diff --git a/net-analyzer/arping/files/arping-tests.patch b/net-analyzer/arping/files/arping-tests.patch
deleted file mode 100644
index fb8592df372f..000000000000
--- a/net-analyzer/arping/files/arping-tests.patch
+++ /dev/null
@@ -1,190 +0,0 @@
-diff --git a/src/arping_test.c b/src/arping_test.c
-index 438670b..0133fe7 100644
---- a/src/arping_test.c
-+++ b/src/arping_test.c
-@@ -40,35 +40,10 @@ extern libnet_t* libnet;
- extern int mock_libnet_lo_ok;
- extern int mock_libnet_null_ok;
-
--struct registered_test {
-- void* fn;
-- const char* name;
--};
--
--static int numtests = 0;
--static struct registered_test test_registry[1024];
--
--static int num_exit_tests = 0;
--static struct registered_test test_exit_registry[1024];
--
- int get_mac_addr(const char *in, char *out);
- void strip_newline(char* s);
-
-
--#define MYTEST(a) static void a(int);__attribute__((constructor)) \
--static void cons_##a() { \
-- test_registry[numtests].fn = a; \
-- test_registry[numtests].name = #a; \
-- numtests++; \
--} START_TEST(a)
--
--#define MY_EXIT_TEST(a) static void a(int);__attribute__((constructor)) \
--static void cons_##a() { \
-- test_exit_registry[num_exit_tests].fn = a; \
-- test_exit_registry[num_exit_tests].name = #a; \
-- num_exit_tests++; \
--} START_TEST(a)
--
- /**
- *
- */
-@@ -236,7 +211,7 @@ dump_packet(uint8_t* packet, int len)
- fprintf(stderr, "\n");
- }
-
--MYTEST(test_mkpacket)
-+START_TEST(test_mkpacket)
- {
- uint8_t correct_packet[] = {
- 0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88, 0x99, 0xaa,
-@@ -261,7 +236,7 @@ MYTEST(test_mkpacket)
-
-
- // Received uninteresting packet, should not record anything.
--MYTEST(pingip_uninteresting_packet)
-+START_TEST(pingip_uninteresting_packet)
- {
- struct pcap_pkthdr pkthdr;
- uint8_t* packet;
-@@ -389,7 +364,7 @@ MYTEST(pingip_uninteresting_packet)
- } END_TEST
-
- // Received reply that actually matches. Things should happen.
--MYTEST(pingip_interesting_packet)
-+START_TEST(pingip_interesting_packet)
- {
- struct pcap_pkthdr pkthdr;
- extern uint8_t srcmac[ETH_ALEN];
-@@ -449,7 +424,7 @@ MYTEST(pingip_interesting_packet)
- "numrecvd not incremented second time");
- } END_TEST
-
--MYTEST(strip_newline_test)
-+START_TEST(strip_newline_test)
- {
- const char *tests[][2] = {
- {"", ""},
-@@ -469,7 +444,7 @@ MYTEST(strip_newline_test)
- }
- } END_TEST
-
--MYTEST(get_mac_addr_success)
-+START_TEST(get_mac_addr_success)
- {
- const char *tests[][2] = {
- // Null.
-@@ -501,7 +476,7 @@ MYTEST(get_mac_addr_success)
- }
- } END_TEST
-
--MYTEST(get_mac_addr_fail)
-+START_TEST(get_mac_addr_fail)
- {
- const char *tests[] = {
- "",
-@@ -517,7 +492,7 @@ MYTEST(get_mac_addr_fail)
- }
- } END_TEST
-
--MY_EXIT_TEST(libnet_init_bad_nolo)
-+START_TEST(libnet_init_bad_nolo)
- {
- // It'll only try lo if named interface fails.
- // So by accepting lo, we make sure it doesn't try lo.
-@@ -525,27 +500,28 @@ MY_EXIT_TEST(libnet_init_bad_nolo)
- do_libnet_init("bad", 0);
- } END_TEST
-
--MY_EXIT_TEST(libnet_init_null_nolo_nonull)
-+START_TEST(libnet_init_null_nolo_nonull)
- {
- mock_libnet_lo_ok = 0;
- mock_libnet_null_ok = 0;
- do_libnet_init(NULL, 0);
- } END_TEST
-
--MYTEST(libnet_init_good)
-+START_TEST(libnet_init_good)
- {
- mock_libnet_lo_ok = 0; // Don't even try falling back to lo.
- do_libnet_init("good", 0);
- fail_if(libnet == NULL);
- } END_TEST
-
--MYTEST(libnet_init_null_nolo)
-+START_TEST(libnet_init_null_nolo)
- {
- mock_libnet_lo_ok = 0;
- mock_libnet_null_ok = 1;
- do_libnet_init(NULL, 0);
- fail_if(libnet == NULL);
--} END_TEST
-+}
-+END_TEST
-
- static Suite*
- arping_suite(void)
-@@ -553,17 +529,34 @@ arping_suite(void)
- int c;
- Suite* s = suite_create("Arping");
-
-- //tcase_add_checked_fixture (tc_core, setup, teardown);
-- for (c = 0; c < numtests; c++) {
-- TCase *tc_core = tcase_create(test_registry[c].name);
-- tcase_add_test(tc_core, test_registry[c].fn);
-- suite_add_tcase(s, tc_core);
-- }
-- for (c = 0; c < num_exit_tests; c++) {
-- TCase *tc_core = tcase_create(test_exit_registry[c].name);
-- tcase_add_exit_test(tc_core, test_exit_registry[c].fn, 1);
-- suite_add_tcase(s, tc_core);
-- }
-+
-+ TCase *tc_core;
-+
-+ // libcheck broke test registries, so have to resort to code duplication. :-(
-+ // https://github.com/libcheck/check/pull/158/files
-+#define SIGH_LIBCHECK(tn) \
-+ tc_core = tcase_create(#tn); \
-+ tcase_add_test(tc_core, tn); \
-+ suite_add_tcase(s, tc_core);
-+
-+ SIGH_LIBCHECK(libnet_init_null_nolo);
-+ SIGH_LIBCHECK(test_mkpacket);
-+ SIGH_LIBCHECK(pingip_uninteresting_packet);
-+ SIGH_LIBCHECK(pingip_interesting_packet);
-+ SIGH_LIBCHECK(strip_newline_test);
-+ SIGH_LIBCHECK(get_mac_addr_success);
-+ SIGH_LIBCHECK(get_mac_addr_fail);
-+ SIGH_LIBCHECK(libnet_init_good);
-+
-+
-+#define SIGH_LIBCHECK_EXIT(tn) \
-+ tc_core = tcase_create(#tn); \
-+ tcase_add_exit_test(tc_core, tn, 1); \
-+ suite_add_tcase(s, tc_core);
-+
-+ SIGH_LIBCHECK_EXIT(libnet_init_bad_nolo);
-+ SIGH_LIBCHECK_EXIT(libnet_init_null_nolo_nonull);
-+
- return s;
- }
-
-@@ -577,6 +570,7 @@ main()
- number_failed = srunner_ntests_failed (sr);
- srunner_free (sr);
- return (number_failed == 0) ? EXIT_SUCCESS : EXIT_FAILURE;
-+ return 0;
- }
- /* ---- Emacs Variables ----
- * Local Variables:
diff --git a/net-dns/resolv_wrapper/resolv_wrapper-1.1.8.ebuild b/net-dns/resolv_wrapper/resolv_wrapper-1.1.8.ebuild
index a08204f06ec5..70ac2a279f08 100644
--- a/net-dns/resolv_wrapper/resolv_wrapper-1.1.8.ebuild
+++ b/net-dns/resolv_wrapper/resolv_wrapper-1.1.8.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
diff --git a/net-fs/samba/samba-4.16.8.ebuild b/net-fs/samba/samba-4.16.8.ebuild
index d60aa238d199..0df40e9643bf 100644
--- a/net-fs/samba/samba-4.16.8.ebuild
+++ b/net-fs/samba/samba-4.16.8.ebuild
@@ -16,7 +16,7 @@ if [[ ${PV} == *_rc* ]]; then
SRC_URI="mirror://samba/rc/${MY_P}.tar.gz"
else
SRC_URI="mirror://samba/stable/${MY_P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc x86"
+ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc x86"
fi
S="${WORKDIR}/${MY_P}"
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.4.0.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.4.0.ebuild
index f785bc51dc55..9ee1c9b2a444 100644
--- a/net-libs/socket_wrapper/socket_wrapper-1.4.0.ebuild
+++ b/net-libs/socket_wrapper/socket_wrapper-1.4.0.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc x86"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
diff --git a/net-misc/streamlink/streamlink-5.2.1.ebuild b/net-misc/streamlink/streamlink-5.2.1.ebuild
index ff7c51d0ed88..5c099a070e94 100644
--- a/net-misc/streamlink/streamlink-5.2.1.ebuild
+++ b/net-misc/streamlink/streamlink-5.2.1.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://streamlink.github.io/"
if [[ ${PV} != 9999* ]]; then
SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="amd64 ~x86"
fi
LICENSE="BSD-2 Apache-2.0"
diff --git a/sys-libs/ldb/ldb-2.5.2.ebuild b/sys-libs/ldb/ldb-2.5.2.ebuild
index c0303e7c5971..a8951be72895 100644
--- a/sys-libs/ldb/ldb-2.5.2.ebuild
+++ b/sys-libs/ldb/ldb-2.5.2.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://samba.org/ftp/pub/${PN}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86"
IUSE="doc ldap +lmdb python test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
diff --git a/sys-libs/nss_wrapper/nss_wrapper-1.1.15.ebuild b/sys-libs/nss_wrapper/nss_wrapper-1.1.15.ebuild
index d9a8b42f1056..cefa4d95a2bd 100644
--- a/sys-libs/nss_wrapper/nss_wrapper-1.1.15.ebuild
+++ b/sys-libs/nss_wrapper/nss_wrapper-1.1.15.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc x86"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
diff --git a/sys-libs/talloc/talloc-2.4.0.ebuild b/sys-libs/talloc/talloc-2.4.0.ebuild
index c9682c97a3c8..054c6262c441 100644
--- a/sys-libs/talloc/talloc-2.4.0.ebuild
+++ b/sys-libs/talloc/talloc-2.4.0.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://www.samba.org/ftp/${PN}/${P}.tar.gz"
LICENSE="GPL-3 LGPL-3+ LGPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x64-solaris"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x64-solaris"
IUSE="compat +python"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
diff --git a/sys-libs/tdb/tdb-1.4.8.ebuild b/sys-libs/tdb/tdb-1.4.8.ebuild
index c1916cd19ab5..9c6b692dd0c5 100644
--- a/sys-libs/tdb/tdb-1.4.8.ebuild
+++ b/sys-libs/tdb/tdb-1.4.8.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://samba.org/ftp/tdb/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
IUSE="python"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="test"
diff --git a/sys-libs/tevent/tevent-0.14.1.ebuild b/sys-libs/tevent/tevent-0.14.1.ebuild
index 7d3990e2e638..c423e1cd6a10 100644
--- a/sys-libs/tevent/tevent-0.14.1.ebuild
+++ b/sys-libs/tevent/tevent-0.14.1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://samba.org/ftp/tevent/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~x86-linux"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~x86-linux"
IUSE="python test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="test !test? ( test )"
diff --git a/sys-libs/uid_wrapper/uid_wrapper-1.3.0.ebuild b/sys-libs/uid_wrapper/uid_wrapper-1.3.0.ebuild
index 0d8af44bb443..bd1fe448d57f 100644
--- a/sys-libs/uid_wrapper/uid_wrapper-1.3.0.ebuild
+++ b/sys-libs/uid_wrapper/uid_wrapper-1.3.0.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://www.samba.org/ftp/pub/cwrap/${P}.tar.gz
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc x86"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"