summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-18 21:54:49 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-18 23:28:09 +0100
commitadbd7efe412817f7d75fbc9550373fb02ac9ecd2 (patch)
tree2d7b0124aaeadc46f213d74e5a402d6656efa13c
parentdev-python/virtualenv: Bump to 20.13.4 (diff)
downloadgentoo-adbd7efe412817f7d75fbc9550373fb02ac9ecd2.tar.gz
gentoo-adbd7efe412817f7d75fbc9550373fb02ac9ecd2.tar.bz2
gentoo-adbd7efe412817f7d75fbc9550373fb02ac9ecd2.zip
dev-python/botocore: Bump to 1.24.22
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.24.22.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index fd081434c649..a040fa01b88c 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,4 +4,5 @@ DIST botocore-1.24.18.tar.gz 8823998 BLAKE2B 0b3e94ad6ee5257642cc24c1c0966b92b0e
DIST botocore-1.24.19.tar.gz 8826833 BLAKE2B 371aeb445c798b1d365397cd4e300cf86efa6c478d0e37ef768f14ead751f0e3f97d2d5190ee75681e11affb835517305fc4d8694e8c9aa9084048701b93d937 SHA512 a6020b9fcaf285859bd33239ac1f46ba7ddaab3c680a93ccb0562352bf8677b890da4ee6f6a0b6c33e3cce56931cedf29f3b373509815b5597be0578b392a74a
DIST botocore-1.24.20.tar.gz 8826541 BLAKE2B 8661c7057d64905972062761a567e88507769108e8e97ebea7d71b89a46fe7e807bd270a23d811c182651d334e50cdbd10d25302e021e19aeb509fff449629f0 SHA512 60c9160fa2e01f3e17bb964bcbd8194e011a787ad610d24fc31c3791b2a4b7645f94a688b8766b839a140dfa76fb9f1ae470604a262aaaf2838d42c730481653
DIST botocore-1.24.21.tar.gz 8837199 BLAKE2B 34b321900ff52b5d8fbde87160745243fedff5ad74930c428814c86ad713a367fd036aeb3ee74267420d2c39860327b39d604ddad208fc09008be30b8aac7b62 SHA512 6b5a5011501c81b3fc616c94c1dc1c673dd2a6d3c1f40638aa36a27131876e9bf64f736c9536606b9817079b33013fd62474b685bea4088d949bd6a225c7f247
+DIST botocore-1.24.22.tar.gz 8839717 BLAKE2B 7b3843900da913561ab2a99f7371139cd8fd89a2eb52a90b33f8fb4c0449ff23a00f56347a2916b271346acf2c0721af0a9695bff3663888aa87c790705ce4c3 SHA512 070222b5eca46fa5463620af63816bc8813c717a56b4c41294556130390959ac14570a1256542f145a5b36727ced9657b386fcd5f538d64912c8a9f049673bd6
DIST botocore-1.24.8.tar.gz 8798121 BLAKE2B 4ca37ed7be0af62901bf154f75739cc7e07505a809e551884c72d5b5eed334fff1111fc6db016df522564a1f3d9b6f258e8eca96161a734711340bf880b553b5 SHA512 6ac2139694ab199313a0fb9a2f783b12de7f3915d10cba739f4758356a3b84a917c3c394954b6d82d7a62de907c6fe57a3559e2b9a625bb0479e7bacd31d21cc
diff --git a/dev-python/botocore/botocore-1.24.22.ebuild b/dev-python/botocore/botocore-1.24.22.ebuild
new file mode 100644
index 000000000000..3bf7c7cfb689
--- /dev/null
+++ b/dev-python/botocore/botocore-1.24.22.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}