summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2016-07-26 09:22:48 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2016-07-26 09:22:48 +0000
commitb3b1621ceae304b2eb10b68963bbb30eb13340fd (patch)
tree7bc202c67481c7c055ad34b3245e3d006fc7c0fa
parent2016-07-26 08:43:53 UTC (diff)
parentghc-package.eclass, haskell-cabal.eclass: remove ghc-host-root. (diff)
downloadgentoo-b3b1621ceae304b2eb10b68963bbb30eb13340fd.tar.gz
gentoo-b3b1621ceae304b2eb10b68963bbb30eb13340fd.tar.bz2
gentoo-b3b1621ceae304b2eb10b68963bbb30eb13340fd.zip
Merge updates from master
-rw-r--r--app-crypt/kstart/Manifest1
-rw-r--r--app-crypt/kstart/kstart-4.2.ebuild31
-rw-r--r--dev-lang/ghc/ghc-7.10.3.ebuild5
-rw-r--r--dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild9
-rw-r--r--eclass/ghc-package.eclass12
-rw-r--r--eclass/haskell-cabal.eclass2
6 files changed, 42 insertions, 18 deletions
diff --git a/app-crypt/kstart/Manifest b/app-crypt/kstart/Manifest
index 31fcefe33eeb..b8805f7eb6bd 100644
--- a/app-crypt/kstart/Manifest
+++ b/app-crypt/kstart/Manifest
@@ -1 +1,2 @@
DIST kstart-4.1.tar.gz 269215 SHA256 ad1a71be149d56473319bf3b9bca83a60caa3af463d52c134e8f187103700224 SHA512 74a8a3f2c8d2c95f166f5861fb05a2d659a31db3165e27e81e5cf216bde44809d937ebc00995f89fa3b9df68609e3081303eb30742f5c4d90151b1410f0bd3cc WHIRLPOOL d72c71729eb1eb972eec4329ffb442b02856ddfb73fffca5ffe97f8a8d299155fe5535b0ca59e98197c2b2214bd56e3f5739a42d269fe3dac011556eb588bd13
+DIST kstart-4.2.tar.gz 296651 SHA256 2698bc1ab2fb36d49cc946b0cb864c56dd3a2f9ef596bfff59592e13d35315cd SHA512 7ce9c1f964c0d469b4b8a5de88ae83186e99116959941c4e7f69c59165d0c22aac432ac26dd5fe54f7c2f725048bb55b787107aea8408e2fd6c9ad02dcb31552 WHIRLPOOL 8b3dc378c57498915d2db81da20e1dbcd0df41e7cc549ae79f8658bd4c682055df4d90b1efa49b58f754fc99b96f813581979d994db4e1db573503f035644bff
diff --git a/app-crypt/kstart/kstart-4.2.ebuild b/app-crypt/kstart/kstart-4.2.ebuild
new file mode 100644
index 000000000000..297000ae8bc5
--- /dev/null
+++ b/app-crypt/kstart/kstart-4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Modified versions of kinit for refreshing kerberos tickets
+automatically"
+HOMEPAGE="http://www.eyrie.org/~eagle/software/kstart"
+SRC_URI="http://archives.eyrie.org/software/kerberos/${P}.tar.gz"
+
+LICENSE="|| ( MIT Stanford ISC )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="afs"
+
+DEPEND="virtual/krb5
+ afs? ( net-fs/openafs )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ econf \
+ --enable-reduced-depends \
+ "$(use_with afs)" \
+ "$(use_enable afs setpag)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README NEWS TODO examples/*
+}
diff --git a/dev-lang/ghc/ghc-7.10.3.ebuild b/dev-lang/ghc/ghc-7.10.3.ebuild
index 9721ed4fb10f..78ebfbf12d46 100644
--- a/dev-lang/ghc/ghc-7.10.3.ebuild
+++ b/dev-lang/ghc/ghc-7.10.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -16,7 +16,7 @@ if [[ ${CTARGET} = ${CHOST} ]] ; then
fi
inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
-inherit multilib pax-utils toolchain-funcs versionator
+inherit multilib pax-utils toolchain-funcs versionator prefix
DESCRIPTION="The Glasgow Haskell Compiler"
HOMEPAGE="http://www.haskell.org/ghc/"
@@ -322,6 +322,7 @@ relocate_ghc() {
"${WORKDIR}/usr/bin/$(cross)runghc-${GHC_PV}" \
"$gp_back" \
|| die "Adding LD_LIBRARY_PATH for wrappers failed"
+ hprefixify "${bin_libpath}"/${PN}*/settings
fi
# regenerate the binary package cache
diff --git a/dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild b/dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild
index 014cd42af1f7..da462620cf82 100644
--- a/dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild
+++ b/dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -28,7 +28,7 @@ src_prepare() {
}
_make_call_script() {
- cat <<-EOF >"${D}/$1"
+ cat <<-EOF >"${ED}/$1"
#! /usr/bin/env python
from gprof2dot import Main
Main().main()
@@ -39,7 +39,8 @@ _make_call_script() {
src_install() {
abi_specific_install() {
- insinto "$(python_get_sitedir)"
+ local sitedir="$(python_get_sitedir)"
+ insinto ${sitedir#"${EPREFIX}"}
doins ${PN}.py || die
python_optimize || die
}
@@ -47,5 +48,5 @@ src_install() {
dodir /usr/bin || die
_make_call_script /usr/bin/${PN} || die
- python_replicate_script "${D}"/usr/bin/${PN} || die
+ python_replicate_script "${ED}"/usr/bin/${PN} || die
}
diff --git a/eclass/ghc-package.eclass b/eclass/ghc-package.eclass
index ccc6d6ffd84b..5466c0b5b20d 100644
--- a/eclass/ghc-package.eclass
+++ b/eclass/ghc-package.eclass
@@ -62,16 +62,6 @@ ghc-getghcpkgbin() {
fi
}
-# @FUNCTION: ghc-host-prefix
-# @DESCRIPTION:
-# Returns root of installed ghc.
-# Some helpers (like best_version) require reference
-# host system as they are tied to compiler bing executed.
-ghc-host-root() {
- has "${EAPI:-0}" 0 1 2 && ! use prefix && EPREFIX=
- echo "${EPREFIX}/"
-}
-
# @FUNCTION: ghc-version
# @DESCRIPTION:
# returns upstream version of ghc
@@ -95,7 +85,7 @@ ghc-pm-version() {
local pm_ghc_p
if [[ -z "${_GHC_PM_VERSION_CACHE}" ]]; then
- pm_ghc_p=$(ROOT=$(ghc-host-root) best_version dev-lang/ghc)
+ pm_ghc_p=$(best_version dev-lang/ghc)
_GHC_PM_VERSION_CACHE="PM:${pm_ghc_p#dev-lang/ghc-}"
fi
echo "${_GHC_PM_VERSION_CACHE}"
diff --git a/eclass/haskell-cabal.eclass b/eclass/haskell-cabal.eclass
index 7732711ea90a..c1a13300abb0 100644
--- a/eclass/haskell-cabal.eclass
+++ b/eclass/haskell-cabal.eclass
@@ -177,7 +177,7 @@ cabal-version() {
else
# We ask portage, not ghc, so that we only pick up
# portage-installed cabal versions.
- _CABAL_VERSION_CACHE="$(ROOT=$(ghc-host-root) ghc-extractportageversion dev-haskell/cabal)"
+ _CABAL_VERSION_CACHE="$(ghc-extractportageversion dev-haskell/cabal)"
fi
fi
echo "${_CABAL_VERSION_CACHE}"