summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-20 19:44:55 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-20 20:21:18 +0100
commitb5b6748448b40e5a3c1efc87ab1ff1f13aab4da0 (patch)
treefcebd4b412668610351ba5a3a341aa95dffb5ae9
parentdev-python/sqlglot: Bump to 23.0.4 (diff)
downloadgentoo-b5b6748448b40e5a3c1efc87ab1ff1f13aab4da0.tar.gz
gentoo-b5b6748448b40e5a3c1efc87ab1ff1f13aab4da0.tar.bz2
gentoo-b5b6748448b40e5a3c1efc87ab1ff1f13aab4da0.zip
dev-python/threadpoolctl: Bump to 3.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/threadpoolctl/Manifest1
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-3.4.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/threadpoolctl/Manifest b/dev-python/threadpoolctl/Manifest
index 7bd16c6fd538..3980cb303b8e 100644
--- a/dev-python/threadpoolctl/Manifest
+++ b/dev-python/threadpoolctl/Manifest
@@ -1 +1,2 @@
DIST threadpoolctl-3.3.0.gh.tar.gz 36189 BLAKE2B 0c51d10d2444e76d8c1e46dc60e8434e515c56919b2e276261a5c595db38c5ecf35fda88308d4e2d50e5a03a2946a02fb7c15ecc3224d734bd6f1ab0e7af16f4 SHA512 901ab53aa30b3931b08f89eb1439517883f05762032e924d4bbcbf19a2ffc145b10fc65817199a9a3a7c5cf2ad38860d3b0df6b9d3b83fd24799804671c01524
+DIST threadpoolctl-3.4.0.gh.tar.gz 36777 BLAKE2B f5ac09cb2d15ee7c46ebedde61b2ad4e583f4a787bcce8189901f97a56ec030f67fa5dcb20e675b541710db3a48b1983162aa1109b6648a99bb50068590107ac SHA512 3ee49d9936811dd373d25e036e9165aedd1e4d740f0e6a30c5f114c6d58d33321e279919093f1d076c6510fd92dd77273c6d24bf7f6e06030194512093fcc266
diff --git a/dev-python/threadpoolctl/threadpoolctl-3.4.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-3.4.0.ebuild
new file mode 100644
index 000000000000..88092a680ad2
--- /dev/null
+++ b/dev-python/threadpoolctl/threadpoolctl-3.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
+HOMEPAGE="
+ https://github.com/joblib/threadpoolctl/
+ https://pypi.org/project/threadpoolctl/
+"
+SRC_URI="
+ https://github.com/joblib/threadpoolctl/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Asserts against a hardcoded list of CPUs. Either we skip it
+ # or file bugs about missing architectures until upstream realizes
+ # how bad idea that were.
+ tests/test_threadpoolctl.py::test_architecture
+ # This test fails if the Python executable (or any library that it
+ # links to) uses OpenMP. This can particularly be the case with
+ # CPython 3.12 that links to app-crypt/libb2.
+ # https://github.com/joblib/threadpoolctl/issues/146
+ tests/test_threadpoolctl.py::test_command_line_empty
+)