summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-23 19:13:37 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-23 19:13:37 +0100
commitb621f163b9af5f8949f0ce1ce1bc13651562b3ff (patch)
treed2072d515e196aff290333a9be3ad1445f7d4268
parentwww-client/chromium: security cleanup (diff)
downloadgentoo-b621f163b9af5f8949f0ce1ce1bc13651562b3ff.tar.gz
gentoo-b621f163b9af5f8949f0ce1ce1bc13651562b3ff.tar.bz2
gentoo-b621f163b9af5f8949f0ce1ce1bc13651562b3ff.zip
dev-lang/ocaml: respect CFLAGS
Closes: https://bugs.gentoo.org/719166 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-lang/ocaml/files/ocaml-4.09.0-cflags.patch11
-rw-r--r--dev-lang/ocaml/files/ocaml-4.10.2-cflags.patch42
-rw-r--r--dev-lang/ocaml/ocaml-4.05.0-r7.ebuild4
-rw-r--r--dev-lang/ocaml/ocaml-4.05.0-r8.ebuild4
-rw-r--r--dev-lang/ocaml/ocaml-4.09.0-r2.ebuild2
-rw-r--r--dev-lang/ocaml/ocaml-4.10.2-r2.ebuild8
-rw-r--r--dev-lang/ocaml/ocaml-4.11.2-r2.ebuild5
-rw-r--r--dev-lang/ocaml/ocaml-4.12.1.ebuild4
-rw-r--r--dev-lang/ocaml/ocaml-4.13.1.ebuild4
9 files changed, 78 insertions, 6 deletions
diff --git a/dev-lang/ocaml/files/ocaml-4.09.0-cflags.patch b/dev-lang/ocaml/files/ocaml-4.09.0-cflags.patch
index 920cd32264b6..8d2391407a35 100644
--- a/dev-lang/ocaml/files/ocaml-4.09.0-cflags.patch
+++ b/dev-lang/ocaml/files/ocaml-4.09.0-cflags.patch
@@ -52,3 +52,14 @@
-I$(ROOTDIR)/runtime $(SHAREDLIB_CFLAGS) -DNATIVE_CODE \
-DTARGET_$(ARCH) -DMODEL_$(MODEL) -DSYS_$(SYSTEM) \
$(OUTPUTOBJ)$@ -c $<
+--- a/tools/Makefile 2022-01-23 09:57:00.788877931 +0100
++++ b/tools/Makefile 2022-01-23 09:57:21.735516656 +0100
+@@ -322,7 +322,7 @@
+ endif
+
+ objinfo_helper$(EXE): objinfo_helper.c $(ROOTDIR)/runtime/caml/s.h
+- $(CC) $(OC_CFLAGS) $(OC_CPPFLAGS) -I$(ROOTDIR)/runtime $(OUTPUTEXE)$@ \
++ $(CC) $(OC_CFLAGS) $(CFLAGS) $(OC_CPPFLAGS) -I$(ROOTDIR)/runtime $(OUTPUTEXE)$@ \
+ $(DEF_SYMBOL_PREFIX) $(LIBBFD_INCLUDE) $< $(LIBBFD_LINK)
+
+ OBJINFO=$(ROOTDIR)/compilerlibs/ocamlcommon.cma \
diff --git a/dev-lang/ocaml/files/ocaml-4.10.2-cflags.patch b/dev-lang/ocaml/files/ocaml-4.10.2-cflags.patch
new file mode 100644
index 000000000000..01117c39887d
--- /dev/null
+++ b/dev-lang/ocaml/files/ocaml-4.10.2-cflags.patch
@@ -0,0 +1,42 @@
+--- a/runtime/Makefile 2022-01-22 19:49:32.914213696 +0100
++++ b/runtime/Makefile 2022-01-22 19:50:03.765640701 +0100
+@@ -335,7 +335,7 @@
+ # (without the extension, which is added by the macro)
+ define COMPILE_C_FILE
+ $(1).$(O): %.c
+- $$(CC) -c $$(OC_CFLAGS) $$(OC_CPPFLAGS) $$(OUTPUTOBJ)$$@ $$<
++ $$(CC) -c $$(OC_CFLAGS) $(CFLAGS) $$(OC_CPPFLAGS) $$(OUTPUTOBJ)$$@ $$<
+ endef
+
+ object_types := % %_b %_bd %_bi %_bpic %_n %_nd %_ni %_np %_npic
+--- a/otherlibs/Makefile.otherlibs.common 2022-01-22 20:24:15.316779625 +0100
++++ b/otherlibs/Makefile.otherlibs.common 2022-01-22 20:24:50.730126701 +0100
+@@ -138,4 +138,4 @@
+ $(CAMLOPT) -c $(COMPFLAGS) $(OPTCOMPFLAGS) $<
+
+ .c.$(O):
+- $(CC) -c $(OC_CFLAGS) $(OC_CPPFLAGS) $(OUTPUTOBJ)$@ $<
++ $(CC) -c $(OC_CFLAGS) $(CFLAGS) $(OC_CPPFLAGS) $(OUTPUTOBJ)$@ $<
+--- a/otherlibs/systhreads/Makefile 2022-01-22 20:42:17.647349876 +0100
++++ b/otherlibs/systhreads/Makefile 2022-01-22 20:43:29.766086103 +0100
+@@ -102,10 +102,10 @@
+ st_stubs_n.$(O): OC_CPPFLAGS += $(NATIVE_CPPFLAGS)
+
+ st_stubs_b.$(O): st_stubs.c $(HEADER)
+- $(CC) -c $(OC_CFLAGS) $(OC_CPPFLAGS) $(OUTPUTOBJ)$@ $<
++ $(CC) -c $(OC_CFLAGS) $(CFLAGS) $(OC_CPPFLAGS) $(OUTPUTOBJ)$@ $<
+
+ st_stubs_n.$(O): st_stubs.c $(HEADER)
+- $(CC) -c $(OC_CFLAGS) $(OC_CPPFLAGS) $(OUTPUTOBJ)$@ $<
++ $(CC) -c $(OC_CFLAGS) $(CFLAGS) $(OC_CPPFLAGS) $(OUTPUTOBJ)$@ $<
+
+ partialclean:
+ rm -f *.cm*
+--- a/Makefile.common.in 2022-01-23 18:05:04.192323554 +0100
++++ b/Makefile.common.in 2022-01-23 18:05:17.211122643 +0100
+@@ -79,4 +79,4 @@
+ # general (it supports both .o and .obj)
+
+ %.$(O): %.c
+- $(CC) -c $(OC_CFLAGS) $(OC_CPPFLAGS) $(OUTPUTOBJ)$@ $<
++ $(CC) -c $(OC_CFLAGS) $(CFLAGS) $(OC_CPPFLAGS) $(OUTPUTOBJ)$@ $<
diff --git a/dev-lang/ocaml/ocaml-4.05.0-r7.ebuild b/dev-lang/ocaml/ocaml-4.05.0-r7.ebuild
index 68a369bcebf8..8f3bd8015bfc 100644
--- a/dev-lang/ocaml/ocaml-4.05.0-r7.ebuild
+++ b/dev-lang/ocaml/ocaml-4.05.0-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,6 +30,8 @@ BDEPEND="${RDEPEND}
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"
+QA_FLAGS_IGNORED='/usr/lib.*/ocaml/raw_spacetime_lib.cmxs'
+
S="${WORKDIR}/${MY_P}"
PATCHES=(
diff --git a/dev-lang/ocaml/ocaml-4.05.0-r8.ebuild b/dev-lang/ocaml/ocaml-4.05.0-r8.ebuild
index 4c2da17dac59..58ae1dde82d7 100644
--- a/dev-lang/ocaml/ocaml-4.05.0-r8.ebuild
+++ b/dev-lang/ocaml/ocaml-4.05.0-r8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,6 +30,8 @@ BDEPEND="${RDEPEND}
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"
+QA_FLAGS_IGNORED='/usr/lib.*/ocaml/raw_spacetime_lib.cmxs'
+
S="${WORKDIR}/${MY_P}"
PATCHES=(
diff --git a/dev-lang/ocaml/ocaml-4.09.0-r2.ebuild b/dev-lang/ocaml/ocaml-4.09.0-r2.ebuild
index ca9871a0c358..ef5e9bedc947 100644
--- a/dev-lang/ocaml/ocaml-4.09.0-r2.ebuild
+++ b/dev-lang/ocaml/ocaml-4.09.0-r2.ebuild
@@ -21,6 +21,8 @@ BDEPEND="${RDEPEND}
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"
+QA_FLAGS_IGNORED='/usr/lib.*/ocaml/bigarray.cmxs'
+
PATCHES=(
"${FILESDIR}"/${PN}-4.09.0-gcc-10.patch
"${FILESDIR}"/${P}-cflags.patch
diff --git a/dev-lang/ocaml/ocaml-4.10.2-r2.ebuild b/dev-lang/ocaml/ocaml-4.10.2-r2.ebuild
index 3b6334a9c87c..fbf4e4c204b6 100644
--- a/dev-lang/ocaml/ocaml-4.10.2-r2.ebuild
+++ b/dev-lang/ocaml/ocaml-4.10.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,6 +21,12 @@ BDEPEND="${RDEPEND}
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"
+QA_FLAGS_IGNORED='/usr/lib.*/ocaml/bigarray.cmxs'
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+)
+
src_prepare() {
default
diff --git a/dev-lang/ocaml/ocaml-4.11.2-r2.ebuild b/dev-lang/ocaml/ocaml-4.11.2-r2.ebuild
index cbc5b7cb458b..666f43b938bd 100644
--- a/dev-lang/ocaml/ocaml-4.11.2-r2.ebuild
+++ b/dev-lang/ocaml/ocaml-4.11.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,8 +21,11 @@ BDEPEND="${RDEPEND}
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"
+QA_FLAGS_IGNORED='/usr/lib.*/ocaml/bigarray.cmxs'
+
PATCHES=(
"${FILESDIR}"/${PN}-4.11.2-glibc-2.34.patch
+ "${FILESDIR}"/${PN}-4.10.2-cflags.patch
)
src_prepare() {
diff --git a/dev-lang/ocaml/ocaml-4.12.1.ebuild b/dev-lang/ocaml/ocaml-4.12.1.ebuild
index 287a7f38e79d..fd6cae2fff2c 100644
--- a/dev-lang/ocaml/ocaml-4.12.1.ebuild
+++ b/dev-lang/ocaml/ocaml-4.12.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,8 @@ BDEPEND="${RDEPEND}
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"
+QA_FLAGS_IGNORED='/usr/lib.*/ocaml/bigarray.cmxs'
+
PATCHES=(
"${FILESDIR}"/${PN}-4.12.0-glibc-2.34.patch
)
diff --git a/dev-lang/ocaml/ocaml-4.13.1.ebuild b/dev-lang/ocaml/ocaml-4.13.1.ebuild
index da99522c6e38..1765de6905c0 100644
--- a/dev-lang/ocaml/ocaml-4.13.1.ebuild
+++ b/dev-lang/ocaml/ocaml-4.13.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,8 @@ BDEPEND="${RDEPEND}
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"
+QA_FLAGS_IGNORED='/usr/lib.*/ocaml/bigarray.cmxs'
+
src_prepare() {
default