summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-24 14:05:05 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-24 14:05:15 +0100
commitb9dfc299925659f3a2d124f6c9c89a1755b10e29 (patch)
treef62b7f44ae652895332dc7d24175f0ee23e4cf45
parentgames-simulation/simutrans: Fix language pack URL (diff)
downloadgentoo-b9dfc299925659f3a2d124f6c9c89a1755b10e29.tar.gz
gentoo-b9dfc299925659f3a2d124f6c9c89a1755b10e29.tar.bz2
gentoo-b9dfc299925659f3a2d124f6c9c89a1755b10e29.zip
sci-electronics/gspiceui: add version 1.2.87, bump to wxwidgets gtk3
Closes: https://bugs.gentoo.org/769629 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-electronics/gspiceui/Manifest1
-rw-r--r--sci-electronics/gspiceui/files/gspiceui-1.2.87-respect-users-flags.patch28
-rw-r--r--sci-electronics/gspiceui/gspiceui-1.2.87.ebuild81
3 files changed, 110 insertions, 0 deletions
diff --git a/sci-electronics/gspiceui/Manifest b/sci-electronics/gspiceui/Manifest
index f58ffcf502a6..8e067dce86db 100644
--- a/sci-electronics/gspiceui/Manifest
+++ b/sci-electronics/gspiceui/Manifest
@@ -1 +1,2 @@
DIST gspiceui-v1.1.00.tar.gz 1048236 BLAKE2B cc3d14137517cd26687dabac7e001e7518fee91aedc74f1995ac763873345f2965c3edb4e037ecb6ac8ca874289b2e658fe3185d95b3eeaf2b349efab151f37b SHA512 46ccf3dd7a5dd9ec1cac1eb742187ecab15a6c0033467d52a44c916e239696faf7b8797e1a155191cf0ed37b04619b0666cff51e78912a06ecd2c63d377cba93
+DIST gspiceui-v1.2.87.tar.gz 1089733 BLAKE2B c1801bfebd5d42fe9c1ab26e6fd0cb06b56cac53bbad272522896325e5fd979e6fcc63d6f99262b152180f249b5b2d4aa119aa83254a2fc07256574c9ebaef10 SHA512 081d04c39f4fb96139f12fa063dfb888e036948a00a6b55de3b04a49b2b4af01b45fd9b7f903855d798a71957452550dfa8c8505c167c239e27ada29cb6fa747
diff --git a/sci-electronics/gspiceui/files/gspiceui-1.2.87-respect-users-flags.patch b/sci-electronics/gspiceui/files/gspiceui-1.2.87-respect-users-flags.patch
new file mode 100644
index 000000000000..fd5881745279
--- /dev/null
+++ b/sci-electronics/gspiceui/files/gspiceui-1.2.87-respect-users-flags.patch
@@ -0,0 +1,28 @@
+diff --git a/src/Makefile b/src/Makefile
+index 50736fd..22a1328 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -91,13 +91,7 @@ BINDIR = $(ROOT)/bin
+ # -Os Optimize for size
+ # -Og Optimize debugging experience but don't break debugging
+ # -std=[C++NO] The C++ standard to use where C++NO is eg. c++98, c++03, c++11, c++14, c++17, etc.
+-ifeq ($(GSPICEUI_DEBUG),0)
+- # Options for release (not using -Wall since it's GCC specific)
+- CXXFLAGS := -O3 -std=c++17 -pipe $(shell $(WXCFG) --cxxflags)
+-else
+- # Options for development
+- CXXFLAGS := -g -Og -std=c++17 -Wall -Wextra -Wpedantic -pipe $(shell $(WXCFG) --cxxflags)
+-endif
++CXXFLAGS += $(shell $(WXCFG) --cxxflags)
+
+ # I like to compile using the option "-Wall" etc., tests that break wxWidgets are turned off below
+ ifeq ($(GSPICEUI_DEBUG),1)
+@@ -181,7 +175,7 @@ $(OBJDIR)/%.o : %.cpp
+ # -o specify the output file name
+
+ $(BINDIR)/$(PROG) : $(OBJS)
+- $(LD) -pipe -o $(BINDIR)/$(PROG) obj/*.o $(LIBS)
++ $(LD) -pipe -o $(BINDIR)/$(PROG) obj/*.o $(LDFLAGS) $(LIBS)
+ ifeq ($(ROOT)/GSpiceUI.app,$(wildcard $(ROOT)/GSpiceUI.app))
+ cp $(BINDIR)/$(PROG) $(ROOT)/GSpiceUI.app/Contents/MacOS/gspiceui
+ endif
diff --git a/sci-electronics/gspiceui/gspiceui-1.2.87.ebuild b/sci-electronics/gspiceui/gspiceui-1.2.87.ebuild
new file mode 100644
index 000000000000..8c007ed14442
--- /dev/null
+++ b/sci-electronics/gspiceui/gspiceui-1.2.87.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+inherit desktop optfeature toolchain-funcs wxwidgets
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="GUI frontend for Ngspice and Gnucap"
+HOMEPAGE="https://sourceforge.net/projects/gspiceui/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ sci-electronics/electronics-menu
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ sci-electronics/ngspice
+ sci-electronics/gnucap
+ )
+"
+
+PATCHES=(
+ # Use Gentoo LDFLAGS and CXXFLAGS
+ "${FILESDIR}"/${P}-respect-users-flags.patch
+)
+
+src_prepare() {
+ default
+
+ # Adjusting the doc path at src/main/FrmHtmlVwr.cpp
+ sed -i -e \
+ "s:/share/gspiceui/html/User-Manual.html:/share/doc/${PF}/html/User-Manual.html:g" \
+ src/main/FrmHtmlVwr.cpp || die
+}
+
+src_configure() {
+ setup-wxwidgets
+ default
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ dobin bin/gspiceui
+
+ einstalldocs
+ dodoc html/*.html html/*.jpg html/*.png
+ dodoc ChangeLog ReadMe ToDo release-notes-v${PV}.txt
+ doman gspiceui.1
+
+ # installing examples and according model and symbol files
+ use examples && dodoc -r lib sch
+
+ newicon -s 32 src/icons/gspiceui-32x32.xpm gspiceui.xpm
+ newicon -s 48 src/icons/gspiceui-48x48.xpm gspiceui.xpm
+ make_desktop_entry gspiceui "GNU Spice GUI" gspiceui "Electronics"
+}
+
+pkg_postinst() {
+ if use examples ; then
+ elog "If you want to use the examples, copy and extract from"
+ elog "${EROOT}/usr/share/doc/${PF} the sch and lib directory"
+ elog "side by side to your home directory to be able"
+ elog "to generate the netlists as normal user."
+ fi
+ optfeature "schematics editing" sci-electronics/geda
+ optfeature "waveform display" sci-electronics/gwave
+}