summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-28 06:51:16 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-28 06:51:16 +0200
commitbb4db5902aa004fff933872ee2e07803e651a3a4 (patch)
tree01d1f5a5b9191e469159ddc7b0f333660c04b78d
parentdev-python/humanize: Bump to 4.7.0 (diff)
downloadgentoo-bb4db5902aa004fff933872ee2e07803e651a3a4.tar.gz
gentoo-bb4db5902aa004fff933872ee2e07803e651a3a4.tar.bz2
gentoo-bb4db5902aa004fff933872ee2e07803e651a3a4.zip
dev-python/multipledispatch: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/multipledispatch/Manifest1
-rw-r--r--dev-python/multipledispatch/multipledispatch-1.0.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/multipledispatch/Manifest b/dev-python/multipledispatch/Manifest
index 05b253a5602a..7db279bcd944 100644
--- a/dev-python/multipledispatch/Manifest
+++ b/dev-python/multipledispatch/Manifest
@@ -1 +1,2 @@
DIST multipledispatch-0.6.0.gh.tar.gz 23692 BLAKE2B 4f73f05382c4aefbe3706839a18ba68d8ca0ed025744fe67d2069a770c517821d726913e5757dfe0ebe4628738b4b3dc83c76049f2beb4411b3679f574cc5f8d SHA512 34cefbceef1c756d06f0fbcf34709b70750928e21b1d5f02eef61eec3d5b8ce29475bfe4c53943f3fa9264b4de1f2524d813c6723927e576cd83771b6a4fcaf8
+DIST multipledispatch-1.0.0.gh.tar.gz 24244 BLAKE2B e10b19fcfd781aeb613bb4858243a888642bd588e9b167cf35902a4d1ba8e3461ce51edd6e3eb1bae092462774933c93638e03dd1632234e8370c5d9677425e9 SHA512 67237fa7736adc41ea3a27c5916ba5ed958619a1420390c0bab52c313b4423d4facb76fe8286bf2e831b366e6bf6d989716155901fc2acefe96c65ac5add45f3
diff --git a/dev-python/multipledispatch/multipledispatch-1.0.0.ebuild b/dev-python/multipledispatch/multipledispatch-1.0.0.ebuild
new file mode 100644
index 000000000000..5ba1f62d385f
--- /dev/null
+++ b/dev-python/multipledispatch/multipledispatch-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Multiple dispatch"
+HOMEPAGE="
+ https://pypi.org/project/multipledispatch/
+ https://github.com/mrocklin/multipledispatch/
+"
+SRC_URI="
+ https://github.com/mrocklin/multipledispatch/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ multipledispatch/tests/test_core.py::test_multipledispatch
+ multipledispatch/tests/test_benchmark.py
+)