summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-26 15:33:10 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-26 22:00:03 +0200
commitbdcfa9248d9148a8c273e006274c85fb2b977c5b (patch)
tree3817dc57a20d3880178f0e7eb9caa63b3b0ac174
parentdev-ada/gtkada: enable gnat_2020, fix VariableScope (diff)
downloadgentoo-bdcfa9248d9148a8c273e006274c85fb2b977c5b.tar.gz
gentoo-bdcfa9248d9148a8c273e006274c85fb2b977c5b.tar.bz2
gentoo-bdcfa9248d9148a8c273e006274c85fb2b977c5b.zip
sys-kernel/vanilla-kernel: Bump to 5.4.122
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-kernel/vanilla-kernel/Manifest2
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-5.4.122.ebuild108
2 files changed, 110 insertions, 0 deletions
diff --git a/sys-kernel/vanilla-kernel/Manifest b/sys-kernel/vanilla-kernel/Manifest
index 3519accd364d..eb4ebc8b9975 100644
--- a/sys-kernel/vanilla-kernel/Manifest
+++ b/sys-kernel/vanilla-kernel/Manifest
@@ -32,3 +32,5 @@ DIST linux-5.4.120.tar.sign 991 BLAKE2B 12c786791b72afccc4a3f9c412b900f25355920c
DIST linux-5.4.120.tar.xz 109107108 BLAKE2B d3ccfefaadfe4186cce3232dc0b58759914d0f9eb0ac7c82b855d0230a512b92e37801b75e32dde57ef5d6d6ee04c3bbd59f58a20e73304cf235c90c7dd2855b SHA512 b376e262164d8a79a4ffe478e42e38929fcc4b7f08dfaed24a842c238d55162ebcc1f6a5d0926a618e03f98f7f9623997306ffa66c6425f3e77865c2d70e1d54
DIST linux-5.4.121.tar.sign 991 BLAKE2B 379897a668e4f97041f48a3a7368f13629797e4ab69cfa41b1f7911be32413b312800121e4d04daa599da8e48d13eb9c4e74302624a89f690102ef021312de35 SHA512 e800edee4e01f7d0b80d636438e04b3f755859560114144fb54e987a11768b1872b6b89f548ea528f06d4e23995815c582629a164130ddcfe9bed76f8bd1dae2
DIST linux-5.4.121.tar.xz 109108220 BLAKE2B b1fe71ddcd3e47a653e92538ec5bf5b52bf265c4403bb856b9d0b20c60aa6abbf94db6a889f76e61e76001269f70b10600814fcd0db7ceb01089a0567ac35e6e SHA512 b68a19890ce90185e5253a635f844b59a4ee83753e4bcf89015b188af741d5a9531a07d05c4430458bec9c41c89c05c45567c93f8f68f9355bf29b973ce47d7c
+DIST linux-5.4.122.tar.sign 991 BLAKE2B 4c954e2fbfc89654da1646374b813f494d9a47e91122a52eb2de00cf83ca5ccc98d20c5cd3d1700e29a19012833d5ede9c220d06ba0dfd2de1874d41b8467972 SHA512 772f661535270438321e8edf77bd6d7bfb0dce0530147a2c706ecd0e6cf9006242f9138055011cb231fef7ca062b10f7c7046eb004abc80186d2629f1871c8fe
+DIST linux-5.4.122.tar.xz 109109228 BLAKE2B d9989903e30afea012fb46734378d2252519312bbab6c8380e53d43010b4f1a95f7cc0ab5dbe3ead700c609ea8ca0060fc67808f8a22f773dda26e836232dd59 SHA512 4b97b1754e342fc50db970883ecf1baee7f6402c5a4738bb4ce372614862e8fe93a45e5c95e2afa6c09171e6d9740400786eef45157f19ad2d7b5c110a39173a
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.122.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.122.ebuild
new file mode 100644
index 000000000000..e11e956ef1fd
--- /dev/null
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.122.ebuild
@@ -0,0 +1,108 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-build verify-sig
+
+MY_P=linux-${PV}
+# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
+CONFIG_VER=5.4.21
+CONFIG_HASH=2809b7faa6a8cb232cd825096c146b7bdc1e08ea
+GENTOO_CONFIG_VER=5.4.114
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ https://github.com/mgorny/gentoo-kernel-config/archive/v${GENTOO_CONFIG_VER}.tar.gz
+ -> gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz
+ verify-sig? (
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.sign
+ )
+ amd64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-x86_64.config
+ -> kernel-x86_64.config.${CONFIG_VER}
+ )
+ arm64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-aarch64.config
+ -> kernel-aarch64.config.${CONFIG_VER}
+ )
+ ppc64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-ppc64le.config
+ -> kernel-ppc64le.config.${CONFIG_VER}
+ )
+ x86? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-i686.config
+ -> kernel-i686.config.${CONFIG_VER}
+ )"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ !sys-kernel/vanilla-kernel-bin:${SLOT}"
+BDEPEND="
+ debug? ( dev-util/dwarves )
+ verify-sig? ( app-crypt/openpgp-keys-kernel )"
+PDEPEND="
+ >=virtual/dist-kernel-${PV}"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/kernel.org.asc
+
+pkg_pretend() {
+ ewarn "Starting with 5.4.52, Distribution Kernels are switching from Arch"
+ ewarn "Linux configs to Fedora. Please keep a backup kernel just in case."
+
+ kernel-install_pkg_pretend
+}
+
+src_unpack() {
+ if use verify-sig; then
+ einfo "Unpacking linux-${PV}.tar.xz ..."
+ verify-sig_verify_detached - "${DISTDIR}"/linux-${PV}.tar.sign \
+ < <(xz -cd "${DISTDIR}"/linux-${PV}.tar.xz | tee >(tar -x))
+ assert "Unpack failed"
+ unpack "gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz"
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}/kernel-x86_64.config.${CONFIG_VER}" .config || die
+ ;;
+ arm64)
+ cp "${DISTDIR}/kernel-aarch64.config.${CONFIG_VER}" .config || die
+ ;;
+ ppc64)
+ cp "${DISTDIR}/kernel-ppc64le.config.${CONFIG_VER}" .config || die
+ ;;
+ x86)
+ cp "${DISTDIR}/kernel-i686.config.${CONFIG_VER}" .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ echo 'CONFIG_LOCALVERSION="-dist"' > "${T}"/version.config || die
+ local merge_configs=(
+ "${T}"/version.config
+ "${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"/base.config
+ )
+ use debug || merge_configs+=(
+ "${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"/no-debug.config
+ )
+ [[ ${ARCH} == x86 ]] && merge_configs+=(
+ "${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"/32-bit.config
+ )
+
+ kernel-build_merge_configs "${merge_configs[@]}"
+}