summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2019-02-11 16:43:51 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2019-02-11 16:43:51 +0000
commitbea232b21ae38cdd1d4f4be5b8810aea5f763555 (patch)
treeb3bbfadfbfb228fc2aadeb5d2935d40e154bc8c0
parent2019-02-11 16:24:22 UTC (diff)
parentRevert "dev-libs/json-c: Drop old" (diff)
downloadgentoo-bea232b21ae38cdd1d4f4be5b8810aea5f763555.tar.gz
gentoo-bea232b21ae38cdd1d4f4be5b8810aea5f763555.tar.bz2
gentoo-bea232b21ae38cdd1d4f4be5b8810aea5f763555.zip
Merge updates from master
-rw-r--r--dev-libs/json-c/Manifest1
-rw-r--r--dev-libs/json-c/json-c-0.12.ebuild40
-rw-r--r--kde-misc/kmarkdownwebview/Manifest1
-rw-r--r--kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.3.ebuild39
-rw-r--r--kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.4.ebuild2
-rw-r--r--net-news/rawdog/rawdog-2.22-r1.ebuild2
-rw-r--r--sci-geosciences/qgis/files/qgis-3.0.0-featuresummary.patch26
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild4
8 files changed, 44 insertions, 71 deletions
diff --git a/dev-libs/json-c/Manifest b/dev-libs/json-c/Manifest
index 358927a4fd1b..40602e756dd0 100644
--- a/dev-libs/json-c/Manifest
+++ b/dev-libs/json-c/Manifest
@@ -1 +1,2 @@
+DIST json-c-0.12.tar.gz 501419 BLAKE2B 24f035792ff1ba5c39e55bca6ee4ba2509ab71d0374c70b520791f38e1ec4ff2245a282f234fde9f4a02cd9eaaaaa998ce307563a20702c04ee972fdf51f2539 SHA512 c959804362386f6b77e9d04b5fedf6d6aff1fcd0ab50250edb25f759b510b402e7ad4b33d1cbadc3337b63a3145d19f310812a9ee351748348304b384dc2dc35
DIST json-c-0.13.1.tar.gz 639425 BLAKE2B 1da310309f9ce03306a9fd4a161670e460cf0b2222348df7c006902390f74a4cf100aab1ce6ac8a361a278dd917c114a278de5b3445817f3a40ae287478add46 SHA512 e984db2a42b9c95b52c798b2e8dd1b79951a8dcba27370af30c43b9549fbb00008dbcf052a535c528209aaee38e6d1f760168b706905ae72f3e704ed20f8a1a1
diff --git a/dev-libs/json-c/json-c-0.12.ebuild b/dev-libs/json-c/json-c-0.12.ebuild
new file mode 100644
index 000000000000..9074dc523491
--- /dev/null
+++ b/dev-libs/json-c/json-c-0.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-multilib
+
+DESCRIPTION="A JSON implementation in C"
+HOMEPAGE="https://github.com/json-c/json-c/wiki"
+SRC_URI="https://s3.amazonaws.com/json-c_releases/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc static-libs"
+
+RDEPEND=""
+
+# tests break otherwise
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ sed -i -e "s:-Werror::" Makefile.am.inc || die
+ autotools-multilib_src_prepare
+}
+
+src_test() {
+ export USE_VALGRIND=0 VERBOSE=1
+ autotools-multilib_src_test
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${S}"/doc/html )
+ autotools-multilib_src_install
+
+ # add symlink for projects not using pkgconfig
+ dosym ../json-c /usr/include/json-c/json
+}
diff --git a/kde-misc/kmarkdownwebview/Manifest b/kde-misc/kmarkdownwebview/Manifest
index 6d831d4141ae..1e697d733a2c 100644
--- a/kde-misc/kmarkdownwebview/Manifest
+++ b/kde-misc/kmarkdownwebview/Manifest
@@ -1,2 +1 @@
-DIST kmarkdownwebview-0.5.3.tar.xz 62480 BLAKE2B ea8104b084e4be66aa37001cf7b1b159c8f7f03c2a32eb75d69aff2d447c9a57c1a5f0419137bfa790510bd8532a8bd7e171dae901d0bceab0cc193868069d83 SHA512 04864a069b502f0293d7b66c7ecfb4e32048611028f54b4e33cfcef4931fdc6a3947aff8c863975ea639bd2c3b9c8f2fbc27624247864e20862d050b032b6fc2
DIST kmarkdownwebview-0.5.4.tar.xz 64148 BLAKE2B 58a837afe1a85c0f5dfc5c7b3e2c93562e1cba61296712fb0fef7a03bc8d88feb97a65a67dc50f9d33f1099820112e501eb595dbf56ab9f13f19938bcad40719 SHA512 30dfd68f63b0b83905a9e2c8aff026313e4df3a4745e26fa9f420677788744e575ef848ffe3e930f0ea3d266a005006a9e033cbf9354c0072c4f2d2902bfc59d
diff --git a/kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.3.ebuild b/kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.3.ebuild
deleted file mode 100644
index e354d42dbbf3..000000000000
--- a/kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.3.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit kde5
-
-DESCRIPTION="KPart for rendering Markdown content"
-HOMEPAGE="https://frinring.wordpress.com/2017/09/14/kmarkdownwebview-0-1-0/"
-SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
-
-LICENSE="!webkit? ( BSD ) LGPL-2.1+"
-KEYWORDS="amd64"
-IUSE="webkit"
-
-DEPEND="
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep kparts)
- $(add_frameworks_dep kxmlgui)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtwidgets)
- webkit? ( $(add_qt_dep qtwebkit) )
- !webkit? (
- $(add_qt_dep qtwebchannel)
- $(add_qt_dep qtwebengine 'widgets')
- )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_QTWEBKIT=$(usex webkit)
- )
-
- kde5_src_configure
-}
diff --git a/kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.4.ebuild b/kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.4.ebuild
index 154c0e8d7749..86226db89b6f 100644
--- a/kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.4.ebuild
+++ b/kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.4.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://frinring.wordpress.com/2017/09/14/kmarkdownwebview-0-1-0/"
SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
LICENSE="!webkit? ( BSD ) LGPL-2.1+"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE="webkit"
DEPEND="
diff --git a/net-news/rawdog/rawdog-2.22-r1.ebuild b/net-news/rawdog/rawdog-2.22-r1.ebuild
index a36ab884c14d..e006e120796f 100644
--- a/net-news/rawdog/rawdog-2.22-r1.ebuild
+++ b/net-news/rawdog/rawdog-2.22-r1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="http://offog.org/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha ~amd64 hppa ia64 ppc ~s390 sparc x86"
+KEYWORDS="alpha amd64 hppa ia64 ppc ~s390 sparc x86"
DEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
diff --git a/sci-geosciences/qgis/files/qgis-3.0.0-featuresummary.patch b/sci-geosciences/qgis/files/qgis-3.0.0-featuresummary.patch
deleted file mode 100644
index 8b841a39b50f..000000000000
--- a/sci-geosciences/qgis/files/qgis-3.0.0-featuresummary.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 70505aa1569c541dd252115848f46f91811955c0 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 9 Apr 2017 20:21:28 +0200
-Subject: [PATCH 1/2] Use FeatureSummary
-
----
- CMakeLists.txt | 4 ++++
- 1 file changed, 4 insertions(+)
-
---- a/CMakeLists.txt 2018-10-27 17:19:26.188192919 +0200
-+++ b/CMakeLists.txt 2018-10-27 17:19:13.915507445 +0200
-@@ -68,6 +68,8 @@
- endif(USE_CCACHE)
- endif(NOT MSVC)
-
-+include(FeatureSummary)
-+
- # in generated makefiles use relative paths so the project dir is moveable
- # Note commented out since it cause problems but it would be nice to resolve these and enable
- #
-@@ -935,3 +937,5 @@
- IF (CMAKE_SYSTEM_NAME STREQUAL "Linux")
- ADD_SUBDIRECTORY(linux)
- ENDIF (CMAKE_SYSTEM_NAME STREQUAL "Linux")
-+
-+FEATURE_SUMMARY(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index afbd37bc704c..9e1e9a34acbe 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -101,8 +101,6 @@ RESTRICT="test"
PATCHES=(
# git master
"${FILESDIR}/${PN}-2.18.12-cmake-lib-suffix.patch"
- # TODO upstream
- "${FILESDIR}/${PN}-3.0.0-featuresummary.patch"
)
pkg_setup() {