summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-05-09 20:20:04 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-05-09 20:20:04 +0000
commitbf48b7ec8f796b22df74a9cd2c6405219e1ea62c (patch)
treef9c3bfc27e5e321cc70e7879a3cb317b2d0fc720
parent2022-05-09 19:48:21 UTC (diff)
parentdev-python/pytest-forked: Use PEP517 build (diff)
downloadgentoo-bf48b7ec8f796b22df74a9cd2c6405219e1ea62c.tar.gz
gentoo-bf48b7ec8f796b22df74a9cd2c6405219e1ea62c.tar.bz2
gentoo-bf48b7ec8f796b22df74a9cd2c6405219e1ea62c.zip
Merge updates from master
-rw-r--r--app-emacs/treemacs/files/50treemacs-gentoo.el2
-rw-r--r--app-emacs/treemacs/treemacs-2.10-r1.ebuild (renamed from app-emacs/treemacs/treemacs-2.10.ebuild)0
-rw-r--r--app-emacs/treemacs/treemacs-2.9.5-r1.ebuild (renamed from app-emacs/treemacs/treemacs-2.9.5.ebuild)0
-rw-r--r--dev-python/execnet/execnet-1.9.0-r1.ebuild46
-rw-r--r--dev-python/psutil/psutil-5.9.0.ebuild5
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.4.0-r1.ebuild36
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.5.0-r1.ebuild45
7 files changed, 129 insertions, 5 deletions
diff --git a/app-emacs/treemacs/files/50treemacs-gentoo.el b/app-emacs/treemacs/files/50treemacs-gentoo.el
index 431f7e90ae73..296e01d5b8b4 100644
--- a/app-emacs/treemacs/files/50treemacs-gentoo.el
+++ b/app-emacs/treemacs/files/50treemacs-gentoo.el
@@ -1 +1,3 @@
(add-to-list 'load-path "@SITELISP@")
+(autoload 'treemacs "treemacs"
+ "Initialise or toggle treemacs." t)
diff --git a/app-emacs/treemacs/treemacs-2.10.ebuild b/app-emacs/treemacs/treemacs-2.10-r1.ebuild
index ea3b8ab8544a..ea3b8ab8544a 100644
--- a/app-emacs/treemacs/treemacs-2.10.ebuild
+++ b/app-emacs/treemacs/treemacs-2.10-r1.ebuild
diff --git a/app-emacs/treemacs/treemacs-2.9.5.ebuild b/app-emacs/treemacs/treemacs-2.9.5-r1.ebuild
index ea3b8ab8544a..ea3b8ab8544a 100644
--- a/app-emacs/treemacs/treemacs-2.9.5.ebuild
+++ b/app-emacs/treemacs/treemacs-2.9.5-r1.ebuild
diff --git a/dev-python/execnet/execnet-1.9.0-r1.ebuild b/dev-python/execnet/execnet-1.9.0-r1.ebuild
new file mode 100644
index 000000000000..9132437f00a1
--- /dev/null
+++ b/dev-python/execnet/execnet-1.9.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Rapid multi-Python deployment"
+HOMEPAGE="
+ https://codespeak.net/execnet/
+ https://pypi.org/project/execnet/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # needs python2.7 with apipkg?
+ 'testing/test_termination.py::test_close_initiating_remote_no_error[python2.7]'
+ # tries to run python2
+ testing/test_channel.py::TestStringCoerce::test_3to2
+ testing/test_gateway.py::TestStringCoerce::test_3to2
+ # does not like Gentoo defaults
+ testing/test_gateway.py::TestPopenGateway::test_dont_write_bytecode
+ # almost all tests call py2, not worth filtering for the rest
+ testing/test_serializer.py
+)
+
+python_prepare_all() {
+ sed -i -r 's:(,[[:space:]]*|)"eventlet":: ; s:(,[[:space:]]*|)"gevent"(,|)::' \
+ testing/conftest.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/psutil/psutil-5.9.0.ebuild b/dev-python/psutil/psutil-5.9.0.ebuild
index df449a5481c5..baf0ec1ad2e9 100644
--- a/dev-python/psutil/psutil-5.9.0.ebuild
+++ b/dev-python/psutil/psutil-5.9.0.ebuild
@@ -23,11 +23,6 @@ PATCHES=(
)
python_test() {
- if [[ ${EPYTHON} == pypy* ]]; then
- ewarn "Not running tests on ${EPYTHON} since they are broken"
- return 0
- fi
-
# since we are running in an environment a bit similar to CI,
# let's skip the tests that are disable for CI
local -x TRAVIS=1
diff --git a/dev-python/pytest-forked/pytest-forked-1.4.0-r1.ebuild b/dev-python/pytest-forked/pytest-forked-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..ea35730f0141
--- /dev/null
+++ b/dev-python/pytest-forked/pytest-forked-1.4.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="run tests in isolated forked subprocesses"
+HOMEPAGE="
+ https://pypi.org/project/pytest-forked/
+ https://github.com/pytest-dev/pytest-forked/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Please do not RDEPEND on pytest; this package won't do anything
+# without pytest installed, and there is no reason to force older
+# implementations on pytest.
+RDEPEND="
+ dev-python/py[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:flaky
+}
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.5.0-r1.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.5.0-r1.ebuild
new file mode 100644
index 000000000000..68f728f1bae7
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-2.5.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xdist/
+ https://github.com/pytest-dev/pytest-xdist/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+
+ epytest
+}