summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-13 09:08:14 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-13 09:19:02 +0100
commitca6f9ee6422f71421044f2d9f156f452e2d45bf4 (patch)
tree82958b677c7d707685f606568fe17bd61a5a6691
parentsci-visualization/gle: clean old (diff)
downloadgentoo-ca6f9ee6422f71421044f2d9f156f452e2d45bf4.tar.gz
gentoo-ca6f9ee6422f71421044f2d9f156f452e2d45bf4.tar.bz2
gentoo-ca6f9ee6422f71421044f2d9f156f452e2d45bf4.zip
dev-ruby/thor: amd64 stable
This also requires dropping tests due to a long chain of circular dependencies. Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--dev-ruby/thor/thor-0.19.4.ebuild25
1 files changed, 4 insertions, 21 deletions
diff --git a/dev-ruby/thor/thor-0.19.4.ebuild b/dev-ruby/thor/thor-0.19.4.ebuild
index 21005803cb06..58028ada9729 100644
--- a/dev-ruby/thor/thor-0.19.4.ebuild
+++ b/dev-ruby/thor/thor-0.19.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+USE_RUBY="ruby22 ruby23 ruby24"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_TEST="none"
RUBY_FAKEGEM_DOCDIR="rdoc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
RUBY_FAKEGEM_BINWRAP="thor"
@@ -19,15 +19,9 @@ SRC_URI="https://github.com/erikhuda/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~amd64-linux"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~amd64-linux"
IUSE="doc"
-USE_RUBY="ruby21 ruby22 ruby23" ruby_add_bdepend "
- test? (
- dev-ruby/childlabor
- dev-ruby/webmock:0
- )"
-
all_ruby_prepare() {
# Remove rspec default options (as we might not have the last
# rspec).
@@ -45,14 +39,3 @@ all_ruby_prepare() {
# bug 430402
sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
}
-
-each_ruby_test() {
- case ${RUBY} in
- *ruby24)
- einfo "Skipping tests due to circular dependencies"
- ;;
- *)
- RSPEC_VERSION=3 ruby-ng_rspec spec || die
- ;;
- esac
-}