summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-06-26 11:12:36 +0200
committerDavid Seifert <soap@gentoo.org>2023-06-26 11:12:36 +0200
commitce4fffac82794c2adf6799bae81a3911329baeb7 (patch)
treee059baed610a104a40a873ae45e166b7cfbe6adc
parentsys-apps/pkgcore: Depend on bash[readline] for compgen (diff)
downloadgentoo-ce4fffac82794c2adf6799bae81a3911329baeb7.tar.gz
gentoo-ce4fffac82794c2adf6799bae81a3911329baeb7.tar.bz2
gentoo-ce4fffac82794c2adf6799bae81a3911329baeb7.zip
sys-fs/xfsprogs: drop 6.1.1, 6.2.0
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sys-fs/xfsprogs/Manifest2
-rw-r--r--sys-fs/xfsprogs/xfsprogs-6.1.1.ebuild94
-rw-r--r--sys-fs/xfsprogs/xfsprogs-6.2.0.ebuild95
3 files changed, 0 insertions, 191 deletions
diff --git a/sys-fs/xfsprogs/Manifest b/sys-fs/xfsprogs/Manifest
index e9b11d05bf05..dd1fcf78ad78 100644
--- a/sys-fs/xfsprogs/Manifest
+++ b/sys-fs/xfsprogs/Manifest
@@ -1,3 +1 @@
-DIST xfsprogs-6.1.1.tar.xz 1322528 BLAKE2B f6551356ccc68ee6d0bdc50edcf9717bfc94053e97b408f0fa6b316d51391bd347baa8c6ce09e269d09177eec14befc4235738e92d5e4408bda1113c79b2b18b SHA512 ec11cb9be34502a006f18ebea0a62aa227580753fce57cb7b6394d079fa41aee778382c06116a2fa45b67989a1501bbba2013829d2348b51e1136e668966c5e6
-DIST xfsprogs-6.2.0.tar.xz 1324216 BLAKE2B 847ad267b3667604c9c6a30857605e9cef0f184b7c375d0771b29a0c9596f621a819cc4e88af939a3f9a3ce14a2984fece5e70346bc673a5982af6eebe3909cc SHA512 71c04f744af9f4f3197a9c6eb468574d984c1532753f83f0bcd583cf737b89fab034442c072794975c813ea168572b39ae43f28d9a0428204be2fb7f1e141fc5
DIST xfsprogs-6.3.0.tar.xz 1328452 BLAKE2B 47a4ec45c88f26b32debd52283602d8244f996c071853b6bf7cf905f917436b1324bc9b58338346c8255201629d69e771d6c3bfd81f33f4f3c3907251d0a6c8c SHA512 dbb3e77d0d9cf184a0e647b8231350401a7549a23a0bfd9121cf2a1b48e85f71d98329dff440fc6e984bcecfdcc2a72f0f27c4989560f3c55359f21f3fb434bb
diff --git a/sys-fs/xfsprogs/xfsprogs-6.1.1.ebuild b/sys-fs/xfsprogs/xfsprogs-6.1.1.ebuild
deleted file mode 100644
index 7b3222444649..000000000000
--- a/sys-fs/xfsprogs/xfsprogs-6.1.1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic systemd usr-ldscript
-
-DESCRIPTION="XFS filesystem utilities"
-HOMEPAGE="https://xfs.wiki.kernel.org/ https://git.kernel.org/pub/scm/fs/xfs/xfsprogs-dev.git/"
-SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="icu libedit nls selinux"
-
-RDEPEND="dev-libs/inih
- dev-libs/userspace-rcu:=
- >=sys-apps/util-linux-2.17.2
- icu? ( dev-libs/icu:= )
- libedit? ( dev-libs/libedit )"
-DEPEND="${RDEPEND}"
-BDEPEND="nls? ( sys-devel/gettext )"
-RDEPEND+=" selinux? ( sec-policy/selinux-xfs )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.3.0-libdir.patch
- "${FILESDIR}"/${PN}-5.18.0-docdir.patch
-)
-
-src_prepare() {
- default
-
- # Fix doc dir
- sed -i \
- -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- include/builddefs.in || die
-
- # Don't install compressed docs
- sed 's@\(CHANGES\)\.gz[[:space:]]@\1 @' -i doc/Makefile || die
-}
-
-src_configure() {
- # include/builddefs.in will add FCFLAGS to CFLAGS which will
- # unnecessarily clutter CFLAGS (and fortran isn't used)
- unset FCFLAGS
-
- # If set in user env, this breaks configure
- unset PLATFORM
-
- export DEBUG=-DNDEBUG
-
- # Package is honoring CFLAGS; No need to use OPTIMIZER anymore.
- # However, we have to provide an empty value to avoid default
- # flags.
- export OPTIMIZER=" "
-
- # Avoid automagic on libdevmapper (bug #709694)
- export ac_cv_search_dm_task_create=no
-
- # Build fails with -O3 (bug #712698)
- replace-flags -O3 -O2
-
- # Upstream does NOT support --disable-static anymore,
- # https://www.spinics.net/lists/linux-xfs/msg30185.html
- # https://www.spinics.net/lists/linux-xfs/msg30272.html
- local myconf=(
- --enable-blkid
- --with-crond-dir="${EPREFIX}/etc/cron.d"
- --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
- $(use_enable icu libicu)
- $(use_enable nls gettext)
- $(use_enable libedit editline)
- )
-
- if is-flagq -flto ; then
- myconf+=( --enable-lto )
- else
- myconf+=( --disable-lto )
- fi
-
- econf "${myconf[@]}"
-}
-
-src_compile() {
- emake V=1
-}
-
-src_install() {
- emake DIST_ROOT="${ED}" HAVE_ZIPPED_MANPAGES=false install
- emake DIST_ROOT="${ED}" HAVE_ZIPPED_MANPAGES=false install-dev
-
- gen_usr_ldscript -a handle
-}
diff --git a/sys-fs/xfsprogs/xfsprogs-6.2.0.ebuild b/sys-fs/xfsprogs/xfsprogs-6.2.0.ebuild
deleted file mode 100644
index f9a26d57b3d1..000000000000
--- a/sys-fs/xfsprogs/xfsprogs-6.2.0.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic systemd usr-ldscript
-
-DESCRIPTION="XFS filesystem utilities"
-HOMEPAGE="https://xfs.wiki.kernel.org/ https://git.kernel.org/pub/scm/fs/xfs/xfsprogs-dev.git/"
-SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="icu libedit nls selinux"
-
-RDEPEND="dev-libs/inih
- dev-libs/userspace-rcu:=
- >=sys-apps/util-linux-2.17.2
- icu? ( dev-libs/icu:= )
- libedit? ( dev-libs/libedit )"
-DEPEND="${RDEPEND}"
-BDEPEND="nls? ( sys-devel/gettext )"
-RDEPEND+=" selinux? ( sec-policy/selinux-xfs )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.3.0-libdir.patch
- "${FILESDIR}"/${PN}-5.18.0-docdir.patch
-)
-
-src_prepare() {
- default
-
- # Fix doc dir
- sed -i \
- -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- include/builddefs.in || die
-
- # Don't install compressed docs
- sed 's@\(CHANGES\)\.gz[[:space:]]@\1 @' -i doc/Makefile || die
-}
-
-src_configure() {
- # include/builddefs.in will add FCFLAGS to CFLAGS which will
- # unnecessarily clutter CFLAGS (and fortran isn't used)
- unset FCFLAGS
-
- # If set in user env, this breaks configure
- unset PLATFORM
-
- export DEBUG=-DNDEBUG
-
- # Package is honoring CFLAGS; No need to use OPTIMIZER anymore.
- # However, we have to provide an empty value to avoid default
- # flags.
- export OPTIMIZER=" "
-
- # Avoid automagic on libdevmapper (bug #709694)
- export ac_cv_search_dm_task_create=no
-
- # Build fails with -O3 (bug #712698)
- replace-flags -O3 -O2
-
- # Upstream does NOT support --disable-static anymore,
- # https://www.spinics.net/lists/linux-xfs/msg30185.html
- # https://www.spinics.net/lists/linux-xfs/msg30272.html
- local myconf=(
- --enable-static
- --enable-blkid
- --with-crond-dir="${EPREFIX}/etc/cron.d"
- --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
- $(use_enable icu libicu)
- $(use_enable nls gettext)
- $(use_enable libedit editline)
- )
-
- if is-flagq -flto ; then
- myconf+=( --enable-lto )
- else
- myconf+=( --disable-lto )
- fi
-
- econf "${myconf[@]}"
-}
-
-src_compile() {
- emake V=1
-}
-
-src_install() {
- emake DIST_ROOT="${ED}" HAVE_ZIPPED_MANPAGES=false install
- emake DIST_ROOT="${ED}" HAVE_ZIPPED_MANPAGES=false install-dev
-
- gen_usr_ldscript -a handle
-}