summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-30 21:58:49 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-30 22:02:11 +0100
commitd1b8d32f60f323db56ccf734254bcdb10fdd132c (patch)
tree66dbd32907b4d3d9071427cf2d9b9fe19c4012da
parentxfce-extra/thunar-media-tags-plugin: Bump to 0.5.0 (diff)
downloadgentoo-d1b8d32f60f323db56ccf734254bcdb10fdd132c.tar.gz
gentoo-d1b8d32f60f323db56ccf734254bcdb10fdd132c.tar.bz2
gentoo-d1b8d32f60f323db56ccf734254bcdb10fdd132c.zip
xfce-extra/thunar-vcs-plugin: Bump to 0.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/thunar-vcs-plugin/Manifest1
-rw-r--r--xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.3.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/xfce-extra/thunar-vcs-plugin/Manifest b/xfce-extra/thunar-vcs-plugin/Manifest
index ddb51e870d46..d4fef3df761a 100644
--- a/xfce-extra/thunar-vcs-plugin/Manifest
+++ b/xfce-extra/thunar-vcs-plugin/Manifest
@@ -1 +1,2 @@
DIST thunar-vcs-plugin-0.2.0.tar.bz2 546608 BLAKE2B ccd0d057e358b321b6287284c25ee03c4252f5e120fcba9272139ebf0739ee7363e619da12f86e725abc70d4834451ec112386ba2b008b038c03571d26349f51 SHA512 c33f54caa2f27de6c8f9e5cb8368f7538ea82730f1364ad974b19017a25bc6a398c19dfe861b0d0133db08ee36e4e209c8d824ce07de0c2ae6da830aca9e7e68
+DIST thunar-vcs-plugin-0.3.0.tar.bz2 808074 BLAKE2B 17c850fa628eec06e043355f9b637f8de914fadc2554d4cf265f7e2b36ebeffb564cbd118bda1f0b2ee086fe2ee4448cf15b664f8b897829142c90502e252bdb SHA512 81f9a545d55dc09f0008ab54b5a9edebd5d72526d18e78722df2b3ee2e475e453e9a4113cb2e87b64d74d8bc31d6e112a30b8077ad3ac485d0e810fb3a0d20e7
diff --git a/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.3.0.ebuild b/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.3.0.ebuild
new file mode 100644
index 000000000000..34e364504ce0
--- /dev/null
+++ b/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.3.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Adds Subversion and GIT actions to the context menu of thunar"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/thunar/thunar-vcs-plugin
+ https://gitlab.xfce.org/thunar-plugins/thunar-vcs-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="+git subversion"
+
+DEPEND="
+ >=dev-libs/glib-2.32:2=
+ >=x11-libs/gtk+-3.20:3=
+ >=xfce-base/exo-0.11.4:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/thunar-1.7:=
+ git? ( dev-vcs/git )
+ subversion? (
+ >=dev-libs/apr-0.9.7:=
+ >=dev-libs/apr-util-0.9.1:=
+ >=dev-vcs/subversion-1.5:=
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable subversion)
+ $(use_enable git)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}