summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-29 04:12:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-29 04:12:52 +0200
commitd2d6b9cd0013af6e4004acb464eeb6e1f5f111ac (patch)
tree9220336b2c2e0d508d9759a2fce27d70e7c95804
parentdev-python/botocore: Bump to 1.34.136 (diff)
downloadgentoo-d2d6b9cd0013af6e4004acb464eeb6e1f5f111ac.tar.gz
gentoo-d2d6b9cd0013af6e4004acb464eeb6e1f5f111ac.tar.bz2
gentoo-d2d6b9cd0013af6e4004acb464eeb6e1f5f111ac.zip
dev-python/boto3: Bump to 1.34.136
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.136.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 115b267657dd..d29cb3e4fb19 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.34.132.gh.tar.gz 823417 BLAKE2B b78d25f597f3035653a5af46fc865b5840f
DIST boto3-1.34.133.gh.tar.gz 823981 BLAKE2B 3a0d10f1154930d09236552b8978403ed5c35627faa608e70fb11d70badf547e2924f0e8183b323fb7cc59bcf5b83ab1ad9f38cdc024d317aaad58af3abb6b20 SHA512 7e46f72c1e1ef18f89379b4a430ecdbc00c15d8dd733b2b303d69d1ddf8a34b416fe37fad846bfc8fd868403589a59232281c84ec7207332e868a54bafc90668
DIST boto3-1.34.134.gh.tar.gz 824465 BLAKE2B 0a39dbafb278296a28c2077a92c0145e4b4c00d46aebf1deecf4406e71e1a0e733c1bd7c119bd66b2d127725861e8f5821725d1ac97135a854ce9e841eb2f601 SHA512 739b86b258d3bfbc1a950bf2ab641cb8a27f21b0d1ee9fab69917f715e0f6c3394a29653e6ff078a0cbb105b001e66424fe59cda72938cfdcb28c324ee01e9ca
DIST boto3-1.34.135.gh.tar.gz 825414 BLAKE2B b17a1c9baf0daf33dd4e9e050c0bd1e19008cf2cb690c96b5b2cd24126fc4b3b7b444ed3adda5b90e564592c549f0d189b8cd9b4c029c7baf059a526e5535fa1 SHA512 956c20b05d39489ee34d82a06d6d9b6a240414eb46b487fb518bc118a3abf71958fbea6d2e43ae404824360ca19d3f9ca15cee21f67d65eb56a4cf0c0783c3ca
+DIST boto3-1.34.136.gh.tar.gz 826543 BLAKE2B 307705ba777d155772a2dafad775e55d94e17a9e4c2986e48bd8a691c3bc4e433f212e1a59053222927bda42584b2d1d266bc2489f94fd3e4463416c56531d54 SHA512 f2307db517b393164028c17a8073c5baf7f7e3be36c988a90d455cad98a55b7a7e1a6e44584038141047237e81cb495bffaf70747de421ce316bb457e2d168e8
diff --git a/dev-python/boto3/boto3-1.34.136.ebuild b/dev-python/boto3/boto3-1.34.136.ebuild
new file mode 100644
index 000000000000..2c733040b7a3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.136.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}