summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-02 19:42:57 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-02 21:48:50 +0100
commitd6d91a38a9c20f553c015cb013348b66d1fadaf1 (patch)
treef2fdc3538185f8cde72abe4a451d5ce2e324728e
parentnet-mail/fetchmail: drop old (diff)
downloadgentoo-d6d91a38a9c20f553c015cb013348b66d1fadaf1.tar.gz
gentoo-d6d91a38a9c20f553c015cb013348b66d1fadaf1.tar.bz2
gentoo-d6d91a38a9c20f553c015cb013348b66d1fadaf1.zip
dev-python/apsw: Bump to 3.45.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.45.1.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index d1ca91d84d38..9e8b9c6f9273 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1 +1,2 @@
DIST apsw-3.44.2.0.gh.tar.gz 902852 BLAKE2B bdaf72ef063d3ddaf46bf403e688ffe5ee657de5a17ca3aba496058d8f244fdfd82b41899f3c944b6d7cdfe5bab0e7608bd26db926016df6af9fa5a950c12415 SHA512 76f8b92feb792c3003d251bcf61dab80bfb34147cfb8512ad6ff1dd1f07b4e7a5c97b98c4bfc7fee179efc7439ea28573552ae25d5bc33e633da0722866fd551
+DIST apsw-3.45.1.0.gh.tar.gz 904083 BLAKE2B 4cf397557bfe36e38fd48d124345de395b77a8dd313ebd77f97624d873123d5ecd82e56b6e134849e00a77f94b0c3ee2fa0cfc888b8fbbddc34b99b3274b8dc8 SHA512 5d754c45881db9e299c70bd0c290211f7e30421da258b25b5aa0d8b3c97a10622f0b75735fc84d687f78403fc257139ffc249d926be611a4101b98caf3c60a3a
diff --git a/dev-python/apsw/apsw-3.45.1.0.ebuild b/dev-python/apsw/apsw-3.45.1.0.ebuild
new file mode 100644
index 000000000000..7fe76f0deaa5
--- /dev/null
+++ b/dev-python/apsw/apsw-3.45.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ enable=load_extension
+ use_system_sqlite_config=True
+ EOF
+}
+
+python_test() {
+ esetup.py build_test_extension
+ cd "${T}" || die
+ "${EPYTHON}" -m apsw.tests -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}