summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-23 04:21:28 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-23 04:37:10 +0100
commitd79ec3733ed4827413ff45c350b5bdcadbde82d0 (patch)
tree0a153a2140721ecdc92ef7c18e620ed47cef4e3b
parentdev-python/openstacksdk: Bump to 3.0.0 (diff)
downloadgentoo-d79ec3733ed4827413ff45c350b5bdcadbde82d0.tar.gz
gentoo-d79ec3733ed4827413ff45c350b5bdcadbde82d0.tar.bz2
gentoo-d79ec3733ed4827413ff45c350b5bdcadbde82d0.zip
dev-python/oslo-i18n: Bump to 6.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/oslo-i18n/Manifest1
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-6.3.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/oslo-i18n/Manifest b/dev-python/oslo-i18n/Manifest
index e914d3e3d826..05eef74bcfa2 100644
--- a/dev-python/oslo-i18n/Manifest
+++ b/dev-python/oslo-i18n/Manifest
@@ -1 +1,2 @@
DIST oslo.i18n-6.2.0.tar.gz 48228 BLAKE2B bb65caff703e2bbc82f4fecd4b0d491f64ec7d863f848f8f79497df9471257dec25a77ad7f084c6d88ac14a4b1a1f44fd302297e1e13919e69ebaf27c5491d6f SHA512 725d814c7db35250e8ffe06c0021fc9147bcdaa300791f1d50b0eef2897abe609b415a12b6aa58d50925516fd9e6a1ad54e141f77e11856de3ab765b4e06939b
+DIST oslo.i18n-6.3.0.tar.gz 48207 BLAKE2B 20a882516dd45da8dda34127ba422a619decd982f01adeee5909b8646d49c8609ecb6adad4fc48ab32e820c4dcf4a42d4baf7e776983daf4586ae944b738bb6e SHA512 483ff39425b3fc5c6c54a3502a78a53406ccb3cdb7aff0836b9c2a49b8146fd931e2b4f3133d708d33d16bd99155f8cbcf8505491d74de5016da5e647a069a15
diff --git a/dev-python/oslo-i18n/oslo-i18n-6.3.0.ebuild b/dev-python/oslo-i18n/oslo-i18n-6.3.0.ebuild
new file mode 100644
index 000000000000..c578a7449021
--- /dev/null
+++ b/dev-python/oslo-i18n/oslo-i18n-6.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo i18n library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.i18n/
+ https://github.com/openstack/oslo.i18n/
+ https://pypi.org/project/oslo.i18n/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest