summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-04-29 17:05:11 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-04-29 17:05:11 +0000
commitdf1db7b952adb03657ca26637e52871863d9de13 (patch)
treeef9c11b32e3108a8c98d6eca293cd3b6d48348cc
parent2021-04-29 16:20:12 UTC (diff)
parentx11-plugins/pidgin-telegram: remove libressl support (diff)
downloadgentoo-df1db7b952adb03657ca26637e52871863d9de13.tar.gz
gentoo-df1db7b952adb03657ca26637e52871863d9de13.tar.bz2
gentoo-df1db7b952adb03657ca26637e52871863d9de13.zip
Merge updates from master
-rw-r--r--dev-util/packer/Manifest3
-rw-r--r--dev-util/packer/packer-1.6.6.ebuild (renamed from dev-util/packer/packer-1.6.5.ebuild)2
-rw-r--r--dev-util/packer/packer-1.7.2.ebuild34
-rw-r--r--x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild7
4 files changed, 39 insertions, 7 deletions
diff --git a/dev-util/packer/Manifest b/dev-util/packer/Manifest
index 459a61ab17ee..310e77836185 100644
--- a/dev-util/packer/Manifest
+++ b/dev-util/packer/Manifest
@@ -1 +1,2 @@
-DIST packer-1.6.5.tar.gz 17900733 BLAKE2B b267f5b861de9eb4fc88ab747560aef30825897e1f42038ff443185c6591afec039e12a4639ca22598704a7ada68b8af373c67f7391f9884566fd0f431b3c0ee SHA512 17df612ccac44f6ee987cfee0f5b0422768302a40e7e4177c47e427fd0aa09be136ceda40272e6a1cbdeb52587b5c93f2fe7158f787e19399149ee514fec001d
+DIST packer-1.6.6.tar.gz 17130110 BLAKE2B 3e348d3b3afc65cb50d4e855dd3138892dbc1c1f049fa50849e988ac2d0263a7438b706d595e99fb7a6a11e4b1594e3027ffc137fe7c263017c7b00153b350cb SHA512 0b856cf7a745621bedf8b8b7998e1267a8b16fea2f066d39beeccd2b6bb5eb9ba01276c98bebe9f2f53f3916be71ba2d86d409ad532a8b7648a00c256aa776d2
+DIST packer-1.7.2.tar.gz 17972088 BLAKE2B 6599c9bb19380ed08d186b1f1bd5d9ad581425acce59920a02d4dcdc5237e8f9f9f9af264b4d1ed93f39a56061b9c391fcccdd2582393af420d72421abbd1beb SHA512 019bd07571ca59cb8fbf6edb5dc7f57af11c43b144986222c3d560a812f25d61bbc87a554963eea479f8bfe61abacca7173c4f12b1bc09ffaf78c269624c826e
diff --git a/dev-util/packer/packer-1.6.5.ebuild b/dev-util/packer/packer-1.6.6.ebuild
index f7b69386e57d..302cc7c43eea 100644
--- a/dev-util/packer/packer-1.6.5.ebuild
+++ b/dev-util/packer/packer-1.6.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
diff --git a/dev-util/packer/packer-1.7.2.ebuild b/dev-util/packer/packer-1.7.2.ebuild
new file mode 100644
index 000000000000..302cc7c43eea
--- /dev/null
+++ b/dev-util/packer/packer-1.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 MIT MPL-2.0 unicode"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( {README,CHANGELOG}.md )
+
+RESTRICT+=" test"
+
+src_compile() {
+ go build \
+ -ldflags "${go_ldflags}" \
+ -mod=vendor \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/packer
+
+ einstalldocs
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+}
diff --git a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild
index ce82b54c47d4..7dac50fdb5bd 100644
--- a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild
+++ b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild
@@ -11,16 +11,13 @@ S="${WORKDIR}/telegram-purple"
LICENSE="GPL-2+"
KEYWORDS="amd64 x86"
SLOT="0"
-IUSE="gcrypt libressl +nls +png +webp"
+IUSE="gcrypt +nls +png +webp"
RDEPEND="
net-im/pidgin
sys-libs/zlib:=
gcrypt? ( dev-libs/libgcrypt:0= )
- !gcrypt? (
- libressl? ( dev-libs/libressl:0= )
- !libressl? ( dev-libs/openssl:0= )
- )
+ !gcrypt? ( dev-libs/openssl:0= )
png? ( media-libs/libpng:0= )
webp? ( media-libs/libwebp:= )
"