summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2016-06-03 14:26:25 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2016-06-03 14:26:25 +0000
commite1539e71ee309115b64b70229d8fc97fb083ca39 (patch)
treeafc2d988bb5e474c18ca9341f554bf1f85ca83ea
parent2016-06-03 13:36:23 UTC (diff)
parentapp-crypt/sign: add libressl support (diff)
downloadgentoo-e1539e71ee309115b64b70229d8fc97fb083ca39.tar.gz
gentoo-e1539e71ee309115b64b70229d8fc97fb083ca39.tar.bz2
gentoo-e1539e71ee309115b64b70229d8fc97fb083ca39.zip
Merge updates from master
-rw-r--r--app-crypt/keynote/keynote-2.3-r3.ebuild7
-rw-r--r--app-crypt/openssl-tpm-engine/openssl-tpm-engine-0.4.2.ebuild10
-rw-r--r--app-crypt/ophcrack/ophcrack-3.3.1.ebuild9
-rw-r--r--app-crypt/ophcrack/ophcrack-3.4.0.ebuild9
-rw-r--r--app-crypt/ophcrack/ophcrack-3.6.0.ebuild9
-rw-r--r--app-crypt/osslsigncode/osslsigncode-1.4.ebuild10
-rw-r--r--app-crypt/pesign/pesign-0.108.ebuild7
-rw-r--r--app-crypt/pkcs11-dump/pkcs11-dump-0.3.4.ebuild10
-rw-r--r--app-crypt/sbsigntool/sbsigntool-0.6-r1.ebuild10
-rw-r--r--app-crypt/sign/sign-1.0.7.ebuild10
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/metadata.xml9
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.3.ebuild69
13 files changed, 133 insertions, 37 deletions
diff --git a/app-crypt/keynote/keynote-2.3-r3.ebuild b/app-crypt/keynote/keynote-2.3-r3.ebuild
index b599291bb26c..17d3c8fcfcf8 100644
--- a/app-crypt/keynote/keynote-2.3-r3.ebuild
+++ b/app-crypt/keynote/keynote-2.3-r3.ebuild
@@ -13,9 +13,12 @@ SRC_URI="http://www1.cs.columbia.edu/~angelos/Code/${P}.tar.gz"
LICENSE="keynote"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="ssl"
+IUSE="libressl ssl"
-RDEPEND="ssl? ( dev-libs/openssl:0 )"
+RDEPEND="ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
DEPEND="${RDEPEND}
virtual/yacc"
diff --git a/app-crypt/openssl-tpm-engine/openssl-tpm-engine-0.4.2.ebuild b/app-crypt/openssl-tpm-engine/openssl-tpm-engine-0.4.2.ebuild
index 6f99d19ef349..9539e900227a 100644
--- a/app-crypt/openssl-tpm-engine/openssl-tpm-engine-0.4.2.ebuild
+++ b/app-crypt/openssl-tpm-engine/openssl-tpm-engine-0.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,9 +13,11 @@ HOMEPAGE="http://trousers.sourceforge.net"
SRC_URI="mirror://sourceforge/trousers/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE=""
-RDEPEND=">=dev-libs/openssl-0.9.8:*
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
>=app-crypt/trousers-0.2.8"
DEPEND="${RDEPEND}"
diff --git a/app-crypt/ophcrack/ophcrack-3.3.1.ebuild b/app-crypt/ophcrack/ophcrack-3.3.1.ebuild
index 22aa37c1e377..1e1909f01a3c 100644
--- a/app-crypt/ophcrack/ophcrack-3.3.1.ebuild
+++ b/app-crypt/ophcrack/ophcrack-3.3.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="3"
+EAPI="5"
inherit eutils
DESCRIPTION="A time-memory-trade-off-cracker"
@@ -12,9 +12,10 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="qt4 debug +tables"
+IUSE="debug libressl qt4 +tables"
-CDEPEND="dev-libs/openssl
+CDEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
net-libs/netwib
qt4? ( dev-qt/qtgui:4 )"
DEPEND="app-arch/unzip
diff --git a/app-crypt/ophcrack/ophcrack-3.4.0.ebuild b/app-crypt/ophcrack/ophcrack-3.4.0.ebuild
index 22aa37c1e377..1e1909f01a3c 100644
--- a/app-crypt/ophcrack/ophcrack-3.4.0.ebuild
+++ b/app-crypt/ophcrack/ophcrack-3.4.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="3"
+EAPI="5"
inherit eutils
DESCRIPTION="A time-memory-trade-off-cracker"
@@ -12,9 +12,10 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="qt4 debug +tables"
+IUSE="debug libressl qt4 +tables"
-CDEPEND="dev-libs/openssl
+CDEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
net-libs/netwib
qt4? ( dev-qt/qtgui:4 )"
DEPEND="app-arch/unzip
diff --git a/app-crypt/ophcrack/ophcrack-3.6.0.ebuild b/app-crypt/ophcrack/ophcrack-3.6.0.ebuild
index bf6912108a04..1e1909f01a3c 100644
--- a/app-crypt/ophcrack/ophcrack-3.6.0.ebuild
+++ b/app-crypt/ophcrack/ophcrack-3.6.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="3"
+EAPI="5"
inherit eutils
DESCRIPTION="A time-memory-trade-off-cracker"
@@ -12,9 +12,10 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="qt4 debug +tables"
+IUSE="debug libressl qt4 +tables"
-CDEPEND="dev-libs/openssl
+CDEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
net-libs/netwib
qt4? ( dev-qt/qtgui:4 )"
DEPEND="app-arch/unzip
diff --git a/app-crypt/osslsigncode/osslsigncode-1.4.ebuild b/app-crypt/osslsigncode/osslsigncode-1.4.ebuild
index 40c7df0e2359..f96b63665d86 100644
--- a/app-crypt/osslsigncode/osslsigncode-1.4.ebuild
+++ b/app-crypt/osslsigncode/osslsigncode-1.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
DESCRIPTION="Platform-independent tool for Authenticode signing of EXE/CAB files"
HOMEPAGE="https://sourceforge.net/projects/osslsigncode"
@@ -11,9 +11,11 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="curl"
+IUSE="curl libressl"
-RDEPEND="dev-libs/openssl
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
curl? ( net-misc/curl )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
diff --git a/app-crypt/pesign/pesign-0.108.ebuild b/app-crypt/pesign/pesign-0.108.ebuild
index a17c46449a83..3189c1c7ef8c 100644
--- a/app-crypt/pesign/pesign-0.108.ebuild
+++ b/app-crypt/pesign/pesign-0.108.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,11 +13,12 @@ SRC_URI="https://github.com/vathpela/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="libressl"
RDEPEND="
dev-libs/nspr
- dev-libs/openssl:0
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
sys-apps/util-linux
"
DEPEND="${RDEPEND}
diff --git a/app-crypt/pkcs11-dump/pkcs11-dump-0.3.4.ebuild b/app-crypt/pkcs11-dump/pkcs11-dump-0.3.4.ebuild
index d5cf2f11a471..3f8c5974e96d 100644
--- a/app-crypt/pkcs11-dump/pkcs11-dump-0.3.4.ebuild
+++ b/app-crypt/pkcs11-dump/pkcs11-dump-0.3.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
DESCRIPTION="Utilities for PKCS#11 token content dump"
HOMEPAGE="https://sites.google.com/site/alonbarlev/pkcs11-utilities"
@@ -13,9 +13,11 @@ SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="libressl"
-RDEPEND=">=dev-libs/openssl-0.9.7:0"
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
diff --git a/app-crypt/sbsigntool/sbsigntool-0.6-r1.ebuild b/app-crypt/sbsigntool/sbsigntool-0.6-r1.ebuild
index cc49b5b2dc65..cbb72cffde8e 100644
--- a/app-crypt/sbsigntool/sbsigntool-0.6-r1.ebuild
+++ b/app-crypt/sbsigntool/sbsigntool-0.6-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit eutils toolchain-funcs
@@ -13,9 +13,11 @@ SRC_URI="https://launchpad.net/ubuntu/+archive/primary/+files/${PN}_${PV}.orig.t
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
+IUSE="libressl"
-RDEPEND="dev-libs/openssl
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
sys-apps/util-linux"
DEPEND="${RDEPEND}
sys-apps/help2man
diff --git a/app-crypt/sign/sign-1.0.7.ebuild b/app-crypt/sign/sign-1.0.7.ebuild
index 3277e9e9ba25..dd59e5d0f64f 100644
--- a/app-crypt/sign/sign-1.0.7.ebuild
+++ b/app-crypt/sign/sign-1.0.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit toolchain-funcs eutils
@@ -13,9 +13,11 @@ SRC_URI="http://swapped.cc/${PN}/files/${P}.tar.gz"
LICENSE="BZIP2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
+IUSE="libressl"
-RDEPEND=">=dev-libs/openssl-0.9.8"
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
DEPEND="${RDEPEND}"
src_prepare() {
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/Manifest b/xfce-extra/xfce4-whiskermenu-plugin/Manifest
index a15332be19be..359d14e27b2e 100644
--- a/xfce-extra/xfce4-whiskermenu-plugin/Manifest
+++ b/xfce-extra/xfce4-whiskermenu-plugin/Manifest
@@ -1,3 +1,4 @@
DIST xfce4-whiskermenu-plugin-1.5.0-src.tar.bz2 145549 SHA256 da82bdbc899a9935b560323aac9037d44f37fb110509b80ec293196722671851 SHA512 2cfbade2926fc7ff936ae2d5be2ef1d6a49e9ffc79fc9d9b78ba75070b70e7978ce4ae20df08b7d1089f016741231be029f92cd4b53cbaf7dfec08c97ad60028 WHIRLPOOL fc6e9a32e6fc6e0a8127b214899c743712503fff0a117e993b3c8049004b75519690948e4bf664a6200ae54e29c1cd70ab919dfd5953acee02e11aa77537768d
DIST xfce4-whiskermenu-plugin-1.5.1-src.tar.bz2 148050 SHA256 1c7650562322867513370ab575536b67aa3712329bb60a0c91a0a70e23a8945a SHA512 ae1ea2395d574fc942dc83303e768be776968b5f6cd69310450c2c4f291c9639e430c8a65282da8587be930baa503905eaf69bbab5b86c552d4de7689dd2ae79 WHIRLPOOL eafefc8da4fa38f2e82a6ec44d5448152633a19850a26e92a5ebd601564485988fd696358bb55709bc78c828a06269af9aa3cd66a74d40d8efeeb825fc3d95fb
DIST xfce4-whiskermenu-plugin-1.5.2.tar.gz 152494 SHA256 ffab7120d18591bb8cfc055e9e3d162c97e8d5d960dd12ebdee4fae7766d757b SHA512 deca89e8ca8f8e2b0674961d24ca71fca6d8527c6b8ae8042a9aa62027adc1b4de304a7d0f7678b65e9ebc7559f877cefec00dc1f3ac764c7189ada97b83f863 WHIRLPOOL 452a9134584b47a8e210aa1cc9a3643cafb535e309fa40426574e052772afa0105b21ab086ab0aa39dbbe8e27f2c13c65a14aadc84b64a38a82d9e49cbdb5d6a
+DIST xfce4-whiskermenu-plugin-1.5.3.tar.gz 155395 SHA256 12a54f1086ba4edad3c0837bc3cbc8da35ff45dc6c5973f92d6ebe9ac4a2e03e SHA512 974a206456a334253c1c03ef7932f1836427a771faec92daf0b766878b95e61eea4b29545c96c14fdafd3af0b3b4bf07127e48b973fb8aa809397eb22712362b WHIRLPOOL d03f87167639c1493e45eea2a10c01a9880e1822ad54cb9414d5637998e53c99d01c03b4469ef345572173170ed7b64d41b5ade075b56d757df572d20db177cd
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/metadata.xml b/xfce-extra/xfce4-whiskermenu-plugin/metadata.xml
index 2fd56a300e4b..6c18f61c3984 100644
--- a/xfce-extra/xfce4-whiskermenu-plugin/metadata.xml
+++ b/xfce-extra/xfce4-whiskermenu-plugin/metadata.xml
@@ -1,6 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>christian.tietz@mailbox.org</email>
+ <name>Christian Tietz</name>
+ <description>Proxy Maintainer</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<maintainer type="project">
<email>xfce@gentoo.org</email>
<name>XFCE Team</name>
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.3.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.3.ebuild
new file mode 100644
index 000000000000..00713a5aad85
--- /dev/null
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Alternate application launcher for Xfce"
+HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin"
+SRC_URI="https://github.com/gottcode/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/gtk+:2=
+ xfce-base/exo:=
+ xfce-base/garcon:=
+ xfce-base/libxfce4ui:=
+ xfce-base/libxfce4util:=
+ xfce-base/xfce4-panel:=
+ virtual/libintl:="
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ local i
+ cd po || die
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in *.po ; do
+ einfo "removing ${i%.po} linguas"
+ has ${i%.po} ${LINGUAS} || { rm ${i} || die ; }
+ done
+ fi
+
+ eapply_user
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_AS_NEEDED=OFF
+ -DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
+ -DENABLE_DEVELOPER_MODE=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc NEWS README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}