summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-06-24 10:56:08 +0530
committerSam James <sam@gentoo.org>2023-06-24 06:28:06 +0100
commite6517eb54f88c2cb030ecd59d430670970a465a9 (patch)
treeef7eab060b92ebb0a1bb3c55dc5a62a21d855273
parentapp-text/dictd: fix EAPI 8 port (diff)
downloadgentoo-e6517eb54f88c2cb030ecd59d430670970a465a9.tar.gz
gentoo-e6517eb54f88c2cb030ecd59d430670970a465a9.tar.bz2
gentoo-e6517eb54f88c2cb030ecd59d430670970a465a9.zip
media-libs/gexiv2: Fix no template named 'auto_ptr' w/ llvm profile
[sam: gexiv2-0.14.1 switches to C++17 but exiv-0.27* doesn't support it yet, and exiv-0.28* is masked. Do a workaround for now.] Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31587 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/gexiv2/files/0.14.1-revert-default-cpp_stdto17.patch18
-rw-r--r--media-libs/gexiv2/gexiv2-0.14.1.ebuild7
2 files changed, 24 insertions, 1 deletions
diff --git a/media-libs/gexiv2/files/0.14.1-revert-default-cpp_stdto17.patch b/media-libs/gexiv2/files/0.14.1-revert-default-cpp_stdto17.patch
new file mode 100644
index 000000000000..9697e4455ba0
--- /dev/null
+++ b/media-libs/gexiv2/files/0.14.1-revert-default-cpp_stdto17.patch
@@ -0,0 +1,18 @@
+With clang 16 and libcxx this is causig build error such as:
+/usr/include/exiv2/value.hpp:54:17: error: no template named 'auto_ptr' in namespace 'std'; did you mean simply 'auto_ptr'?
+ typedef std::auto_ptr<Value> AutoPtr;
+Reverting upstream commit https://gitlab.gnome.org/GNOME/gexiv2/-/commit/2eb5c2c9ac1d36bee7089117e1f4825162a9409d
+helps solve them for now.
+
+There is on going work for exiv2-0.28
+--- a/meson.build
++++ b/meson.build
+@@ -5,7 +5,7 @@ project(
+ license: 'GPL-2.0-or-later',
+ meson_version : '>=0.51',
+ default_options : [
+- 'cpp_std=c++17'
++ 'cpp_std=c++11'
+ ]
+ )
+
diff --git a/media-libs/gexiv2/gexiv2-0.14.1.ebuild b/media-libs/gexiv2/gexiv2-0.14.1.ebuild
index 86688f8cdbd0..b9f339964fc9 100644
--- a/media-libs/gexiv2/gexiv2-0.14.1.ebuild
+++ b/media-libs/gexiv2/gexiv2-0.14.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit gnome.org meson python-r1 vala
@@ -47,6 +47,11 @@ BDEPEND="
virtual/pkgconfig
vala? ( $(vala_depend) )
"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-revert-default-cpp_stdto17.patch"
+)
+
src_prepare() {
default
use vala && vala_setup