summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 13:11:15 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-31 01:23:55 +0100
commite84579b092eddc1815cbd92ab0dc769557d3d383 (patch)
treea97b54d6612f74ec601751a821fddff591dd0996
parentdev-python/ipython: Run a single Xvfb (diff)
downloadgentoo-e84579b092eddc1815cbd92ab0dc769557d3d383.tar.gz
gentoo-e84579b092eddc1815cbd92ab0dc769557d3d383.tar.bz2
gentoo-e84579b092eddc1815cbd92ab0dc769557d3d383.zip
dev-python/pillow: Run a single Xvfb
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pillow/pillow-9.0.0-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pillow/pillow-9.0.0-r1.ebuild b/dev-python/pillow/pillow-9.0.0-r1.ebuild
index a1ac66234130..82a914de8bf7 100644
--- a/dev-python/pillow/pillow-9.0.0-r1.ebuild
+++ b/dev-python/pillow/pillow-9.0.0-r1.ebuild
@@ -82,10 +82,14 @@ python_configure_all() {
tc-export PKG_CONFIG
}
+src_test() {
+ virtx distutils-r1_src_test
+}
+
python_test() {
"${EPYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
# no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
- virtx epytest -p no:relaxed
+ epytest -p no:relaxed || die "Tests failed with ${EPYTHON}"
}
python_install() {