summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 04:33:59 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 04:33:59 +0000
commitec6b3640a5b20f697cb392c6e5c0c777eb2d2e1d (patch)
treecf2e50f6f3f0c472775a6c7f93c177f29237f3c6
parent2024-07-15 03:49:07 UTC (diff)
parentapp-emulation/cloud-init: Stabilize 23.4 x86, #932918 (diff)
downloadgentoo-ec6b3640a5b20f697cb392c6e5c0c777eb2d2e1d.tar.gz
gentoo-ec6b3640a5b20f697cb392c6e5c0c777eb2d2e1d.tar.bz2
gentoo-ec6b3640a5b20f697cb392c6e5c0c777eb2d2e1d.zip
Merge updates from master
-rw-r--r--app-emulation/cloud-init/Manifest1
-rw-r--r--app-emulation/cloud-init/cloud-init-23.4.ebuild2
-rw-r--r--app-emulation/cloud-init/cloud-init-24.2.ebuild101
-rw-r--r--app-emulation/cloud-init/cloud-init-9999.ebuild8
-rw-r--r--dev-db/mongodb/files/mongodb-4.4.29-boost-1.85.patch146
-rw-r--r--dev-db/mongodb/mongodb-4.4.29.ebuild1
-rw-r--r--dev-python/click-option-group/click-option-group-0.5.6.ebuild2
-rw-r--r--dev-python/pysubs2/pysubs2-1.7.2.ebuild2
-rw-r--r--dev-python/srt/srt-3.5.3.ebuild2
-rw-r--r--media-video/subliminal/subliminal-2.2.1.ebuild2
10 files changed, 261 insertions, 6 deletions
diff --git a/app-emulation/cloud-init/Manifest b/app-emulation/cloud-init/Manifest
index a1fdc85deb9c..e09f96458f80 100644
--- a/app-emulation/cloud-init/Manifest
+++ b/app-emulation/cloud-init/Manifest
@@ -1,3 +1,4 @@
DIST cloud-init-22.2.2.tar.gz 1349451 BLAKE2B fdb6669e9762984614fefe787834f20f056345d304327679fa8bc7b4d6566509a23ecc4a7ac4e6368b9b9078a72fe6fe35533a67e7aeb0c0accbf5ad014f8aae SHA512 18b75ebbb5e808e19df5ceddb6402cc881c33443fb169f736f54837254ba43836994f2392a26febbd8df3342b3467ee72759b6942cfeb96d07c0e452c11dd0bf
DIST cloud-init-22.4.tar.gz 1494295 BLAKE2B 5f961c895c0d6c78a7cee47d2b52acd57d959baeb5172cea89d75ffe23424e3a8a3170a0ecdcad729c6cb0c898477ea94c43a5f8bdf200fc3f122c32fdb2e96d SHA512 6151d1d5e4be241219cb5804ca2bad2dd790f366bc847d286a8840faad1fb4adf5d780c9418ce574c2cfcefc16851a49961f33c5da1fbc84bb8299cf138bfcfc
DIST cloud-init-23.4.tar.gz 1648908 BLAKE2B 0acec9c437c7a5a86ed9cd8718830a7311c257ae9f223a68959b8d1eccc693b35f6a716de5c04112d848c1e2e54f6461a3919fd733debba18989145f6669d359 SHA512 34966b173571764bf83779bef0e89a86971310ff0fa62feceef4fbe17c9fa6d1b69f11f57caaa32cc4ae4a74f598f157dfb3ce356221044666401230cfb1ad13
+DIST cloud-init-24.2.tar.gz 1786275 BLAKE2B 21f5209a77ef401d12271f6ea695d84065b22f40b7273dd8709dee5fadc7038a0f59a9a3dd53b73812a44a603b5cdc7fb36b71fcdb1f2d4295d87d2cc6069fcd SHA512 72de351b3e978e01a4695b58987d942cc1b2faee749ac0df2024a839e0e1539c9b1f0a9e5cf1930e33c36344d152b7580cfe2dd55f95ad4f669df9b4dda4648d
diff --git a/app-emulation/cloud-init/cloud-init-23.4.ebuild b/app-emulation/cloud-init/cloud-init-23.4.ebuild
index d9af1ace0ad9..2e3478cac607 100644
--- a/app-emulation/cloud-init/cloud-init-23.4.ebuild
+++ b/app-emulation/cloud-init/cloud-init-23.4.ebuild
@@ -15,7 +15,7 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://git.launchpad.net/cloud-init"
else
SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 ~ppc64 ~x86"
+ KEYWORDS="amd64 arm64 ppc64 x86"
fi
DESCRIPTION="Cloud instance initialisation magic"
diff --git a/app-emulation/cloud-init/cloud-init-24.2.ebuild b/app-emulation/cloud-init/cloud-init-24.2.ebuild
new file mode 100644
index 000000000000..a5af2bf3bfc1
--- /dev/null
+++ b/app-emulation/cloud-init/cloud-init-24.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Disabled for now: bug #850628
+#DISTUTILS_USE_PEP517=setuptools
+# https://bugs.launchpad.net/cloud-init/+bug/1978328
+PYTHON_COMPAT=( python3_10 python3_11 python3_12 )
+
+inherit distutils-r1 udev
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.launchpad.net/cloud-init"
+else
+ SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Cloud instance initialisation magic"
+HOMEPAGE="https://launchpad.net/cloud-init"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="selinux"
+
+CDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.2[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/netifaces[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${CDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ net-analyzer/macchanger
+ sys-apps/iproute2
+ sys-fs/growpart
+ virtual/logger
+ selinux? ( sec-policy/selinux-cloudinit )
+"
+
+EPYTEST_IGNORE=(
+ # Can't find file
+ tests/unittests/config/test_apt_configure_sources_list_v1.py
+ tests/unittests/config/test_apt_configure_sources_list_v3.py
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Fix location of documentation installation
+ sed -i "s:USR + '/share/doc/cloud-init:USR + '/share/doc/${PF}:" setup.py || die
+
+ if [[ ${PV} == *9999 ]] ; then
+ sed -i 's/version=get_version(),/version=9999,/g' setup.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install --init-system=sysvinit_openrc,systemd --distro gentoo
+}
+
+python_install_all() {
+ keepdir /etc/cloud
+
+ distutils-r1_python_install_all
+
+ # installs as non-executable
+ chmod +x "${D}"/etc/init.d/* || die
+}
+
+pkg_prerm() {
+ udev_reload
+}
+
+pkg_postinst() {
+ udev_reload
+
+ elog "cloud-init-local needs to be run in the boot runlevel because it"
+ elog "modifies services in the default runlevel. When a runlevel is started"
+ elog "it is cached, so modifications that happen to the current runlevel"
+ elog "while you are in it are not acted upon."
+}
diff --git a/app-emulation/cloud-init/cloud-init-9999.ebuild b/app-emulation/cloud-init/cloud-init-9999.ebuild
index 7bb69ee6336a..a5af2bf3bfc1 100644
--- a/app-emulation/cloud-init/cloud-init-9999.ebuild
+++ b/app-emulation/cloud-init/cloud-init-9999.ebuild
@@ -15,7 +15,7 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://git.launchpad.net/cloud-init"
else
SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi
DESCRIPTION="Cloud instance initialisation magic"
@@ -55,6 +55,12 @@ RDEPEND="
selinux? ( sec-policy/selinux-cloudinit )
"
+EPYTEST_IGNORE=(
+ # Can't find file
+ tests/unittests/config/test_apt_configure_sources_list_v1.py
+ tests/unittests/config/test_apt_configure_sources_list_v3.py
+)
+
distutils_enable_tests pytest
python_prepare_all() {
diff --git a/dev-db/mongodb/files/mongodb-4.4.29-boost-1.85.patch b/dev-db/mongodb/files/mongodb-4.4.29-boost-1.85.patch
new file mode 100644
index 000000000000..92831264b4e3
--- /dev/null
+++ b/dev-db/mongodb/files/mongodb-4.4.29-boost-1.85.patch
@@ -0,0 +1,146 @@
+https://bugs.gentoo.org/932251#c7
+--- a/src/mongo/db/initialize_server_global_state.cpp 2024-02-13 00:46:45.000000000 -0800
++++ b/src/mongo/db/initialize_server_global_state.cpp 2024-06-05 01:07:27.035053336 -0700
+@@ -34,7 +34,7 @@
+ #include "mongo/db/initialize_server_global_state.h"
+ #include "mongo/db/initialize_server_global_state_gen.h"
+
+-#include <boost/filesystem/operations.hpp>
++#include <boost/filesystem.hpp>
+ #include <fmt/format.h>
+ #include <iostream>
+ #include <memory>
+@@ -346,7 +346,7 @@
+ << "\" should name a file, not a directory.");
+ }
+
+- if (!serverGlobalParams.logAppend && boost::filesystem::is_regular(absoluteLogpath)) {
++ if (!serverGlobalParams.logAppend && boost::filesystem::is_regular_file(absoluteLogpath)) {
+ std::string renameTarget = absoluteLogpath + "." + terseCurrentTime(false);
+ boost::system::error_code ec;
+ boost::filesystem::rename(absoluteLogpath, renameTarget, ec);
+
+
+--- a/src/mongo/db/startup_warnings_mongod.cpp 2024-02-13 00:46:45.000000000 -0800
++++ b/src/mongo/db/startup_warnings_mongod.cpp 2024-06-05 01:09:36.740158960 -0700
+@@ -34,6 +34,7 @@
+ #include "mongo/db/startup_warnings_mongod.h"
+
+ #include <boost/filesystem/operations.hpp>
++#include <boost/filesystem/exception.hpp>
+ #include <fstream>
+ #ifndef _WIN32
+ #include <sys/resource.h>
+
+
+--- a/src/mongo/db/storage/storage_engine_lock_file_posix.cpp 2024-06-05 00:46:38.374648451 -0700
++++ b/src/mongo/db/storage/storage_engine_lock_file_posix.cpp 2024-06-05 00:47:33.178731500 -0700
+@@ -55,7 +55,7 @@
+ // if called without a fully qualified path it asserts; that makes mongoperf fail.
+ // so make a warning. need a better solution longer term.
+ // massert(40389, str::stream() << "Couldn't find parent dir for file: " << file.string(),);
+- if (!file.has_branch_path()) {
++ if (!file.has_parent_path()) {
+ LOGV2(22274,
+ "warning flushMyDirectory couldn't find parent dir for file: {file}",
+ "flushMyDirectory couldn't find parent dir for file",
+@@ -64,7 +64,7 @@
+ }
+
+
+- boost::filesystem::path dir = file.branch_path(); // parent_path in new boosts
++ boost::filesystem::path dir = file.parent_path(); // parent_path in new boosts
+
+ LOGV2_DEBUG(22275, 1, "flushing directory {dir_string}", "dir_string"_attr = dir.string());
+
+
+--- a/src/mongo/db/storage/storage_engine_metadata.cpp 2024-02-13 00:46:45.000000000 -0800
++++ b/src/mongo/db/storage/storage_engine_metadata.cpp 2024-06-05 01:26:46.904273382 -0700
+@@ -220,7 +220,7 @@
+ // if called without a fully qualified path it asserts; that makes mongoperf fail.
+ // so make a warning. need a better solution longer term.
+ // massert(13652, str::stream() << "Couldn't find parent dir for file: " << file.string(),);
+- if (!file.has_branch_path()) {
++ if (!file.has_parent_path()) {
+ LOGV2(22283,
+ "warning flushMyDirectory couldn't find parent dir for file: {file}",
+ "flushMyDirectory couldn't find parent dir for file",
+@@ -229,7 +229,7 @@
+ }
+
+
+- boost::filesystem::path dir = file.branch_path(); // parent_path in new boosts
++ boost::filesystem::path dir = file.parent_path(); // parent_path in new boosts
+
+ LOGV2_DEBUG(22284, 1, "flushing directory {dir_string}", "dir_string"_attr = dir.string());
+
+
+--- a/src/mongo/shell/shell_utils_launcher.cpp 2024-02-13 00:46:45.000000000 -0800
++++ b/src/mongo/shell/shell_utils_launcher.cpp 2024-06-05 01:29:45.140048809 -0700
+@@ -39,6 +39,7 @@
+ #include <boost/iostreams/stream.hpp>
+ #include <boost/iostreams/stream_buffer.hpp>
+ #include <boost/iostreams/tee.hpp>
++#include <boost/filesystem.hpp>
+ #include <cctype>
+ #include <fcntl.h>
+ #include <fmt/format.h>
+@@ -907,26 +908,26 @@
+ boost::filesystem::directory_iterator i(from);
+ while (i != end) {
+ boost::filesystem::path p = *i;
+- if (p.leaf() == "metrics.interim" || p.leaf() == "metrics.interim.temp") {
++ if (p.filename() == "metrics.interim" || p.filename() == "metrics.interim.temp") {
+ // Ignore any errors for metrics.interim* files as these may disappear during copy
+ boost::system::error_code ec;
+- boost::filesystem::copy_file(p, to / p.leaf(), ec);
++ boost::filesystem::copy_file(p, to / p.filename(), ec);
+ if (ec) {
+ LOGV2_INFO(22814,
+ "Skipping copying of file from '{from}' to "
+ "'{to}' due to: {error}",
+ "Skipping copying of file due to error"
+ "from"_attr = p.generic_string(),
+- "to"_attr = (to / p.leaf()).generic_string(),
++ "to"_attr = (to / p.filename()).generic_string(),
+ "error"_attr = ec.message());
+ }
+- } else if (p.leaf() != "mongod.lock" && p.leaf() != "WiredTiger.lock") {
++ } else if (p.filename() != "mongod.lock" && p.filename() != "WiredTiger.lock") {
+ if (boost::filesystem::is_directory(p)) {
+- boost::filesystem::path newDir = to / p.leaf();
++ boost::filesystem::path newDir = to / p.filename();
+ boost::filesystem::create_directory(newDir);
+ copyDir(p, newDir);
+ } else {
+- boost::filesystem::copy_file(p, to / p.leaf());
++ boost::filesystem::copy_file(p, to / p.filename());
+ }
+ }
+ ++i;
+
+
+--- a/src/mongo/scripting/engine.cpp 2024-02-13 00:46:45.000000000 -0800
++++ b/src/mongo/scripting/engine.cpp 2024-06-05 00:59:57.488909335 -0700
+@@ -34,6 +34,7 @@
+ #include "mongo/scripting/engine.h"
+
+ #include <boost/filesystem/operations.hpp>
++#include <boost/filesystem/directory.hpp>
+ #include <cctype>
+
+ #include "mongo/client/dbclient_base.h"
+
+
+--- a/src/mongo/shell/shell_utils_launcher.h 2024-02-13 00:46:45.000000000 -0800
++++ b/src/mongo/shell/shell_utils_launcher.h 2024-06-05 01:04:44.286162623 -0700
+@@ -29,7 +29,7 @@
+
+ #pragma once
+
+-#include <boost/filesystem/convenience.hpp>
++#include <boost/filesystem/path.hpp>
+ #include <map>
+ #include <sstream>
+ #include <string>
+
diff --git a/dev-db/mongodb/mongodb-4.4.29.ebuild b/dev-db/mongodb/mongodb-4.4.29.ebuild
index 830acd956f53..7c004e0b2b0a 100644
--- a/dev-db/mongodb/mongodb-4.4.29.ebuild
+++ b/dev-db/mongodb/mongodb-4.4.29.ebuild
@@ -64,6 +64,7 @@ PATCHES=(
"${FILESDIR}/${PN}-4.4.10-no-force-lld.patch"
"${FILESDIR}/${PN}-4.4.10-boost-1.81.patch"
"${FILESDIR}/${P}-no-enterprise.patch"
+ "${FILESDIR}/${PN}-4.4.29-boost-1.85.patch"
)
python_check_deps() {
diff --git a/dev-python/click-option-group/click-option-group-0.5.6.ebuild b/dev-python/click-option-group/click-option-group-0.5.6.ebuild
index 1eb381f327d5..1515b7410ac7 100644
--- a/dev-python/click-option-group/click-option-group-0.5.6.ebuild
+++ b/dev-python/click-option-group/click-option-group-0.5.6.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~arm64"
RDEPEND="
dev-python/click[${PYTHON_USEDEP}]
diff --git a/dev-python/pysubs2/pysubs2-1.7.2.ebuild b/dev-python/pysubs2/pysubs2-1.7.2.ebuild
index c279af4fd394..7df395ca468c 100644
--- a/dev-python/pysubs2/pysubs2-1.7.2.ebuild
+++ b/dev-python/pysubs2/pysubs2-1.7.2.ebuild
@@ -16,6 +16,6 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~arm64"
distutils_enable_tests pytest
diff --git a/dev-python/srt/srt-3.5.3.ebuild b/dev-python/srt/srt-3.5.3.ebuild
index 564075540e07..4e91e103862c 100644
--- a/dev-python/srt/srt-3.5.3.ebuild
+++ b/dev-python/srt/srt-3.5.3.ebuild
@@ -16,7 +16,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~arm64"
RDEPEND="!dev-python/pysrt"
BDEPEND="
diff --git a/media-video/subliminal/subliminal-2.2.1.ebuild b/media-video/subliminal/subliminal-2.2.1.ebuild
index 1aa8338f1813..4a01589227ac 100644
--- a/media-video/subliminal/subliminal-2.2.1.ebuild
+++ b/media-video/subliminal/subliminal-2.2.1.ebuild
@@ -18,7 +18,7 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_BRANCH="develop"
else
SRC_URI="https://github.com/Diaoul/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm64"
fi
SRC_URI+=" test? ( https://downloads.sourceforge.net/matroska/test_files/matroska_test_w1_1.zip )"