summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-09-08 23:58:52 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-09 00:04:43 +0200
commited670c23c665f341bdd8bfd39f7c13a71ee59a81 (patch)
treefbc17635c2a931d780e32a24c7a6d32b6641f59b
parentmedia-libs/libde265: update live ebuild (diff)
downloadgentoo-ed670c23c665f341bdd8bfd39f7c13a71ee59a81.tar.gz
gentoo-ed670c23c665f341bdd8bfd39f7c13a71ee59a81.tar.bz2
gentoo-ed670c23c665f341bdd8bfd39f7c13a71ee59a81.zip
media-libs/libde265: bump to v1.0.3
Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--media-libs/libde265/Manifest1
-rw-r--r--media-libs/libde265/files/libde265-1.0.3-use-new-FFMPEG-enum-names.patch24
-rw-r--r--media-libs/libde265/libde265-1.0.3.ebuild67
3 files changed, 92 insertions, 0 deletions
diff --git a/media-libs/libde265/Manifest b/media-libs/libde265/Manifest
index 1c531c911976..7b7d128f6e52 100644
--- a/media-libs/libde265/Manifest
+++ b/media-libs/libde265/Manifest
@@ -1 +1,2 @@
DIST libde265-1.0.2.tar.gz 381737 BLAKE2B cea70a46193e4cb4a0beb1d0a86af17df13e70602c16c509b85acb918c0ddbdfa3e60bfa2b83922200fd9b1465c18edf20fe0939d7f78f3865a9d54b144de90b SHA512 714ce93f204bd034e3cccd9624d32ea6fcb31be25dbfd1a85f91814b33a01cc1515a3887a1ccabb9f0986686ecbcdd984b88e605190ff33d2bd75cc3b9f4bdd3
+DIST libde265-1.0.3.tar.gz 399996 BLAKE2B 988b21085f82d3b33b0480542677be96db5219c1b767aae3674f89862fdaf3355dcfea3fa99699798a4fcc6b72a63a3a6f61a3fd8d2ea8483231205cd6d87175 SHA512 0153632afcc9733950e8354997ccd93eddad90e8e0f7362bfe49b93b11cb1756cf803d0ba5c07042aee80e18227613af768ca82baf7891c687edf5e253a129c4
diff --git a/media-libs/libde265/files/libde265-1.0.3-use-new-FFMPEG-enum-names.patch b/media-libs/libde265/files/libde265-1.0.3-use-new-FFMPEG-enum-names.patch
new file mode 100644
index 000000000000..33e73c15a93f
--- /dev/null
+++ b/media-libs/libde265/files/libde265-1.0.3-use-new-FFMPEG-enum-names.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/575554
+
+From e5b8e2e703d608777afadc54955bd396e4211da0 Mon Sep 17 00:00:00 2001
+From: Dirk Farin <farin@struktur.de>
+Date: Thu, 19 Apr 2018 13:15:18 +0200
+Subject: [PATCH] use new FFMPEG enum names
+
+---
+ sherlock265/VideoDecoder.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/sherlock265/VideoDecoder.cc b/sherlock265/VideoDecoder.cc
+index 119f6152..b829e1c7 100644
+--- a/sherlock265/VideoDecoder.cc
++++ b/sherlock265/VideoDecoder.cc
+@@ -237,7 +237,7 @@ void VideoDecoder::convert_frame_swscale(const de265_image* img, QImage & qimg)
+ }
+ width = img->get_width();
+ height = img->get_height();
+- sws = sws_getContext(width, height, PIX_FMT_YUV420P, width, height, PIX_FMT_BGRA, SWS_FAST_BILINEAR, NULL, NULL, NULL);
++ sws = sws_getContext(width, height, AV_PIX_FMT_YUV420P, width, height, AV_PIX_FMT_BGRA, SWS_FAST_BILINEAR, NULL, NULL, NULL);
+ }
+
+ int stride[3];
diff --git a/media-libs/libde265/libde265-1.0.3.ebuild b/media-libs/libde265/libde265-1.0.3.ebuild
new file mode 100644
index 000000000000..c9de64e6a520
--- /dev/null
+++ b/media-libs/libde265/libde265-1.0.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools multilib-minimal
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.2-qtbindir.patch" )
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strukturag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+
+ PATCHES+=( "${FILESDIR}"/${P}-use-new-FFMPEG-enum-names.patch )
+fi
+
+DESCRIPTION="Open h.265 video codec implementation"
+HOMEPAGE="https://github.com/strukturag/libde265"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug qt5 static-libs cpu_flags_x86_sse"
+
+DEPEND="
+ media-libs/libsdl
+ virtual/ffmpeg
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ # without this, headers would be missing and make would fail
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable static-libs static)
+ $(use_enable debug log-info)
+ $(use_enable debug log-debug)
+ $(use_enable debug log-trace)
+ $(use_enable qt5 dec265)
+ $(use_enable qt5 sherlock265)
+ --enable-log-error
+ )
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}