summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-03-20 20:57:38 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-03-20 20:57:38 -0400
commited8cd974515c3fe41f4a4ad46f6edbef60d034e2 (patch)
treea07abb3e929a78cff4af31c7b4638f4648a8ba74
parentmedia-gfx/graphite2: Remove old (diff)
downloadgentoo-ed8cd974515c3fe41f4a4ad46f6edbef60d034e2.tar.gz
gentoo-ed8cd974515c3fe41f4a4ad46f6edbef60d034e2.tar.bz2
gentoo-ed8cd974515c3fe41f4a4ad46f6edbef60d034e2.zip
dev-lang/php: revision the 7.0 series to add pdo-dblib support.
The PDO "dblib" driver was somehow lost during the transition from php:5.6 to php:7.0. I've added it back, and tested that it works with a simple query against a Microsoft SQL Server 2005 database. Gentoo-Bug: 576782 Package-Manager: portage-2.2.26
-rw-r--r--dev-lang/php/php-7.0.4-r1.ebuild (renamed from dev-lang/php/php-7.0.4.ebuild)4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-lang/php/php-7.0.4.ebuild b/dev-lang/php/php-7.0.4-r1.ebuild
index 6092aca32564..92b65071532e 100644
--- a/dev-lang/php/php-7.0.4.ebuild
+++ b/dev-lang/php/php-7.0.4-r1.ebuild
@@ -68,7 +68,7 @@ IUSE="${IUSE} bcmath berkdb bzip2 calendar cdb cjk
enchant exif frontbase +fileinfo +filter firebird
flatfile ftp gd gdbm gmp +hash +iconv imap inifile
intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit libressl
- mhash mysql mysqli nls
+ mhash mssql mysql mysqli nls
oci8-instant-client odbc +opcache pcntl pdo +phar +posix postgres qdbm
readline recode selinux +session sharedmem
+simplexml snmp soap sockets spell sqlite ssl
@@ -118,6 +118,7 @@ DEPEND="${DEPEND}
ldap? ( >=net-nds/openldap-1.2.11 )
ldap-sasl? ( dev-libs/cyrus-sasl >=net-nds/openldap-1.2.11 )
libedit? ( || ( sys-freebsd/freebsd-lib dev-libs/libedit ) )
+ mssql? ( dev-db/freetds[mssql] )
nls? ( sys-devel/gettext )
oci8-instant-client? ( dev-db/oracle-instantclient-basic )
odbc? ( >=dev-db/unixODBC-1.8.13 )
@@ -468,6 +469,7 @@ src_configure() {
# PDO support
if use pdo ; then
our_conf+=(
+ $(use_with mssql pdo-dblib "${EPREFIX}/usr")
$(use_with mysql pdo-mysql "${mysqllib}")
$(use_with postgres pdo-pgsql)
$(use_with sqlite pdo-sqlite "${EPREFIX}/usr")