summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-03-22 20:05:48 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-03-22 20:05:48 +0000
commitf2620495c9a697ddb55a1986f42c0d25333c5ea6 (patch)
treeb103a8b28b2cc5707d3f89f4f26aa93006e9b9e6
parent2021-03-22 19:50:55 UTC (diff)
parentdev-libs/libassuan: Bump to version 2.5.5 (diff)
downloadgentoo-f2620495c9a697ddb55a1986f42c0d25333c5ea6.tar.gz
gentoo-f2620495c9a697ddb55a1986f42c0d25333c5ea6.tar.bz2
gentoo-f2620495c9a697ddb55a1986f42c0d25333c5ea6.zip
Merge updates from master
-rw-r--r--dev-libs/libassuan/Manifest1
-rw-r--r--dev-libs/libassuan/libassuan-2.5.5.ebuild47
-rw-r--r--dev-python/brotlicffi/Manifest1
-rw-r--r--dev-python/brotlicffi/brotlicffi-0.8.0.ebuild54
-rw-r--r--dev-python/brotlicffi/files/brotlicffi-0.8.0-remove-dict.patch132
-rw-r--r--profiles/package.mask5
-rw-r--r--sci-mathematics/singular/Manifest1
-rw-r--r--sci-mathematics/singular/files/singular-4.0.3-gfan_linking.patch13
-rw-r--r--sci-mathematics/singular/files/singular-4.1.3-doc_install.patch62
-rw-r--r--sci-mathematics/singular/files/singular-4.2.0-no-static.patch69
-rw-r--r--sci-mathematics/singular/singular-4.2.0_p1.ebuild104
-rw-r--r--sys-fs/reiser4progs/Manifest2
-rw-r--r--sys-fs/reiser4progs/reiser4progs-2.0.5.ebuild (renamed from sys-fs/reiser4progs/reiser4progs-2.0.3.ebuild)2
-rw-r--r--x11-misc/py3status/Manifest2
-rw-r--r--x11-misc/py3status/py3status-3.35.ebuild (renamed from x11-misc/py3status/py3status-3.34.ebuild)0
15 files changed, 302 insertions, 193 deletions
diff --git a/dev-libs/libassuan/Manifest b/dev-libs/libassuan/Manifest
index 53f72ed36e11..29c8687e0d4e 100644
--- a/dev-libs/libassuan/Manifest
+++ b/dev-libs/libassuan/Manifest
@@ -1,2 +1,3 @@
DIST libassuan-2.5.3.tar.bz2 572348 BLAKE2B ae3a5a9a03e85d62cf87271cd4a0718a2b89a4f90ea814837913e4b2bb6e5af9746e766d99685cc0cc3a801efaee597e491a2bc03d42ac26059580ea4680fd7a SHA512 e7ccb651ea75b07b2e687d48d86d0ab83cba8e2af7f30da2aec794808e13e6ec93f21d607db50d3431f1c23cb3a07a2793b71170e69fa2f5a82cffb81961f617
DIST libassuan-2.5.4.tar.bz2 574039 BLAKE2B 2eec42c47840741a4726fc35c3ed04300e5fbcd37f808b121534aeaa04d0d0f609a30ad48cfbe33a81ee4b2ebbb822b9a48a5c602268f1b802bf5d7d19d72e9c SHA512 764993d5311c24f0c0f970016e903e1a16783a2050c42072dbc1bc4f350f119e53b0be17ed6df25a0086bc9f8c25ee4f3134330577968480997263f95e05594f
+DIST libassuan-2.5.5.tar.bz2 572263 BLAKE2B 24952e97c757b97c387ab4c2c4bf7b040f2874e9326c129805c7f5326fa14d80e083b0842e336a635531a2c8d4a66d428c816bae6b175f1c4518add1ffa3554d SHA512 70117f77aa43bbbe0ed28da5ef23834c026780a74076a92ec775e30f851badb423e9a2cb9e8d142c94e4f6f8a794988c1b788fd4bd2271e562071adf0ab16403
diff --git a/dev-libs/libassuan/libassuan-2.5.5.ebuild b/dev-libs/libassuan/libassuan-2.5.5.ebuild
new file mode 100644
index 000000000000..f47712edfd6f
--- /dev/null
+++ b/dev-libs/libassuan/libassuan-2.5.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit libtool
+
+DESCRIPTION="IPC library used by GnuPG and GPGME"
+HOMEPAGE="https://www.gnupg.org/related_software/libassuan/index.en.html"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND=">=dev-libs/libgpg-error-1.17"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ elibtoolize
+
+ # fix standards conflict
+ sed -i \
+ -e '/_XOPEN_SOURCE/s/500/600/' \
+ -e 's/_XOPEN_SOURCE_EXTENDED/_NO&/' \
+ -e 's/__EXTENSIONS__/_NO&/' \
+ configure || die
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ GPG_ERROR_CONFIG="${EROOT}/usr/bin/${CHOST}-gpg-error-config"
+ $("${S}/configure" --help | grep -o -- '--without-.*-prefix')
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # ppl need to use libassuan-config for --cflags and --libs
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/dev-python/brotlicffi/Manifest b/dev-python/brotlicffi/Manifest
index 58c38dd88d8b..7f031b2bfc61 100644
--- a/dev-python/brotlicffi/Manifest
+++ b/dev-python/brotlicffi/Manifest
@@ -1,3 +1,2 @@
DIST brotli-46c1a881b41bb638c76247558aa04b1591af3aa7.tar.gz 19840371 BLAKE2B b9a1c3c2e5b62bd63b392debe54bd1732ac1cb31f88500f0142108b453649d96901d9a03b6db98642cb9abaf9188c06d440f2b8bd3cf57fbbb52196a931f5079 SHA512 dc573c90491032a205f32f0ce9c93e95b06c70a3107caa9501e038a212226c37117d63709a29843367344bf7d18cf32d0c0578b11166387198e12b38b1522406
-DIST brotlicffi-0.8.0.gh.tar.gz 21997 BLAKE2B 5e817e228ce01cd7a831c59cca5bab3e851d676f1daa5efab8f61a203c0854bcc92605c88896dff5f4ce27fc880718da5ddfcf02a3bddbbd7b2e18c33f1e77a4 SHA512 fd0c64b400d3b48e0e2d113b4d75e32a2b33fd99505c7661d6d51ba9aedf5cc1f58be09bc90a5f1f7e3424addef2b54cc085a41e6291c87d53dd7d4e8fc7eb4e
DIST brotlicffi-1.0.9.1.gh.tar.gz 22589 BLAKE2B 14ebb3f6168d334abe3ba72bd88697ee98aba87ace6aaf634395ef50ecd9325723f0da0a9ce56a5e4dcfebfe3183a190e2ec183eff95492b25e3542161b32322 SHA512 669c73ed6dd18be6b916bb8cfb240657dcc10d67df5a32b3359f05cadf75aa654c27b53e8b964251f6d6cd74870e159efddf87ef0cfb59b7777eacd3cda66852
diff --git a/dev-python/brotlicffi/brotlicffi-0.8.0.ebuild b/dev-python/brotlicffi/brotlicffi-0.8.0.ebuild
deleted file mode 100644
index 2afad43d1940..000000000000
--- a/dev-python/brotlicffi/brotlicffi-0.8.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
-inherit distutils-r1
-
-# Commit of the Brotli library bundled within brotlipy.
-BROTLI_BUNDLED_COMMIT="46c1a881b41bb638c76247558aa04b1591af3aa7"
-
-DESCRIPTION="Python binding to the Brotli library"
-HOMEPAGE="
- https://github.com/python-hyper/brotlicffi/
- https://pypi.org/project/brotlicffi/"
-SRC_URI="
- https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
- test? (
- https://github.com/google/brotli/archive/${BROTLI_BUNDLED_COMMIT}.tar.gz
- -> brotli-${BROTLI_BUNDLED_COMMIT}.tar.gz
- )"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- app-arch/brotli:=
- virtual/python-cffi[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # remove custom dictionary code that isn't supported by new brotli
- "${FILESDIR}"/brotlicffi-0.8.0-remove-dict.patch
-)
-
-src_unpack() {
- default
- if use test; then
- mv "brotli-${BROTLI_BUNDLED_COMMIT}"/tests "${S}"/libbrotli/ || die
- fi
-}
-
-src_configure() {
- export USE_SHARED_BROTLI=1
-}
diff --git a/dev-python/brotlicffi/files/brotlicffi-0.8.0-remove-dict.patch b/dev-python/brotlicffi/files/brotlicffi-0.8.0-remove-dict.patch
deleted file mode 100644
index bfb1b61b951b..000000000000
--- a/dev-python/brotlicffi/files/brotlicffi-0.8.0-remove-dict.patch
+++ /dev/null
@@ -1,132 +0,0 @@
-From 0fe3dc70240ea62b56861ab830f9ab44644b18e5 Mon Sep 17 00:00:00 2001
-From: Seth Michael Larson <sethmichaellarson@gmail.com>
-Date: Sat, 28 Nov 2020 14:36:59 -0600
-Subject: [PATCH] Update libbrotli to 1.0.9
-
-(stripped down to removing custom dictionary support)
-
----
- src/brotlicffi/_api.py | 21 ++----------
- src/brotlicffi/_build.py | 25 +-------------
- test/test_simple_compression.py | 8 -----
-
-diff --git a/src/brotlicffi/_api.py b/src/brotlicffi/_api.py
-index 49da0a3..8358d3f 100644
---- a/src/brotlicffi/_api.py
-+++ b/src/brotlicffi/_api.py
-@@ -95,8 +95,7 @@ def compress(data,
- mode=DEFAULT_MODE,
- quality=lib.BROTLI_DEFAULT_QUALITY,
- lgwin=lib.BROTLI_DEFAULT_WINDOW,
-- lgblock=0,
-- dictionary=b''):
-+ lgblock=0):
- """
- Compress a string using Brotli.
-
-@@ -124,11 +123,6 @@ def compress(data,
- based on ``quality``.
- :type lgblock: ``int``
-
-- :param dictionary: A pre-set dictionary for LZ77. Please use this with
-- caution: if a dictionary is used for compression, the same dictionary
-- **must** be used for decompression!
-- :type dictionary: ``bytes``
--
- :returns: The compressed bytestring.
- :rtype: ``bytes``
- """
-@@ -141,8 +135,7 @@ def compress(data,
- mode=mode,
- quality=quality,
- lgwin=lgwin,
-- lgblock=lgblock,
-- dictionary=dictionary
-+ lgblock=lgblock
- )
- compressed_data = compressor._compress(data, lib.BROTLI_OPERATION_FINISH)
- assert lib.BrotliEncoderIsFinished(compressor._encoder) == lib.BROTLI_TRUE
-@@ -255,8 +248,7 @@ def __init__(self,
- mode=DEFAULT_MODE,
- quality=lib.BROTLI_DEFAULT_QUALITY,
- lgwin=lib.BROTLI_DEFAULT_WINDOW,
-- lgblock=0,
-- dictionary=b''):
-+ lgblock=0):
- enc = lib.BrotliEncoderCreateInstance(
- ffi.NULL, ffi.NULL, ffi.NULL
- )
-@@ -271,13 +263,6 @@ def __init__(self,
- _set_parameter(enc, lib.BROTLI_PARAM_LGWIN, "lgwin", lgwin)
- _set_parameter(enc, lib.BROTLI_PARAM_LGBLOCK, "lgblock", lgblock)
-
-- if dictionary:
-- self._dictionary = ffi.new("uint8_t []", dictionary)
-- self._dictionary_size = len(dictionary)
-- lib.BrotliEncoderSetCustomDictionary(
-- enc, self._dictionary_size, self._dictionary
-- )
--
- self._encoder = enc
-
- def _compress(self, data, operation):
-diff --git a/src/brotlicffi/_build.py b/src/brotlicffi/_build.py
-index d2a2d85..45dccb6 100644
---- a/src/brotlicffi/_build.py
-+++ b/src/brotlicffi/_build.py
-@@ -93,20 +93,6 @@
- uint8_t** next_out,
- size_t* total_out);
-
-- /* Fills the new state with a dictionary for LZ77, warming up the
-- ringbuffer, e.g. for custom static dictionaries for data formats.
-- Not to be confused with the built-in transformable dictionary of Brotli.
-- |size| should be less or equal to 2^24 (16MiB), otherwise the dictionary
-- will be ignored. The dictionary must exist in memory until decoding is
-- done and is owned by the caller. To use:
-- 1) Allocate and initialize state with BrotliCreateInstance
-- 2) Use BrotliSetCustomDictionary
-- 3) Use BrotliDecompressStream
-- 4) Clean up and free state with BrotliDestroyState
-- */
-- void BrotliDecoderSetCustomDictionary(
-- BrotliDecoderState* s, size_t size, const uint8_t* dict);
--
- /* Returns true, if decoder has some unconsumed output.
- Otherwise returns false. */
- BROTLI_BOOL BrotliDecoderHasMoreOutput(const BrotliDecoderState* s);
-@@ -205,15 +191,6 @@
- BrotliEncoderParameter p,
- uint32_t value);
-
-- /* Fills the new state with a dictionary for LZ77, warming up the
-- ringbuffer, e.g. for custom static dictionaries for data formats.
-- Not to be confused with the built-in transformable dictionary of Brotli.
-- To decode, use BrotliSetCustomDictionary() of the decoder with the same
-- dictionary. */
-- void BrotliEncoderSetCustomDictionary(BrotliEncoderState* state,
-- size_t size,
-- const uint8_t* dict);
--
- /* Check if encoder is in "finished" state, i.e. no more input is
- acceptable and no more output will be produced.
- Works only with BrotliEncoderCompressStream workflow.
-diff --git a/test/test_simple_compression.py b/test/test_simple_compression.py
-index 45c322d..a480587 100644
---- a/test/test_simple_compression.py
-+++ b/test/test_simple_compression.py
-@@ -110,14 +110,6 @@ def test_compressed_data_roundtrips(s):
- assert brotlicffi.decompress(brotlicffi.compress(s)) == s
-
-
--@given(binary(), binary())
--def test_compressed_data_with_dictionaries(s, dictionary):
-- d = brotlicffi.Decompressor(dictionary)
-- compressed = brotlicffi.compress(s, dictionary=dictionary)
-- uncompressed = d.decompress(compressed)
-- assert uncompressed == s
--
--
- @given(binary())
- def test_process_alias(s):
- c1 = brotlicffi.Compressor()
diff --git a/profiles/package.mask b/profiles/package.mask
index 9a0e172d3ae2..88c103f30827 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -36,13 +36,12 @@
# Many reverse dependencies need to be ported due to changes in new glib
# Masking until they've been updated, see tracker bug for details
# bug #777675
-=dev-libs/gobject-introspection-common-2.68.0
-=dev-libs/gobject-introspection-2.68.0
+=dev-libs/gobject-introspection-common-1.68.0
+=dev-libs/gobject-introspection-1.68.0
=dev-util/gdbus-codegen-2.68.0
=dev-util/glib-utils-2.68.0
=dev-libs/glib-2.68.0
=net-libs/glib-networking-2.68.0
-=dev-python/pygobject2-2.68.0
# Marek Szuba <marecki@gentoo.org> (2021-03-19)
# Depends on bundled out-of-date Qt5 libraries, and even with those
diff --git a/sci-mathematics/singular/Manifest b/sci-mathematics/singular/Manifest
index 5cb78241d614..a0d12ebf4970 100644
--- a/sci-mathematics/singular/Manifest
+++ b/sci-mathematics/singular/Manifest
@@ -2,3 +2,4 @@ DIST singular-4.0.2-share.tar.gz 8789162 BLAKE2B 357a68f68cc0508e4e197427c56232d
DIST singular-4.0.2.tar.gz 8635172 BLAKE2B 5f565bf14677d8414300d7a5602aa96c8cef7e863fd858083fe4561742b545d74a5fc4de95ef0c63acf4f78c66405bac7ba77a954e42b2e87a6da608e4732bcd SHA512 4543a45839ce8adc45e3b2edd84a6e398b7ba157da1eda050dbce2a8b20333eb0c63433e3e7eaf59d76bf6bcb65c1b1611bfc08c25fd493c88e2f06624898e3d
DIST singular-4.0.3-share.tar.gz 6633256 BLAKE2B c137b72aaa0926eb006624e03fe938678acb94a41da525de1ca4f7711985d253926788b550d2d98b8def15fb0cb60b2527c1c04566a29a28135fcb1a70246025 SHA512 5f8ae4ecd22a3470e5f00393e03079936d7ed334f44ae056ed1eb1719054afc4371b03e920b598033605600c843dc39cb6b01308505323e2c084dfe1f7a1b94a
DIST singular-4.0.3.tar.gz 12615042 BLAKE2B b3c63434974bb8b5fdef86cbcbe73b76a47503b28dcae6bfc6e4210e1ab1c14224ac0f6eeefa9d8004450f6d9a26843368a9b2ea16bca68bf1215ce33e83df0d SHA512 781227997c510829b02c969259d627572c0b62aa152c9ef623ff27de5b2df0c8e024f086740b89ca8f96b6e3f7def04f8d62ca79adb199d6249ade9b8cbb06ab
+DIST singular-4.2.0p1.tar.gz 14155171 BLAKE2B 444553f87d7ca8d6a62e4519c9857a6892757e92285df7c3b686913a9b51c9ae8d802c41382b0b2b6e37dc2dc496d4a10f262c98407470219cdce131e8baf127 SHA512 2ecd8940c9e8d70a93dbdb4df6da313c00151e5cb959f8eed5856e8df99089b5a03e514fbcdc70903c77df8b59fa7ef9f3b134f1de510b795fa6ea0341089bd8
diff --git a/sci-mathematics/singular/files/singular-4.0.3-gfan_linking.patch b/sci-mathematics/singular/files/singular-4.0.3-gfan_linking.patch
new file mode 100644
index 000000000000..f228d980ffcf
--- /dev/null
+++ b/sci-mathematics/singular/files/singular-4.0.3-gfan_linking.patch
@@ -0,0 +1,13 @@
+diff --git a/gfanlib/Makefile.am b/gfanlib/Makefile.am
+index 2039af0..a1b7dce 100644
+--- a/gfanlib/Makefile.am
++++ b/gfanlib/Makefile.am
+@@ -20,6 +20,8 @@ libgfan_la_SOURCES = $(SOURCES)
+ libgfan_includedir =$(includedir)/gfanlib
+ libgfan_include_HEADERS = config.h gfanlib_mixedvolume.h gfanlib_polymakefile.h gfanlib_symmetry.h gfanlib_vector.h gfanlib_z.h _config.h gfanlib.h gfanlib_paralleltraverser.h gfanlib_q.h gfanlib_traversal.h gfanlib_zcone.h gfanlib_circuittableint.h gfanlib_matrix.h gfanlib_polyhedralfan.h gfanlib_symmetriccomplex.h gfanlib_tropicalhomotopy.h gfanlib_zfan.h
+
++libgfan_la_LIBADD = $(CDDGMPLDFLAGS)
++
+ DISTCLEANFILES = config.h
+
+ moduledir = $(libexecdir)/singular/MOD
diff --git a/sci-mathematics/singular/files/singular-4.1.3-doc_install.patch b/sci-mathematics/singular/files/singular-4.1.3-doc_install.patch
new file mode 100644
index 000000000000..10e831bea701
--- /dev/null
+++ b/sci-mathematics/singular/files/singular-4.1.3-doc_install.patch
@@ -0,0 +1,62 @@
+diff --git a/Makefile.am b/Makefile.am
+index c21b6ba..ea61758 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -14,10 +14,11 @@ dist-hook:
+
+ install-data-local:
+ if test -e $(srcdir)/doc/doc.tbz2; then\
+- (cat ${top_srcdir}/doc/doc.tbz2| (cd $(DESTDIR)$(datadir)/singular; tar jxf -));\
+ mkdir $(DESTDIR)$(datadir)/info;\
+- mkdir $(DESTDIR)$(datadir)/doc;\
+- mv $(DESTDIR)$(datadir)/singular/singular.hlp $(DESTDIR)$(datadir)/info/.;\
++ mkdir -p $(DESTDIR)$(docdir);\
++ (cat ${top_srcdir}/doc/doc.tbz2| (cd $(DESTDIR)$(docdir); tar -jx --no-same-owner -f -));\
++ mv $(DESTDIR)$(docdir)/singular.hlp $(DESTDIR)$(datadir)/info/.;\
++ @INSTALL_DATA@ doc/singular.idx $(DESTDIR)$(datadir)/singular/.;\
+ fi
+
+ uninstall-local:
+diff --git a/configure.ac b/configure.ac
+index 2d53a55..d43b5fe 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -248,6 +248,11 @@ AX_NORMALIZE_PATH([config_datadir],['/'])
+ AC_DEFINE_UNQUOTED([DATA_DIR],"$config_datadir",[datadir])
+ AC_SUBST(DATA_DIR, "$config_datadir")
+
++AX_RECURSIVE_EVAL([[$]docdir], [config_docdir])
++AX_NORMALIZE_PATH([config_docdir],['/'])
++AC_DEFINE_UNQUOTED([DOC_DIR],"$config_docdir",[docdir])
++AC_SUBST(DOC_DIR, "$config_docdir")
++
+ SING_SHOW_FLAGS([Compiler/linker flags: ])
+
+
+diff --git a/resources/configure.ac b/resources/configure.ac
+index cf6720f..ac5f2d0 100644
+--- a/resources/configure.ac
++++ b/resources/configure.ac
+@@ -72,5 +72,9 @@ AX_RECURSIVE_EVAL([[$]datadir], [config_datadir])
+ AX_NORMALIZE_PATH([config_datadir],['/'])
+ AC_DEFINE_UNQUOTED([DATA_DIR],"$config_datadir",[datadir])
+
++AX_RECURSIVE_EVAL([[$]htmldir], [config_htmldir])
++AX_NORMALIZE_PATH([config_htmldir],['/'])
++AC_DEFINE_UNQUOTED([HTML_DIR],"$config_datadir",[htmldir])
++
+ AC_CONFIG_FILES([singular_resources.pc Makefile])
+ AC_OUTPUT
+diff --git a/resources/feResource.cc b/resources/feResource.cc
+index 3d75bc9..7e4fc8c 100644
+--- a/resources/feResource.cc
++++ b/resources/feResource.cc
+@@ -85,7 +85,7 @@ VAR feResourceConfig_s feResourceConfigs[] =
+ {"DefaultDir",'d', feResDir, "SINGULAR_DEFAULT_DIR", SINGULAR_DEFAULT_DIR, (char *)""},
+ {"InfoFile", 'i', feResFile, "SINGULAR_INFO_FILE", "%D/info/singular.hlp", (char *)""},
+ {"IdxFile", 'x', feResFile, "SINGULAR_IDX_FILE", "%D/singular/singular.idx", (char *)""},
+- {"HtmlDir", 'h', feResDir, "SINGULAR_HTML_DIR", "%D/singular/html", (char *)""},
++ {"HtmlDir", 'h', feResDir, "SINGULAR_HTML_DIR", HTML_DIR, (char *)""},
+ {"ManualUrl", 'u', feResUrl, "SINGULAR_URL", "https://www.singular.uni-kl.de/Manual/", (char *)""},
+ {"ExDir", 'm', feResDir, "SINGULAR_EXAMPLES_DIR","%r/examples", (char *)""},
+ {"Path", 'p', feResPath, NULL, "%b;%P;$PATH", (char *)""},
diff --git a/sci-mathematics/singular/files/singular-4.2.0-no-static.patch b/sci-mathematics/singular/files/singular-4.2.0-no-static.patch
new file mode 100644
index 000000000000..5509c58bd6b6
--- /dev/null
+++ b/sci-mathematics/singular/files/singular-4.2.0-no-static.patch
@@ -0,0 +1,69 @@
+From ef9d66230f9697caaa77dbfc275650412d0d9c0d Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Mon, 22 Mar 2021 09:02:58 -0400
+Subject: [PATCH 1/1] Singular/Makefile.am: drop -static linker flags.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+There are a few hard-coded "-static" flags in the Makefile.am for
+Singular that are causing weird problems for shared builds. The
+visible symptom on Gentoo was a few insecure rpaths being stripped
+from the "Singular" executable, but François Bissey was able to track
+down the root cause, namely the "-static" that is causing libtool to
+act weird.
+
+In retrospect, this problem was also reported on Stack Overflow at,
+
+ https://stackoverflow.com/questions/17905121
+
+The Gentoo bug is,
+
+ https://bugs.gentoo.org/712004
+
+If we experience no problems with this patch, it will be sent upstream.
+---
+ Singular/Makefile.am | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/Singular/Makefile.am b/Singular/Makefile.am
+index 7fe43bffb..1e440765d 100644
+--- a/Singular/Makefile.am
++++ b/Singular/Makefile.am
+@@ -153,7 +153,7 @@ Singular_SOURCES = tesths.cc fegetopt.c fegetopt.h utils.cc utils.h
+
+ Singular_LDADD = libSingular.la ${OMALLOC_LIBS} ${BUILTIN_FLAGS}
+
+-Singular_LDFLAGS = -static ${AM_LDFLAGS} ${BUILTIN_FLAGS}
++Singular_LDFLAGS = ${AM_LDFLAGS} ${BUILTIN_FLAGS}
+
+ Singulard_SOURCES = tesths.cc fegetopt.c fegetopt.h utils.cc utils.h
+
+@@ -166,7 +166,6 @@ dist_script_SCRIPTS = singularsurf singularsurf_jupyter singularsurf_win surfex
+
+ #### ESingular
+ ESingular_CPPFLAGS = ${AM_CPPFLAGS} -DESINGULAR -DPROTO
+-# ESingular_LDFLAGS = -static ${AM_LDFLAGS}
+ ESingular_LDADD = ${top_builddir}/libpolys/reporter/libreporter.la \
+ ${top_builddir}/libpolys/misc/libmisc.la ${OMALLOC_LIBS} \
+ ${top_builddir}/resources/libsingular_resources.la
+@@ -176,7 +175,6 @@ ESingular_SOURCES = emacs.cc fegetopt.c fegetopt.h feOptES.inc feOpt.cc
+
+ #### same for TSingular
+ TSingular_CPPFLAGS = ${AM_CPPFLAGS} -DTSINGULAR -DPROTO
+-# TSingular_LDFLAGS = -static ${AM_LDFLAGS}
+ TSingular_LDADD = ${top_builddir}/libpolys/reporter/libreporter.la \
+ ${top_builddir}/libpolys/misc/libmisc.la ${OMALLOC_LIBS} \
+ ${top_builddir}/resources/libsingular_resources.la
+@@ -191,7 +189,7 @@ libparse_CPPFLAGS = ${AM_CPPFLAGS} -DSTANDALONE_PARSER
+ libparse_SOURCES = libparse.cc fegetopt.c fegetopt.h utils.cc utils.h
+
+ libparse_LDADD =
+-libparse_LDFLAGS = -static ${AM_LDFLAGS}
++libparse_LDFLAGS = ${AM_LDFLAGS}
+
+ #########################################################
+ # the Singular library (*.lib files)
+--
+2.26.2
+
diff --git a/sci-mathematics/singular/singular-4.2.0_p1.ebuild b/sci-mathematics/singular/singular-4.2.0_p1.ebuild
new file mode 100644
index 000000000000..b015ba5fee61
--- /dev/null
+++ b/sci-mathematics/singular/singular-4.2.0_p1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools elisp-common
+
+MY_PN=Singular
+MY_PV=$(ver_rs 3 '')
+# Consistency is different...
+MY_DIR2=$(ver_cut 1-3 ${PV})
+MY_DIR=$(ver_rs 1- '-' ${MY_DIR2})
+
+DESCRIPTION="Computer algebra system for polynomial computations"
+HOMEPAGE="https://www.singular.uni-kl.de/ https://github.com/Singular/Sources"
+SRC_URI="ftp://jim.mathematik.uni-kl.de/pub/Math/${MY_PN}/SOURCES/${MY_DIR}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="BSD GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux"
+IUSE="emacs examples +readline static-libs"
+
+RDEPEND="dev-libs/gmp:0
+ dev-libs/ntl:=
+ emacs? ( >=app-editors/emacs-23.1:* )
+ sci-mathematics/flint
+ sci-libs/cddlib
+ dev-lang/perl
+ readline? ( sys-libs/readline )"
+
+DEPEND="${RDEPEND}"
+
+SITEFILE=60${PN}-gentoo.el
+
+S="${WORKDIR}/${PN}-${MY_DIR2}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.0.3-gfan_linking.patch"
+ "${FILESDIR}/${PN}-4.1.3-doc_install.patch"
+ "${FILESDIR}/${PN}-4.2.0-no-static.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-gmp \
+ --with-ntl="${EPREFIX}"/usr \
+ --with-flint \
+ --enable-gfanlib \
+ --disable-debug \
+ --disable-doc \
+ --enable-factory \
+ --enable-libfac \
+ --enable-IntegerProgramming \
+ --disable-polymake \
+ $(use_enable static-libs static) \
+ $(use_enable emacs) \
+ $(use_with readline)
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ pushd "${S}"/emacs
+ elisp-compile *.el || die "elisp-compile failed"
+ popd
+ fi
+}
+
+src_install() {
+ # Do not compress singular's info file (singular.hlp)
+ # some consumer of that file do not know how to deal with compression
+ docompress -x /usr/share/info
+
+ default
+
+ dosym Singular /usr/bin/"${PN}"
+
+ # purge .la file
+ find "${ED}" -name '*.la' -delete || die
+}
+
+src_test() {
+ # SINGULAR_PROCS_DIR need to be set to "" otherwise plugins from
+ # an already installed version of singular may be used and cause segfault
+ # See https://github.com/Singular/Sources/issues/980
+ SINGULAR_PROCS_DIR="" emake check
+}
+
+pkg_postinst() {
+ einfo "Additional functionality can be enabled by installing"
+ einfo "sci-mathematics/4ti2"
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sys-fs/reiser4progs/Manifest b/sys-fs/reiser4progs/Manifest
index 026e6cbab414..5c563f333b4a 100644
--- a/sys-fs/reiser4progs/Manifest
+++ b/sys-fs/reiser4progs/Manifest
@@ -1,3 +1,3 @@
DIST reiser4progs-1.2.1.tar.gz 980203 BLAKE2B 8c9cb77458c083c50f34c17bddf4747b755b52b911a63835152ad584494c2738a5317c28e5b3f1e6bfdc49416f3715ca4fbbd9c8a428b5b484b54f8f4a861a58 SHA512 2caac5a98d672d68910c6df3e694a42365fa6273ae367c26126778c1fbe956aa502dac236d36c3302a5bf109468ad3447e645a6eab89c83f122dd1afe2aeda21
-DIST reiser4progs-2.0.3.tar.gz 995921 BLAKE2B fa38c8998603ca0c26a17c75240d07afec6c46da1b437e5a733ce3a5a865329591d4343b52d7fd5dc56bb6afe34f4f7685e7dc258ed075dfe4a70a7ad420324a SHA512 59bcd6d73a220fd0e71cc4213489801f45597ebfcf0be55f150e929ef391e0a461a94ab99ee9698e1fb1eb58840497277ece6a2ea57e88d54573347a8854da87
DIST reiser4progs-2.0.4.tar.gz 997361 BLAKE2B 3d083c2c702f6c469403447bd2bb59257c22a6f87e062b83227c97147c37e69f93f1ffb6a1ea2c9f23f94a5ac8fcb834da475893c9bd268fc8902e6af2af4c10 SHA512 222eaa69f89fa1cfad2b5791af028560fb6e57e44fbb5e025122c25b50dd4aea28a8fd362818a884fa6b3d6164e5b0c78ab63f0649e2e65780f1aee2c0d26375
+DIST reiser4progs-2.0.5.tar.gz 997516 BLAKE2B 38799bd2161ac3ad631b3f11f4f01f647fa8210786fa4aeb290a84dac95080cdf979be1cb4526abf08567e88f25aad54a3d776be85900e702a7325e674ddd0e1 SHA512 1e1f263828bd5f44837bcbdde072a94b2cc5a099dbf52d3e0f7f6851812fb2e8b77a3edcf5448f678304e23240c63919547a9671d36b816f97f989b17b494d27
diff --git a/sys-fs/reiser4progs/reiser4progs-2.0.3.ebuild b/sys-fs/reiser4progs/reiser4progs-2.0.5.ebuild
index 45ddbfaabf1c..2381c45ae855 100644
--- a/sys-fs/reiser4progs/reiser4progs-2.0.3.ebuild
+++ b/sys-fs/reiser4progs/reiser4progs-2.0.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
diff --git a/x11-misc/py3status/Manifest b/x11-misc/py3status/Manifest
index ee7b54eef29d..e33803b2a6fb 100644
--- a/x11-misc/py3status/Manifest
+++ b/x11-misc/py3status/Manifest
@@ -1 +1 @@
-DIST py3status-3.34.tar.gz 409041 BLAKE2B 2322eedfc37c993f58b2dc45b14a3cb0167e139b0d62fe17de6fdcdd170bda826208b7462e45776b3a42c53a3c4dbee84175c1bf5551bb46fcf1f7b65edfd3c4 SHA512 a018c698ea11fb7a2f150833c13b9eec97c04db023646381f346c9d8f4873f8526dd0696d11ae93eaada3364e041d614a23b59d250b4e3e8fa83303634fce54a
+DIST py3status-3.35.tar.gz 409496 BLAKE2B 5d527846cc4acf5b341b33ed1726165e5f09c7fa59dbda61e4526fadc8151831f8a9c977c60c5f84b37073705448e9258e9311638e8ca929c3d93452cecf8627 SHA512 d2f120818d7d7e100b93d355096cd985c933d9859539a7ffb32ca5830d034617851cfdfbdd2c472f931d30f17e178b134f05a503219a126f8fbf0e920b263157
diff --git a/x11-misc/py3status/py3status-3.34.ebuild b/x11-misc/py3status/py3status-3.35.ebuild
index 249cd9474c6a..249cd9474c6a 100644
--- a/x11-misc/py3status/py3status-3.34.ebuild
+++ b/x11-misc/py3status/py3status-3.35.ebuild