summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-06 09:41:10 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-06 09:47:45 +0200
commitf2a2350027901312cf108e1a9faee76c909bf58a (patch)
treeee65f464880395ed93b3e426fc5387b93ec3485e
parentdev-python/fastbencode: Backport py3.12 fix (diff)
downloadgentoo-f2a2350027901312cf108e1a9faee76c909bf58a.tar.gz
gentoo-f2a2350027901312cf108e1a9faee76c909bf58a.tar.bz2
gentoo-f2a2350027901312cf108e1a9faee76c909bf58a.zip
dev-python/frozenlist: Fix testing the C extension
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/frozenlist/frozenlist-1.4.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/frozenlist/frozenlist-1.4.0.ebuild b/dev-python/frozenlist/frozenlist-1.4.0.ebuild
index f17293f2b4e2..21355bc2d995 100644
--- a/dev-python/frozenlist/frozenlist-1.4.0.ebuild
+++ b/dev-python/frozenlist/frozenlist-1.4.0.ebuild
@@ -43,3 +43,9 @@ python_configure() {
emake cythonize
fi
}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf frozenlist || die
+ epytest
+}