summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-05 06:38:18 +0100
committerSam James <sam@gentoo.org>2023-05-05 06:38:18 +0100
commitf4e53ae2fdef064d2bc47caf44b5173639babdc1 (patch)
treec0ce81f2d3c55af9cfc04c5d70f2b70c55579323
parentdev-python/django-debug-toolbar: Bump to 4.0.0 (diff)
downloadgentoo-f4e53ae2fdef064d2bc47caf44b5173639babdc1.tar.gz
gentoo-f4e53ae2fdef064d2bc47caf44b5173639babdc1.tar.bz2
gentoo-f4e53ae2fdef064d2bc47caf44b5173639babdc1.zip
media-libs/codec2: add 1.1.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/codec2/Manifest1
-rw-r--r--media-libs/codec2/codec2-1.1.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/codec2/Manifest b/media-libs/codec2/Manifest
index d40ab70c9147..74dd6f0839b4 100644
--- a/media-libs/codec2/Manifest
+++ b/media-libs/codec2/Manifest
@@ -1 +1,2 @@
DIST codec2-1.0.5.tar.gz 14786826 BLAKE2B f5be917c1a76f47f386b7fe2a58872e4c660bcfe477e11dfa6880ff71f29dca79c35612f0b0537ec54e7f8db9e24c56088c90c021e67e99b373b1de75f434ff4 SHA512 692feea8ff99430a7ed8efa5bf48a633dc9689b1f39009cf1f907315e600da26ea3787a994b51d7ca9d4cbc8b8c9b26f89031af899f114fa130f0703266a6b17
+DIST codec2-1.1.0.tar.gz 14925316 BLAKE2B 7f99dfa5704c5b7df3efbb0cf5aeafe8d66e294f622dfa639ffe6ebe8b32b347a1632113763d6a3693a1f04451c3a5ff54592bda8cffa2d281847b775c62a561 SHA512 efc0f31b1a265c7acf38ab1c6c856f7a3cce58acec6c214d94cf9cd560efdca08859b317b396efb286176b0e235b2256080c8a2f83695424454b744275d1c661
diff --git a/media-libs/codec2/codec2-1.1.0.ebuild b/media-libs/codec2/codec2-1.1.0.ebuild
new file mode 100644
index 000000000000..7b8c5a0bc64b
--- /dev/null
+++ b/media-libs/codec2/codec2-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Low bit rate speech codec"
+HOMEPAGE="https://freedv.org/ https://www.rowetel.com/?page_id=452 https://github.com/drowe67/codec2"
+SRC_URI="https://github.com/drowe67/codec2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples test"
+
+# Not yet passing, but infrastructure added to run
+# Needs Octave dependencies like "signal"?
+# https://github.com/drowe67/codec2/commit/9a129f1b3ad12ecbf3df7f4460f496ee11e49c08#diff-b335630551682c19a781afebcf4d07bf978fb1f8ac04c6bf87428ed5106870f5R155
+RESTRICT="test"
+
+#BDEPEND="test? ( sci-mathematics/octave )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ # tries to look for octave during configure phase if unit
+ # tests are turned on and bails out during configure if it
+ # cannot find it. since we have test dependency disabled
+ # for now, don't flip this configure flag
+ # -DUNITTEST=$(usex test) # reenable once tests wired up
+ -DUNITTEST=OFF
+ -DINSTALL_EXAMPLES=$(usex examples)
+ )
+
+ cmake_src_configure
+}