summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-10-27 13:18:24 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-10-27 13:18:24 +0000
commitf8d9b2f8aefb9c8045df11e2cbf2b69f1a91d452 (patch)
tree1c76f75a86f410a99f2ec1bfdb57824cc0aefd69
parent2024-10-27 13:03:30 UTC (diff)
parentsci-libs/tokenizers: drop other network tests (diff)
downloadgentoo-f8d9b2f8aefb9c8045df11e2cbf2b69f1a91d452.tar.gz
gentoo-f8d9b2f8aefb9c8045df11e2cbf2b69f1a91d452.tar.bz2
gentoo-f8d9b2f8aefb9c8045df11e2cbf2b69f1a91d452.zip
Merge updates from master
-rw-r--r--dev-python/et-xmlfile/et-xmlfile-2.0.0.ebuild3
-rw-r--r--sci-libs/tokenizers/tokenizers-0.20.1.ebuild23
2 files changed, 15 insertions, 11 deletions
diff --git a/dev-python/et-xmlfile/et-xmlfile-2.0.0.ebuild b/dev-python/et-xmlfile/et-xmlfile-2.0.0.ebuild
index 65cbad44ccf3..c02b0a91bd4d 100644
--- a/dev-python/et-xmlfile/et-xmlfile-2.0.0.ebuild
+++ b/dev-python/et-xmlfile/et-xmlfile-2.0.0.ebuild
@@ -31,4 +31,5 @@ RDEPEND="
"
distutils_enable_tests pytest
-distutils_enable_sphinx doc
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
diff --git a/sci-libs/tokenizers/tokenizers-0.20.1.ebuild b/sci-libs/tokenizers/tokenizers-0.20.1.ebuild
index f2172b1cfd5a..f5e839834cd8 100644
--- a/sci-libs/tokenizers/tokenizers-0.20.1.ebuild
+++ b/sci-libs/tokenizers/tokenizers-0.20.1.ebuild
@@ -325,7 +325,6 @@ src_test() {
cd ../bindings/python
local EPYTEST_DESELECT=(
"tests/bindings/test_tokenizer.py::TestTokenizer::test_encode_formats"
- "tests/documentation/test_tutorial_train_from_iterators.py::TestTrainFromIterators::test_datasets"
"tests/bindings/test_encoding.py::TestEncoding::test_sequence_ids"
"tests/bindings/test_encoding.py::TestEncoding::test_n_sequences"
"tests/bindings/test_encoding.py::TestEncoding::test_word_to_tokens"
@@ -339,28 +338,32 @@ src_test() {
"tests/bindings/test_encoding.py::TestEncoding::test_invalid_truncate_direction"
"tests/bindings/test_models.py::TestBPE::test_instantiate"
"tests/bindings/test_models.py::TestWordLevel::test_instantiate"
+ "tests/bindings/test_models.py::TestWordPiece::test_instantiate"
"tests/bindings/test_processors.py::TestByteLevelProcessing::test_processing"
- "tests/bindings/test_trainers.py::TestUnigram::test_train"
- "tests/documentation/test_pipeline.py::TestPipeline::test_pipeline"
- "tests/documentation/test_pipeline.py::TestPipeline::test_bert_example"
- "tests/implementations/test_char_bpe.py::TestCharBPETokenizer::test_basic_encode"
- "tests/implementations/test_char_bpe.py::TestCharBPETokenizer::test_lowercase"
- "tests/implementations/test_char_bpe.py::TestCharBPETokenizer::test_decoding"
- "tests/implementations/test_char_bpe.py::TestCharBPETokenizer::test_multiprocessing_with_parallelism"
- "tests/test_serialization.py::TestSerialization::test_full_serialization_albert"
- "tests/test_serialization.py::TestSerialization::test_str_big"
"tests/bindings/test_tokenizer.py::TestTokenizer::test_encode_add_special_tokens"
"tests/bindings/test_tokenizer.py::TestTokenizer::test_from_pretrained"
"tests/bindings/test_tokenizer.py::TestTokenizer::test_from_pretrained_revision"
"tests/bindings/test_tokenizer.py::TestTokenizer::test_encode_special_tokens"
"tests/bindings/test_tokenizer.py::TestTokenizer::test_splitting"
+ "tests/bindings/test_trainers.py::TestUnigram::test_continuing_prefix_trainer_mistmatch"
+ "tests/bindings/test_trainers.py::TestUnigram::test_train"
+ "tests/documentation/test_pipeline.py::TestPipeline::test_pipeline"
+ "tests/documentation/test_pipeline.py::TestPipeline::test_bert_example"
"tests/documentation/test_quicktour.py::TestQuicktour::test_quicktour"
+ "tests/documentation/test_tutorial_train_from_iterators.py::TestTrainFromIterators::test_datasets"
+ "tests/documentation/test_tutorial_train_from_iterators.py::TestTrainFromIterators::test_gzip"
"tests/implementations/test_bert_wordpiece.py::TestBertWordPieceTokenizer::test_basic_encode"
"tests/implementations/test_bert_wordpiece.py::TestBertWordPieceTokenizer::test_multiprocessing_with_parallelism"
"tests/implementations/test_byte_level_bpe.py::TestByteLevelBPE::test_basic_encode"
"tests/implementations/test_byte_level_bpe.py::TestByteLevelBPE::test_add_prefix_space"
"tests/implementations/test_byte_level_bpe.py::TestByteLevelBPE::test_lowerspace"
"tests/implementations/test_byte_level_bpe.py::TestByteLevelBPE::test_multiprocessing_with_parallelism"
+ "tests/implementations/test_char_bpe.py::TestCharBPETokenizer::test_basic_encode"
+ "tests/implementations/test_char_bpe.py::TestCharBPETokenizer::test_lowercase"
+ "tests/implementations/test_char_bpe.py::TestCharBPETokenizer::test_decoding"
+ "tests/implementations/test_char_bpe.py::TestCharBPETokenizer::test_multiprocessing_with_parallelism"
+ "tests/test_serialization.py::TestSerialization::test_full_serialization_albert"
+ "tests/test_serialization.py::TestSerialization::test_str_big"
)
local -x EPYTEST_IGNORE=(benches/)
distutils-r1_src_test