summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-15 08:49:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-15 13:32:31 +0200
commite5dd321ce2a592319a566408055961bee35e96d6 (patch)
tree71f4011efffef558ad2b7626f5a1911f97e85ca8 /app-admin/awscli
parentdev-python/boto3: Bump to 1.24.9 (diff)
downloadgentoo-e5dd321ce2a592319a566408055961bee35e96d6.tar.gz
gentoo-e5dd321ce2a592319a566408055961bee35e96d6.tar.bz2
gentoo-e5dd321ce2a592319a566408055961bee35e96d6.zip
app-admin/awscli: Bump to 1.25.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.9.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 1fa6632981b2..08e0dfab945b 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -6,3 +6,4 @@ DIST aws-cli-1.25.5.gh.tar.gz 2222976 BLAKE2B a726ed1ca6eb8172972c53c1418e342fa8
DIST aws-cli-1.25.6.gh.tar.gz 2223055 BLAKE2B e6e16b3b67110ed185bb94e2d56cef9445b32373e92136bde53f63bb94ff7b1e8749f33b022203ba113fde676aa086ab96b409dde7e4c48cbe5512cd9f3bd65e SHA512 c0f7b27583ce774a34467f6af0796ec4c7252d9babfda6e7a484252d2de417686194b1e7b4dffc6d8545b2126f1b55288703473153f3339656e9e7a350d143d0
DIST aws-cli-1.25.7.gh.tar.gz 2223153 BLAKE2B fcadda94fd721135f94b1538c4b27e41108064f6fd32f324d5436138e3d1b0ffcab53fcc545b01c461365d55c4bfa2a05d90e94c875c929a3227efae76452415 SHA512 194adacab0df87d8e4f0cdc71bb956bef6dc8b2de2e7e4416c9c079ff2b7c2bce7584ac1049428d0bcb134368b39c37c04bc5e6a8fc7540c44c64f3934ccaf21
DIST aws-cli-1.25.8.gh.tar.gz 2223378 BLAKE2B 0b7db8cf2e59f8e39929d3257e1008be082f0b5c0e5968c3a5ac8bacbfbe891fd65b1e9fe72e2058b6780b20839e9713636577c77f0efef47aeee187d30bdea7 SHA512 280018f5549c2f6240f8ebd06c82df47fd700b54075a57b21ec09403a0efc2ef039f9bacd3b3035405d29d3c4259a55ad2b8a5761e291abb3768eea6c1f8e3aa
+DIST aws-cli-1.25.9.gh.tar.gz 2223335 BLAKE2B 995c4474bde347593b61b6f8b11ed39a71e63789b2d061e08bbabcf1c1645c9ec46e73b2c58124642fa6bd194d68e81ac43eeb013b27d297d5dbbbcf34ee1cf9 SHA512 5afdabfb5a479e84c7bf302b3b93a3350100afd371270f9884848c57e7f3e48ddf8aa810db217160835d8594cbd6e2c929c86eead213bedb0246aa2145ba3806
diff --git a/app-admin/awscli/awscli-1.25.9.ebuild b/app-admin/awscli/awscli-1.25.9.ebuild
new file mode 100644
index 000000000000..4154af977ee6
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.9.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}