summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2022-07-17 15:43:29 +0200
committerAgostino Sarubbo <ago@gentoo.org>2022-07-17 15:43:29 +0200
commit05f32d96cfbc658af2f14287f52c5416fa3151c1 (patch)
treeb4d18386252945900e61be6c295fb48838dadc06 /app-admin/exo
parentsys-apps/hwinfo: add 21.82 (diff)
downloadgentoo-05f32d96cfbc658af2f14287f52c5416fa3151c1.tar.gz
gentoo-05f32d96cfbc658af2f14287f52c5416fa3151c1.tar.bz2
gentoo-05f32d96cfbc658af2f14287f52c5416fa3151c1.zip
app-admin/exo: version bump to 1.58.0
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin/exo')
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.58.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index 112a7b5b5104..b0dcc706505d 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.57.0.tar.gz 5604952 BLAKE2B c994b5f8c80985abab21d640195b4c91c7434a28f04e14773402fcf028a2ff83d4d6cf4b0654ba3e4d2db2fb6a82e8cd047ca51ecfaad003aa5e8d8b4b746e33 SHA512 46e64257d865e4b2d6211e587a976ac8ce04de897884ed97b978356051d366820029df8547ad65d0b98bee422da15dbe48373079161e4c2157b58b439097a0ac
+DIST exo-1.58.0.tar.gz 5609630 BLAKE2B 266820bd6e51aeaf1bde21b3ecea42e5e7242ffd8b96c60b73316ab938d07764e14e387271f24bb1e71c0692eea11a97deb45e76dfc66a5db82b46a60362bf8a SHA512 5032549d98f9eb9e411387667fe64a75b7ff4f5d830047ebae1cfada2b684fa108e5b945472347d3297f45ef0b2b87baf38750f8f9814cc60af6d08584fce0a3
diff --git a/app-admin/exo/exo-1.58.0.ebuild b/app-admin/exo/exo-1.58.0.ebuild
new file mode 100644
index 000000000000..6149acedfa18
--- /dev/null
+++ b/app-admin/exo/exo-1.58.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}